Dtrain Hsu has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/39020 )
Change subject: mb/google/drallion: Remove MAC address pass through
......................................................................
mb/google/drallion: Remove MAC address pass through
Remove MAC address pass through because when MAC address pass through setting
change to "Use dock built-in MAC address", the MAC address always keeps the VPD
value.
BUG=b:147994020
TEST=tested on drallion and the result as below.
(Option) (Result)
- Use pre-assigned MAC address : Pass
- Use Chromebook built-in address : Pass
- Use dock built-in MAC address : Pass
Signed-off-by: Dtrain Hsu <dtrain_hsu(a)compal.corp-partner.google.com>
Change-Id: I1f58e98187feb4e428ca75f7e82c464567528526
---
M src/mainboard/google/drallion/dsdt.asl
1 file changed, 0 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/20/39020/1
diff --git a/src/mainboard/google/drallion/dsdt.asl b/src/mainboard/google/drallion/dsdt.asl
index ee63d6e..33ede7a 100644
--- a/src/mainboard/google/drallion/dsdt.asl
+++ b/src/mainboard/google/drallion/dsdt.asl
@@ -48,8 +48,6 @@
#include <vendorcode/google/chromeos/acpi/chromeos.asl>
/* VPD support */
#include <vendorcode/google/chromeos/acpi/vpd.asl>
- /* MAC address passthru */
- #include <vendorcode/google/chromeos/acpi/amac.asl>
#endif
#include <southbridge/intel/common/acpi/sleepstates.asl>
--
To view, visit https://review.coreboot.org/c/coreboot/+/39020
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I1f58e98187feb4e428ca75f7e82c464567528526
Gerrit-Change-Number: 39020
Gerrit-PatchSet: 1
Gerrit-Owner: Dtrain Hsu <dtrain_hsu(a)compal.corp-partner.google.com>
Gerrit-MessageType: newchange
Patrick Georgi has removed Ron Minnich from this change. ( https://review.coreboot.org/c/SerialTest/+/39083 )
Change subject: Add rough approximation of SerialTest scaffold
......................................................................
Removed reviewer Ron Minnich.
--
To view, visit https://review.coreboot.org/c/SerialTest/+/39083
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: SerialTest
Gerrit-Branch: master
Gerrit-Change-Id: Iab8d507dee6087bf32280ad6845fdd2d7715bf5c
Gerrit-Change-Number: 39083
Gerrit-PatchSet: 5
Gerrit-Owner: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Dossym Nurmukhanov <dossym(a)google.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-MessageType: deleteReviewer
Paul Menzel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39095 )
Change subject: superio/aspeed/ast2400: rename SWAK to SWC to match the datasheet
......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/c/coreboot/+/39095/1/src/superio/aspeed/ast2400…
File src/superio/aspeed/ast2400/ast2400.h:
https://review.coreboot.org/c/coreboot/+/39095/1/src/superio/aspeed/ast2400…
PS1, Line 9: #define AST2400_SWC 0x4 /* System Wake-Up control */
Keep SWAK in the comment?
--
To view, visit https://review.coreboot.org/c/coreboot/+/39095
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I8b3a14946e37f805d1c4e3df343dfcd7f67f6dc8
Gerrit-Change-Number: 39095
Gerrit-PatchSet: 1
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Frans Hendriks <fhendriks(a)eltan.com>
Gerrit-Reviewer: Michael Niewöhner
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Mon, 24 Feb 2020 11:23:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39092 )
Change subject: mb/supermicro/x11-lga1151-series: devicetree: fix iLPC2AHB irq
......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/c/coreboot/+/39092/1/src/mainboard/supermicro/x…
File src/mainboard/supermicro/x11-lga1151-series/variants/x11ssm-f/overridetree.cb:
https://review.coreboot.org/c/coreboot/+/39092/1/src/mainboard/supermicro/x…
PS1, Line 109: irq 0x70 = 0x0
> not GPIO but Mailbox
I couldn't find a reference in the Aspeed datasheet that "0" means disable and INT0 is assigned to the system timer.
--
To view, visit https://review.coreboot.org/c/coreboot/+/39092
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Idc1cd04e995d68f4c779e9aa9c09bb7bf9f26363
Gerrit-Change-Number: 39092
Gerrit-PatchSet: 1
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Michael Niewöhner
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Comment-Date: Mon, 24 Feb 2020 09:13:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Michael Niewöhner
Comment-In-Reply-To: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-MessageType: comment