Angel Pons has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/47680 )
Change subject: nb/intel/sandybridge: Restore nominal Vref for current channel
......................................................................
nb/intel/sandybridge: Restore nominal Vref for current channel
After aggressive read training, program nominal Vref for the current
channel, not only channel 0. This simple mistake can easily degrade
memory margins, especially when running at high speed (overclocking).
Tested on Asus P8H61-M PRO, still boots.
Change-Id: I12630fe33c5c786c8ec131c45c27180c3887d354
Signed-off-by: Angel Pons <th3fanbus(a)gmail.com>
---
M src/northbridge/intel/sandybridge/raminit_common.c
1 file changed, 2 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/80/47680/1
diff --git a/src/northbridge/intel/sandybridge/raminit_common.c b/src/northbridge/intel/sandybridge/raminit_common.c
index d60271b..7e93786 100644
--- a/src/northbridge/intel/sandybridge/raminit_common.c
+++ b/src/northbridge/intel/sandybridge/raminit_common.c
@@ -2368,7 +2368,8 @@
}
}
- MCHBAR32(GDCRTRAININGMOD_ch(0)) = 0;
+ /* Restore nominal Vref after training */
+ MCHBAR32(GDCRTRAININGMOD_ch(channel)) = 0;
printram("CPA\n");
return 0;
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/47680
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I12630fe33c5c786c8ec131c45c27180c3887d354
Gerrit-Change-Number: 47680
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-MessageType: newchange
Duncan Laurie has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/47478 )
Change subject: mb/google/volteer: Add keyboard layout to fw_config
......................................................................
mb/google/volteer: Add keyboard layout to fw_config
A new field was defined for different keyboard layouts, so add this field
to the list and provide the two options that were defined.
Change-Id: Ic357446725e34221040705929d54cbce94c5ab8b
Signed-off-by: Duncan Laurie <dlaurie(a)google.com>
---
M src/mainboard/google/volteer/variants/baseboard/devicetree.cb
1 file changed, 4 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/78/47478/1
diff --git a/src/mainboard/google/volteer/variants/baseboard/devicetree.cb b/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
index a73d4ad..4d615c8 100644
--- a/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
+++ b/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
@@ -37,6 +37,10 @@
option SD_GL9755S 1
option SD_RTS5261 2
end
+ field KB_LAYOUT 20 21
+ option KB_LAYOUT_DEFAULT 0
+ option KB_LAYOUT_1 1
+ end
end
chip soc/intel/tigerlake
--
To view, visit https://review.coreboot.org/c/coreboot/+/47478
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic357446725e34221040705929d54cbce94c5ab8b
Gerrit-Change-Number: 47478
Gerrit-PatchSet: 1
Gerrit-Owner: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-MessageType: newchange
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/47726 )
Change subject: soc/amd/picasso: Add data fabric read helper function
......................................................................
Patch Set 2:
(7 comments)
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/data_f…
File src/soc/amd/picasso/data_fabric.c:
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/data_f…
PS2, Line 17: pci_write_config32(SOC_DF_F0_DEV, NB_MMIO_CONTROL(reg),
: IOMS0_FABRIC_ID << MMIO_DST_FABRIC_ID_SHIFT);
: pci_write_config32(SOC_DF_F0_DEV, NB_MMIO_BASE(reg), 0);
: pci_write_config32(SOC_DF_F0_DEV, NB_MMIO_LIMIT(reg), 0);
out of scope for this patch, but having a data_fabric_write_reg32() might make this code and the code below easier to read
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/data_f…
PS2, Line 25: pci_read_config32(SOC_DF_F0_DEV, NB_MMIO_CONTROL(reg));
this could be rewritten to use data_fabric_read_reg32(). I'm ok with doing that in a separate patch to not block this and the ACPI CRAT one
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/data_f…
PS2, Line 176: return pci_read_config32(_SOC_DEV(DF_DEV, function), reg);
it might be useful to add a comment that the macros will apply a bit mask to the values, so no bit masking is required here
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/data_f…
PS2, Line 181: reg
reg is the byte address and the two last bits get masked off, since the access is always dword/qword based, right?
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/includ…
File src/soc/amd/picasso/include/soc/data_fabric.h:
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/includ…
PS2, Line 28: #define D18F0_DRAM_HOLE_CTL 0x104
: #define DRAM_HOLE_CTL_VALID BIT(0)
: #define DRAM_HOLE_CTL_BASE_SHFT 24
: #define DRAM_HOLE_CTL_BASE (0xFF << DRAM_HOLE_CTL_BASE_SHFT)
:
: #define D18F0_DRAM_BASE0 0x110
: #define DRAM_BASE_REG_VALID BIT(0)
: #define DRAM_BASE_HOLE_EN BIT(1)
: #define DRAM_BASE_INTLV_CH_SHFT 4
: #define DRAM_BASE_INTLV_CH (0xF << DRAM_BASE_INTLV_CH_SHFT)
: #define DRAM_BASE_INTLV_SEL_SHFT 8
: #define DRAM_BASE_INTLV_SEL (0x7 << DRAM_BASE_INTLV_SEL_SHFT)
: #define DRAM_BASE_ADDR_SHFT 12
: #define DRAM_BASE_ADDR (0xFFFFF << DRAM_BASE_ADDR_SHFT)
:
: #define D18F0_DRAM_LIMIT0 0x114
: #define DRAM_LIMIT_DST_ID_SHFT 0
: #define DRAM_LIMIT_DST_ID (0xFF << DRAM_LIMIT_DST_ID_SHFT)
: #define DRAM_LIMIT_INTLV_NUM_SOCK_SHFT 8
: #define DRAM_LIMIT_INTLV_NUM_SOCK (0x1 << DRAM_LIMIT_INTLV_NUM_SOCK_SHFT)
: #define DRAM_LIMIT_INTLV_NUM_DIE_SHFT 10
: #define DRAM_LIMIT_INTLV_NUM_DIE (0x3 << DRAM_LIMIT_INTLV_NUM_DIE_SHFT)
: #define DRAM_LIMIT_ADDR_SHFT 12
: #define DRAM_LIMIT_ADDR (0xFFFFF << DRAM_LIMIT_ADDR_SHFT)
:
: #define DF_DRAM_BASE(dram_map_pair) ((dram_map_pair) * 2 * sizeof(uint32_t) \
: + D18F0_DRAM_BASE0)
: #define DF_DRAM_LIMIT(dram_map_pair) ((dram_map_pair) * 2 * sizeof(uint32_t) \
: + D18F0_DRAM_LIMIT0)
i'd add those in the next commit, since they aren't needed or used for what this patch adds
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/includ…
PS2, Line 62: BIT(0)
i'd prefer (1 << 0) over BIT(0), but both will work. your call.
https://review.coreboot.org/c/coreboot/+/47726/2/src/soc/amd/picasso/includ…
PS2, Line 70: DF_IND_CFG_INST_ID
is this a mask? if so, i'dd ad _MASK as suffix
--
To view, visit https://review.coreboot.org/c/coreboot/+/47726
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If0dc72063fbb99efaeea3fccef16cc1b5b8526f1
Gerrit-Change-Number: 47726
Gerrit-PatchSet: 2
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Justin Frodsham <justin.frodsham(a)protonmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Matt Papageorge <matthewpapa07(a)gmail.com>
Gerrit-Reviewer: Nikolai Vyssotski <nikolai.vyssotski(a)amd.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Fri, 20 Nov 2020 00:27:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment