Matt DeVillier has submitted this change. ( https://review.coreboot.org/c/coreboot/+/85846?usp=email )
(
4 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: Doc/mb/hp: Rename pro_3500_series to pro_3x00 series
......................................................................
Doc/mb/hp: Rename pro_3500_series to pro_3x00 series
The pro_3500_series was converted to a variant to include the Pro 3400, so rename the corresponding documentation.
Change-Id: I5977f223d6f004a801e163397d1c97febd7ee1d4
Signed-off-by: Vesek <venda.straka(a)gmail.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/85846
Reviewed-by: Nicholas Chin <nic.c3.14(a)gmail.com>
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
R Documentation/mainboard/hp/pro_3x00_series.md
R Documentation/mainboard/hp/pro_3x00_series_flash.avif
R Documentation/mainboard/hp/pro_3x00_series_jumper.avif
M Documentation/mainboard/index.md
4 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Angel Pons: Looks good to me, approved
Nicholas Chin: Looks good to me, approved
build bot (Jenkins): Verified
diff --git a/Documentation/mainboard/hp/pro_3500_series.md b/Documentation/mainboard/hp/pro_3x00_series.md
similarity index 97%
rename from Documentation/mainboard/hp/pro_3500_series.md
rename to Documentation/mainboard/hp/pro_3x00_series.md
index 3280066..a92c4f5 100644
--- a/Documentation/mainboard/hp/pro_3500_series.md
+++ b/Documentation/mainboard/hp/pro_3x00_series.md
@@ -71,7 +71,7 @@
from the OS.
**Position of FDO jumper (E2) close to the F_USB3**
-
+
### External programming
@@ -83,7 +83,7 @@
until cleanly power cycled.
**Position of SOIC-8 flash and pin-header near ATX power connector**
-
+
## Technology
diff --git a/Documentation/mainboard/hp/pro_3500_series_flash.avif b/Documentation/mainboard/hp/pro_3x00_series_flash.avif
similarity index 100%
rename from Documentation/mainboard/hp/pro_3500_series_flash.avif
rename to Documentation/mainboard/hp/pro_3x00_series_flash.avif
Binary files differ
diff --git a/Documentation/mainboard/hp/pro_3500_series_jumper.avif b/Documentation/mainboard/hp/pro_3x00_series_jumper.avif
similarity index 100%
rename from Documentation/mainboard/hp/pro_3500_series_jumper.avif
rename to Documentation/mainboard/hp/pro_3x00_series_jumper.avif
Binary files differ
diff --git a/Documentation/mainboard/index.md b/Documentation/mainboard/index.md
index 177abff..f2be295 100644
--- a/Documentation/mainboard/index.md
+++ b/Documentation/mainboard/index.md
@@ -139,7 +139,7 @@
Compaq 8200 Elite SFF <hp/compaq_8200_sff.md>
Compaq 8300 Elite SFF <hp/compaq_8300_sff.md>
Compaq Elite 8300 USDT <hp/compaq_8300_usdt.md>
-Pro 3x00 Series <hp/pro_3500_series.md>
+Pro 3x00 Series <hp/pro_3x00_series.md>
Z220 Workstation SFF <hp/z220_sff.md>
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/85846?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I5977f223d6f004a801e163397d1c97febd7ee1d4
Gerrit-Change-Number: 85846
Gerrit-PatchSet: 6
Gerrit-Owner: Václav Straka <venda.straka(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Matt DeVillier has submitted this change. ( https://review.coreboot.org/c/coreboot/+/68122?usp=email )
Change subject: soc/amd/common: Support sbin ucode files
......................................................................
soc/amd/common: Support sbin ucode files
Recent PI releases have been distributing the ucode patch files as sbin
files instead of bin files. The sbin uses a 256 byte amd_fw_header to
wrap the bin file.
Offset 0x14 of the header is the size field. The can be extracted with
od to get the size of the ucode bin file. The bin file can then be
extracted with dd and placed in the build directory for inclusion as a
cbfs file.
In the case where both an sbin and bin ucode file are present, the bin
file will be added and a note will print at the start of the build about
the sbin file being skipped.
TEST=builds with only bin, only sbin, non-matching bin and sbin,
matching bin and sbin files
Signed-off-by: Fred Reitberger <reitbergerfred(a)gmail.com>
Signed-off-by: Maximilian Brune <maximilian.brune(a)9elements.com>
Change-Id: I29768ea19543bdc76662e687f59bf31b76f555ae
Reviewed-on: https://review.coreboot.org/c/coreboot/+/68122
Reviewed-by: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M src/soc/amd/common/Makefile.mk
M src/soc/amd/common/block/cpu/Makefile.mk
2 files changed, 45 insertions(+), 13 deletions(-)
Approvals:
Patrick Rudolph: Looks good to me, approved
Fred Reitberger: Looks good to me, but someone else must approve
build bot (Jenkins): Verified
diff --git a/src/soc/amd/common/Makefile.mk b/src/soc/amd/common/Makefile.mk
index 626260f..a030687 100644
--- a/src/soc/amd/common/Makefile.mk
+++ b/src/soc/amd/common/Makefile.mk
@@ -38,8 +38,6 @@
DEP_FILES = $(patsubst %,$(FIRMWARE_LOCATION)/%, $(AMDFW_CFG_IN_FW_LOC)) \
$(AMDFW_CFG_WITH_PATH)
-amd_microcode_bins += $(wildcard ${FIRMWARE_LOCATION}/*U?odePatch*.bin)
-
ifeq ($(CONFIG_RESET_VECTOR_IN_RAM),y)
$(objcbfs)/bootblock.bin: $(obj)/amdfw.rom $(obj)/fmap_config.h
cp $< $@
diff --git a/src/soc/amd/common/block/cpu/Makefile.mk b/src/soc/amd/common/block/cpu/Makefile.mk
index 1c4331c..ea40801 100644
--- a/src/soc/amd/common/block/cpu/Makefile.mk
+++ b/src/soc/amd/common/block/cpu/Makefile.mk
@@ -9,18 +9,52 @@
ramstage-$(CONFIG_SOC_AMD_COMMON_BLOCK_UCODE) += update_microcode.c
ifeq ($(CONFIG_SOC_AMD_COMMON_BLOCK_UCODE),y)
-define add-ucode-as-cbfs
-$(if $(value cpu_microcode_$(2).bin-file),$(info File1: $(cpu_microcode_$(2).bin-file)) $(info File2: $(1)) $(error Error: The cbfs filename "cpu_microcode_$(2).bin" is used for both above files. Check your microcode patches for duplicates.))
-cbfs-files-y += cpu_microcode_$(2).bin
-cpu_microcode_$(2).bin-file := $(1)
-cpu_microcode_$(2).bin-type := microcode
-ifeq ($(CONFIG_SOC_AMD_COMMON_BLOCK_LPC_SPI_DMA),y)
-cpu_microcode_$(2).bin-align := 64
-else
-cpu_microcode_$(2).bin-align := 16
+define add-ucode-as-cbfs
+
+# check for duplicate microcode files. Same sbin and bin ucode is allowed here though, because mendocino has a duplicate.
+ifeq ($(cpu_microcode_$(2).bin-file), $(obj)/cpu_microcode_$(2).$(3))
+ $$(info Tried to add ucode: $(1))
+ $$(error Error: The cbfs filename "cpu_microcode_$(2).bin" is already used. Check your microcode patches for duplicates.)
endif
+
+# offset 0x14 contains the size of the unwrapped ucode file
+# .sbin files contain a 256 wrapper around the usual microcode file
+$(obj)/cpu_microcode_$(2).$(3): $(1)
+ echo $$< "->" $$@
+ if [ $(3) = "bin" ]; then \
+ cp $$< $$@; \
+ elif [ $(3) = "sbin" ]; then \
+ size=$$$$(od --endian little --address-radix n --read-bytes 4 --skip-bytes 0x14 --format u4 $$<); \
+ dd status=none ibs=1 skip=256 count=$$$$((size)) if=$$< of=$$@; \
+ fi
+
+# if there is both a sbin and bin microcode only include the bin one to keep the old behaviour
+ifeq ($(cpu_microcode_$(2).bin-file),)
+ cbfs-files-y += cpu_microcode_$(2).bin
+ cpu_microcode_$(2).bin-file := $(obj)/cpu_microcode_$(2).$(3)
+ cpu_microcode_$(2).bin-type := microcode
+
+ ifeq ($(CONFIG_SOC_AMD_COMMON_BLOCK_LPC_SPI_DMA),y)
+ cpu_microcode_$(2).bin-align := 64
+ else
+ cpu_microcode_$(2).bin-align := 16
+ endif
+endif
+
endef
-$(foreach ucode,$(amd_microcode_bins),$(eval $(call add-ucode-as-cbfs,$(ucode),$(shell hexdump -n 2 -s 0x18 -e '"%x"' $(ucode)))))
-endif
+amd_microcode_bins += $(wildcard ${FIRMWARE_LOCATION}/*U?odePatch*.bin)
+amd_microcode_sbins += $(wildcard ${FIRMWARE_LOCATION}/*UcodePatch_*.sbin)
+
+# Function to grab bytes from a file and format them as desired
+# $(call extract-bytes,filename,bytes-to-read,offset-to-bytes,output-format)
+extract-bytes = $(shell echo $(shell od --endian little --address-radix n --read-bytes $(2) --skip-bytes $(3) --format $(4) $(1)))
+
+$(foreach ucode, $(amd_microcode_bins), \
+ $(eval $(call add-ucode-as-cbfs,$(ucode),$(call extract-bytes,$(ucode),2,0x18,x2),bin)))
+
+$(foreach ucode, $(amd_microcode_sbins), \
+ $(eval $(call add-ucode-as-cbfs,$(ucode),$(call extract-bytes,$(ucode),2,0x118,x2),sbin)))
+
+endif #ifeq ($(CONFIG_SOC_AMD_COMMON_BLOCK_UCODE),y)
--
To view, visit https://review.coreboot.org/c/coreboot/+/68122?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I29768ea19543bdc76662e687f59bf31b76f555ae
Gerrit-Change-Number: 68122
Gerrit-PatchSet: 11
Gerrit-Owner: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Matt DeVillier has submitted this change. ( https://review.coreboot.org/c/coreboot/+/86414?usp=email )
Change subject: soc/intel/common/gpio: Add macro for interrupt GPI with driver mode
......................................................................
soc/intel/common/gpio: Add macro for interrupt GPI with driver mode
Adds PAD_CFG_GPI_APIC_DRIVER macros to configure interrupt pad with
driver mode. This is needed when a PAD is configured as an interrupt
such that the corresponding GPI_IS status bit can be updated by the
host controller hardware.
BUG=none
TEST=Check a GPIO pad that is used as interrupt via GpioInt in the ACPI
device _CRS method and check the interrupt has been assigned in
/proc/interrupts.
Signed-off-by: Cliff Huang <cliff.huang(a)intel.com>
Change-Id: Ibc1ed3089c24302bc7eb02318714b8ec464fad01
Reviewed-on: https://review.coreboot.org/c/coreboot/+/86414
Reviewed-by: Wonkyu Kim <wonkyu.kim(a)intel.com>
Reviewed-by: Kyoung Il Kim <kyoung.il.kim(a)intel.com>
Reviewed-by: Bora Guvendik <bora.guvendik(a)intel.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M src/soc/intel/common/block/include/intelblocks/gpio_defs.h
1 file changed, 8 insertions(+), 0 deletions(-)
Approvals:
build bot (Jenkins): Verified
Bora Guvendik: Looks good to me, approved
Kyoung Il Kim: Looks good to me, but someone else must approve
Wonkyu Kim: Looks good to me, but someone else must approve
diff --git a/src/soc/intel/common/block/include/intelblocks/gpio_defs.h b/src/soc/intel/common/block/include/intelblocks/gpio_defs.h
index f0ff08c..bcf8e73 100644
--- a/src/soc/intel/common/block/include/intelblocks/gpio_defs.h
+++ b/src/soc/intel/common/block/include/intelblocks/gpio_defs.h
@@ -436,6 +436,14 @@
PAD_IRQ_CFG(IOAPIC, trig, inv), PAD_PULL(pull) | \
PAD_IOSSTATE(TxDRxE))
+/* General purpose input, routed to APIC, HostOwn */
+#define PAD_CFG_GPI_APIC_DRIVER(pad, pull, rst, trig, inv) \
+ _PAD_CFG_STRUCT(pad, \
+ PAD_FUNC(GPIO) | PAD_RESET(rst) | PAD_BUF(TX_DISABLE) | \
+ PAD_IRQ_CFG(IOAPIC, trig, inv), PAD_PULL(pull) | \
+ PAD_IOSSTATE(TxDRxE) | \
+ PAD_CFG_OWN_GPIO(DRIVER))
+
/* General purpose input with lock, routed to APIC */
#define PAD_CFG_GPI_APIC_LOCK(pad, pull, trig, inv, lock_action) \
_PAD_CFG_STRUCT_LOCK(pad, \
--
To view, visit https://review.coreboot.org/c/coreboot/+/86414?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ibc1ed3089c24302bc7eb02318714b8ec464fad01
Gerrit-Change-Number: 86414
Gerrit-PatchSet: 5
Gerrit-Owner: Cliff Huang <cliff.huang(a)intel.com>
Gerrit-Reviewer: Bora Guvendik <bora.guvendik(a)intel.com>
Gerrit-Reviewer: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Reviewer: Kyoung Il Kim <kyoung.il.kim(a)intel.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Wonkyu Kim <wonkyu.kim(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Jérémy Compostella <jeremy.compostella(a)intel.com>
Attention is currently required from: Naresh Solanki.
Maximilian Brune has posted comments on this change by Naresh Solanki. ( https://review.coreboot.org/c/coreboot/+/85637?usp=email )
Change subject: soc/amd/glinda/cpu: Update smbios parameters
......................................................................
Patch Set 5: Code-Review+2
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/85637/comment/4dc8abaf_b575568b?us… :
PS3, Line 9: Update smbios parameters for cache type, operation mode & error
: correction type.
> could you add the source of your information?
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/85637?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If8eaa54c9a0086f4d397a7ddb01009acfd3f1aee
Gerrit-Change-Number: 85637
Gerrit-PatchSet: 5
Gerrit-Owner: Naresh Solanki <naresh.solanki(a)9elements.com>
Gerrit-Reviewer: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Naresh Solanki <naresh.solanki(a)9elements.com>
Gerrit-Comment-Date: Fri, 28 Feb 2025 18:05:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Maximilian Brune <maximilian.brune(a)9elements.com>