Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/84197?usp=email )
Change subject: drivers/i2c/generic: Remove erroneous acpigen_pop_len
......................................................................
drivers/i2c/generic: Remove erroneous acpigen_pop_len
There are one too many acpigen_pop_len calls in the code
to generate the ROTM; remove one to fix an EMERG warning:
[EMERG] ASSERTION_ERROR: file `src/acpi/acpigen.c`, line 38
The extra acpigen_pop_len() call was added commit
45d2c3d5436e ("i2c/drivers/generic: Return ROTM in a package").
Change-Id: I913022144813f7f65eac1bcb7c97656f2c513c0b
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/84197
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Matt DeVillier <matt.devillier(a)gmail.com>
---
M src/drivers/i2c/generic/generic.c
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Matt DeVillier: Looks good to me, approved
diff --git a/src/drivers/i2c/generic/generic.c b/src/drivers/i2c/generic/generic.c
index 27bef49..260ea83 100644
--- a/src/drivers/i2c/generic/generic.c
+++ b/src/drivers/i2c/generic/generic.c
@@ -165,7 +165,6 @@
acpigen_write_return_namestr("RBUF");
acpigen_pop_len();
- acpigen_pop_len();
}
/* Chip Direct Mapping */
--
To view, visit https://review.coreboot.org/c/coreboot/+/84197?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I913022144813f7f65eac1bcb7c97656f2c513c0b
Gerrit-Change-Number: 84197
Gerrit-PatchSet: 6
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Attention is currently required from: Alexander Couzens.
Maxim has posted comments on this change by Alexander Couzens. ( https://review.coreboot.org/c/coreboot/+/84191?usp=email )
Change subject: intelp2m: add support for elkhartlake
......................................................................
Patch Set 3:
(6 comments)
Patchset:
PS3:
Thanks for this work!
It seems that the code in all methods is the same as the Apollo Lake platform (https://review.coreboot.org/plugins/gitiles/coreboot/+/refs/heads/main/util…), except for `func (Platform Specific) Pull() {...}`. And if so, we can reuse these methods. It is necessary to define InheritanceMacro : apl.Platform Specific{} inside the structure for the new platform and make calls in the appropriate methods. (for example, for Cannon Lake - https://review.coreboot.org/plugins/gitiles/coreboot/+/refs/heads/main/util…)
File util/intelp2m/platforms/ehl/macro.go:
https://review.coreboot.org/c/coreboot/+/84191/comment/5caf1b86_411e922b?us… :
PS3, Line 151: func (PlatformSpecific) GpiMacroAdd() {
```go
// Adds PAD_CFG_GPI macro with arguments
func (PlatformSpecific) GpiMacroAdd() {
platform.InheritanceMacro.GpiMacroAdd()
}
```
https://review.coreboot.org/c/coreboot/+/84191/comment/23fa57ec_7f4a90e5?us… :
PS3, Line 204: func (PlatformSpecific) GpoMacroAdd() {
```go
// Adds PAD_CFG_GPO macro with arguments
func (platform PlatformSpecific) GpoMacroAdd() {
platform.InheritanceMacro.GpoMacroAdd()
}
```
https://review.coreboot.org/c/coreboot/+/84191/comment/11d578d5_622929a8?us… :
PS3, Line 236: func (PlatformSpecific) NativeFunctionMacroAdd() {
```go
// Adds PAD_CFG_NF macro with arguments
func (platform PlatformSpecific) NativeFunctionMacroAdd() {
platform.InheritanceMacro.NativeFunctionMacroAdd()
}
```
https://review.coreboot.org/c/coreboot/+/84191/comment/ff3a718a_fd94b7cd?us… :
PS3, Line 268: func (PlatformSpecific) NoConnMacroAdd() {
```go
// Adds PAD_NC macro
func (platform PlatformSpecific) NoConnMacroAdd() {
platform.InheritanceMacro.NoConnMacroAdd()
}
```
https://review.coreboot.org/c/coreboot/+/84191/comment/d839a88b_5cd5027e?us… :
PS3, Line 302: macro := common.GetInstanceMacro(PlatformSpecific{}, fields.InterfaceGet())
```go
macro := common.GetInstanceMacro(
PlatformSpecific{
InheritanceMacro: apl.PlatformSpecific{},
},
fields.InterfaceGet(),
)
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/84191?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I0f60d182bc5cc3d0d1d1177fbda0cfe8e2279e46
Gerrit-Change-Number: 84191
Gerrit-PatchSet: 3
Gerrit-Owner: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Reviewer: Maxim <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Comment-Date: Fri, 06 Sep 2024 12:09:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Bao Zheng has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/84233?usp=email )
Change subject: amdfwtool: Add combo new layout for new family
......................................................................
Abandoned
--
To view, visit https://review.coreboot.org/c/coreboot/+/84233?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: abandon
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If573cdeaeb56e95d2fed235c9337fab82d622757
Gerrit-Change-Number: 84233
Gerrit-PatchSet: 2
Gerrit-Owner: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Zheng Bao
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Attention is currently required from: Hung-Te Lin, Xi Chen, Yidi Lin.
Yu-Ping Wu has posted comments on this change by Yidi Lin. ( https://review.coreboot.org/c/coreboot/+/84221?usp=email )
Change subject: soc/mediatek/common: Move common GPIO definitions to gpio_defs.h
......................................................................
Patch Set 1:
(1 comment)
File src/soc/mediatek/common/include/soc/gpio_defs.h:
https://review.coreboot.org/c/coreboot/+/84221/comment/bbc33c56_b60c387d?us… :
PS1, Line 37: val_regs
Can we rename it to `gpio_val_regs`?
--
To view, visit https://review.coreboot.org/c/coreboot/+/84221?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If35dcc4d88732f92c7c43a5eed0478ec52cf1802
Gerrit-Change-Number: 84221
Gerrit-PatchSet: 1
Gerrit-Owner: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Xi Chen <xixi.chen(a)mediatek.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Xi Chen <xixi.chen(a)mediatek.com>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Yidi Lin <yidilin(a)google.com>
Gerrit-Comment-Date: Fri, 06 Sep 2024 10:20:20 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Tongtong Pan.
Weimin Wu has posted comments on this change by Tongtong Pan. ( https://review.coreboot.org/c/coreboot/+/84196?usp=email )
Change subject: mb/google/dedede/var/awasuki: Update touchscreen power sequence
......................................................................
Patch Set 3:
(2 comments)
Patchset:
PS3:
> any spec change?
No spec for stop_delay_ms, when resume the sequence is VTSP => RST => TP_EN(stop), TP_EN(stop) is last phase.
--------------------------------------------------------------------
Before changed:
elants_i2c i2c-ELAN0001:00: PM: acpi_subsys_resume+0x0/0x60 returned 0 after 449906 usecs
the seconds_system_resume > 0.5 seconds, power_UiResume test failed.
--------------------------------------------------------------------
After changed:
elants_i2c i2c-ELAN0001:00: PM: acpi_subsys_resume+0x0/0x60 returned 0 after 161712 usecs
the seconds_system_resume < 0.5 seconds, passed power_UiResume test.
and
Passed power_SuspendStress.bareFSI 2500 cycles test, touchscreen still working functionally.
Commit Message:
https://review.coreboot.org/c/coreboot/+/84196/comment/d1c27fd3_adf5897e?us… :
PS3, Line 9: Reduce resume time.
> Have you confirmed that the touchscreen works even after multiple iterations of suspend/resume. […]
Passed power_SuspendStress.bareFSI 2500 cycles test, touchscreen still working functionally.
--
To view, visit https://review.coreboot.org/c/coreboot/+/84196?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I32b2b1c709ecab964a0e449d416c5d0ee2c1d97d
Gerrit-Change-Number: 84196
Gerrit-PatchSet: 3
Gerrit-Owner: Tongtong Pan <pantongtong(a)huaqin.corp-partner.google.com>
Gerrit-Reviewer: Eric Lai <ericllai(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Weimin Wu <wuweimin(a)huaqin.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Tongtong Pan <pantongtong(a)huaqin.corp-partner.google.com>
Gerrit-Comment-Date: Fri, 06 Sep 2024 09:04:44 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Eric Lai <ericllai(a)google.com>
Comment-In-Reply-To: Karthik Ramasubramanian <kramasub(a)google.com>
Attention is currently required from: Matt DeVillier.
Angel Pons has posted comments on this change by Matt DeVillier. ( https://review.coreboot.org/c/coreboot/+/84225?usp=email )
Change subject: nb/intel/sandybridge: Add Kconfig to set default IGD allocation
......................................................................
Patch Set 4: Code-Review+2
(1 comment)
File src/northbridge/intel/sandybridge/Kconfig:
https://review.coreboot.org/c/coreboot/+/84225/comment/a2b499ac_614b15c6?us… :
PS3, Line 204: IGD_DEFAULT_INT_VALUE
> is IGD_DEFAULT_UMA_INDEX better?
Good enough, thanks!
--
To view, visit https://review.coreboot.org/c/coreboot/+/84225?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I83d57cf4657cfccbb21416c5da05eeff9e95a44f
Gerrit-Change-Number: 84225
Gerrit-PatchSet: 4
Gerrit-Owner: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Comment-Date: Fri, 06 Sep 2024 08:38:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Matt DeVillier <matt.devillier(a)gmail.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>