Yi Chou has uploaded a new patch set (#2). ( https://review.coreboot.org/c/coreboot/+/79800?usp=email )
Change subject: libpayload: Move back the ttb_buffer section
......................................................................
libpayload: Move back the ttb_buffer section
If the move it into the .ttb_buffer section, the LOAD flag would not be set.
We should move it back to .bss.ttb_buffer section.
BUG=b:248610274
TEST=Boot the device.
BRANCH=none
Cq-Depend: chromium:5173448
Change-Id: I9bb08878dd4be01d9ed3f96933f774dd6296f76e
Signed-off-by: Yi Chou <yich(a)google.com>
---
M payloads/libpayload/arch/arm64/libpayload.ldscript
M payloads/libpayload/arch/arm64/mmu.c
2 files changed, 5 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/00/79800/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/79800?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I9bb08878dd4be01d9ed3f96933f774dd6296f76e
Gerrit-Change-Number: 79800
Gerrit-PatchSet: 2
Gerrit-Owner: Yi Chou <yich(a)google.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Yi Chou has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/79800?usp=email )
Change subject: Move back the ttb_buffer section
......................................................................
Move back the ttb_buffer section
If the move it into the .ttb_buffer section, the LOAD flag would not be set.
We should move it back to .bss.ttb_buffer section.
BUG=b:248610274
TEST=Boot the device.
BRANCH=none
Cq-Depend: chromium:5173448
Change-Id: I9bb08878dd4be01d9ed3f96933f774dd6296f76e
Signed-off-by: Yi Chou <yich(a)google.com>
---
M payloads/libpayload/arch/arm64/libpayload.ldscript
M payloads/libpayload/arch/arm64/mmu.c
2 files changed, 5 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/00/79800/1
diff --git a/payloads/libpayload/arch/arm64/libpayload.ldscript b/payloads/libpayload/arch/arm64/libpayload.ldscript
index c9881f7..e3e6faa 100644
--- a/payloads/libpayload/arch/arm64/libpayload.ldscript
+++ b/payloads/libpayload/arch/arm64/libpayload.ldscript
@@ -62,7 +62,7 @@
}
.bss : {
- *(.ttb_buffer)
+ *(.bss.ttb_buffer)
_bss = .;
*(.sbss)
diff --git a/payloads/libpayload/arch/arm64/mmu.c b/payloads/libpayload/arch/arm64/mmu.c
index 5865b1b..ae7ac3a 100644
--- a/payloads/libpayload/arch/arm64/mmu.c
+++ b/payloads/libpayload/arch/arm64/mmu.c
@@ -41,8 +41,10 @@
static uint64_t *xlat_addr;
static int free_idx;
-static uint8_t ttb_buffer[TTB_DEFAULT_SIZE] __aligned(GRANULE_SIZE)
- __attribute__((__section__(".ttb_buffer")));
+
+/* Don't chage the name of this variable without also changing the name in the
+ * linker script. */
+static uint8_t ttb_buffer[TTB_DEFAULT_SIZE] __aligned(GRANULE_SIZE);
static const char * const tag_to_string[] = {
[TYPE_NORMAL_MEM] = "normal",
--
To view, visit https://review.coreboot.org/c/coreboot/+/79800?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I9bb08878dd4be01d9ed3f96933f774dd6296f76e
Gerrit-Change-Number: 79800
Gerrit-PatchSet: 1
Gerrit-Owner: Yi Chou <yich(a)google.com>
Gerrit-MessageType: newchange
Attention is currently required from: Dinesh Gehlot, Eran Mitrani, Jakub Czapiga, Kapil Porwal, Mike Banon, Tarun.
Hello Dinesh Gehlot, Eran Mitrani, Jakub Czapiga, Kapil Porwal, Mike Banon, Tarun,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/79842?usp=email
to look at the new patch set (#2).
Change subject: soc/intel/mtl: Override the `SOC_PHYSICAL_ADDRESS_WIDTH` as integer
......................................................................
soc/intel/mtl: Override the `SOC_PHYSICAL_ADDRESS_WIDTH` as integer
This patch enforces consistent override handling for integer
`SOC_PHYSICAL_ADDRESS_WIDTH` config
Change-Id: Ib5bdfdb8c2689803c9d3c2bfd353609edae91ab3
Signed-off-by: Subrata Banik <subratabanik(a)google.com>
---
M src/soc/intel/meteorlake/Kconfig
1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/42/79842/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/79842?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ib5bdfdb8c2689803c9d3c2bfd353609edae91ab3
Gerrit-Change-Number: 79842
Gerrit-PatchSet: 2
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Reviewer: Eran Mitrani <mitrani(a)google.com>
Gerrit-Reviewer: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Mike Banon <mikebdp2(a)gmail.com>
Gerrit-Reviewer: Tarun <tstuli(a)gmail.com>
Gerrit-Attention: Mike Banon <mikebdp2(a)gmail.com>
Gerrit-Attention: Eran Mitrani <mitrani(a)google.com>
Gerrit-Attention: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Attention: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Tarun <tstuli(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Hung-Te Lin, Paul Menzel, Yidi Lin.
Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79776?usp=email )
Change subject: soc/mediatek: Add common implmentation to configure display
......................................................................
Patch Set 2:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/79776/comment/28c68160_14a3d44d :
PS2, Line 7: implmentation
typo
--
To view, visit https://review.coreboot.org/c/coreboot/+/79776?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I403bba8a826de5f3fb2ea96a5403725ff194164f
Gerrit-Change-Number: 79776
Gerrit-PatchSet: 2
Gerrit-Owner: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Yidi Lin <yidilin(a)google.com>
Gerrit-Comment-Date: Mon, 08 Jan 2024 03:09:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Hung-Te Lin, Paul Menzel, Yidi Lin.
Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79776?usp=email )
Change subject: soc/mediatek: Add common implmentation to configure display
......................................................................
Patch Set 1:
(8 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/79776/comment/bc69738e_b29da548 :
PS1, Line 13: mtcmos_display_power_on
nit: `mtcmos_display_power_on()`
https://review.coreboot.org/c/coreboot/+/79776/comment/bbc5d2fd_545ea20e :
PS1, Line 28: soc
nit: `mediatek`
https://review.coreboot.org/c/coreboot/+/79776/comment/1f5bcdc2_6f99a6fe :
PS1, Line 29: refacts
Do you mean `refactors`?
File src/mainboard/google/geralt/panel.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/9d825f48_e693c00d :
PS1, Line 23: struct panel_description *get_active_panel(void);
I think the declaration should be kept here, because the implementation is in geralt/panel.c.
File src/soc/mediatek/common/display.c:
https://review.coreboot.org/c/coreboot/+/79776/comment/5240a02b_c853c63a :
PS1, Line 13: configure_display
Consider renaming it to `mtk_display_init`?
https://review.coreboot.org/c/coreboot/+/79776/comment/3d4ed732_101c102f :
PS1, Line 42: if (panel->get_edid && panel->get_edid(panel) < 0)
So, this is only for eDP bridges, right? For consistency, I think `get_mipi_cmd_from_cbfs()`, which also sets `panel->s->edid`, can also be moved to soc/meditek/common/. That would also reduce duplicate code for MediaTek boards (for example corsola also has `get_panel_from_cbfs()`). Then the logic here can be
```
if (panel->get_edid) {
panel->get_edid(panel);
} else {
panel_serializable_data mipi_data;
get_mipi_panel_from_cbfs(&mipi_data);
}
```
And `s` can also be removed from `panel`. What do you think?
File src/soc/mediatek/common/include/soc/ddp_common.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/6cfab11e_34262aca :
PS1, Line 142: enum disp_path_sel {
I think this should be put in mediatek/common/.../display.h, and then include display.h from mt8188/.../ddp.h (not the other way around).
File src/soc/mediatek/common/include/soc/display.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/694f054f_98fff66b :
PS1, Line 13: configure_panel_backlight
configure_backlight
--
To view, visit https://review.coreboot.org/c/coreboot/+/79776?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I403bba8a826de5f3fb2ea96a5403725ff194164f
Gerrit-Change-Number: 79776
Gerrit-PatchSet: 1
Gerrit-Owner: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Yidi Lin <yidilin(a)google.com>
Gerrit-Comment-Date: Mon, 08 Jan 2024 03:08:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment