Attention is currently required from: Shelley Chen, Taniya Das, Paul Menzel, Julius Werner, Sudheer Amrabadi.
Venkat Thogaru has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68384 )
Change subject: soc/qualcomm/sc7280: Add API to differentialize PRO and NON_PRO SKUs
......................................................................
Patch Set 12:
(1 comment)
File src/soc/qualcomm/sc7280/socinfo.c:
https://review.coreboot.org/c/coreboot/+/68384/comment/0f17bf24_a8e8e465
PS4, Line 12: static struct chipinfo chipinfolut[] = {
> Qualcomm, do you have an update on this?
Sure. For readability, we have commented 'chip_id' information in latest patch-set-12
--
To view, visit https://review.coreboot.org/c/coreboot/+/68384
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id9f23696384a6c1a89000292eafebd8a16c273ca
Gerrit-Change-Number: 68384
Gerrit-PatchSet: 12
Gerrit-Owner: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Venkat Thogaru <thogaru(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Shelley Chen <shchen(a)google.com>
Gerrit-Attention: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-Comment-Date: Mon, 07 Nov 2022 08:34:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Shelley Chen <shchen(a)google.com>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Comment-In-Reply-To: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-MessageType: comment
Attention is currently required from: Taniya Das, Venkat Thogaru, Paul Menzel, Julius Werner, Sudheer Amrabadi.
Venkat Thogaru has uploaded a new patch set (#12) to the change originally created by Sudheer Amrabadi. ( https://review.coreboot.org/c/coreboot/+/68384 )
Change subject: soc/qualcomm/sc7280: Add API to differentialize PRO and NON_PRO SKUs
......................................................................
soc/qualcomm/sc7280: Add API to differentialize PRO and NON_PRO SKUs
The API socinfo_pro_part() returns 1 for Pro and 0 for NON_PRO SKUs. To
reduce the binary footprint for chipinfo structure, change its members
range from uint32_t to uint16_t. Add helper functions for reading and
matching jtagid.
BUG=b:248187555
TEST=Validate boards are detected correctly on PRO and NON_PRO SKUs
Signed-off-by: Taniya Das <quic_tdas(a)quicinc.com>
Change-Id: Id9f23696384a6c1a89000292eafebd8a16c273ca
---
M src/soc/qualcomm/sc7280/include/soc/socinfo.h
M src/soc/qualcomm/sc7280/socinfo.c
2 files changed, 86 insertions(+), 57 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/84/68384/12
--
To view, visit https://review.coreboot.org/c/coreboot/+/68384
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id9f23696384a6c1a89000292eafebd8a16c273ca
Gerrit-Change-Number: 68384
Gerrit-PatchSet: 12
Gerrit-Owner: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Venkat Thogaru <thogaru(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Attention: Venkat Thogaru <thogaru(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: Tarun Tuli, Rizwan Qureshi.
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69286 )
Change subject: soc/intel/aldrlake: Update ME HFSTS register definition
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
Can you please consider porting the CL for MTL?
--
To view, visit https://review.coreboot.org/c/coreboot/+/69286
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9aeee7a3b41ad59c03391207930a253ffff19ae5
Gerrit-Change-Number: 69286
Gerrit-PatchSet: 1
Gerrit-Owner: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-CC: Reka Norman <rekanorman(a)chromium.org>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 08:09:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Tarun Tuli, Rizwan Qureshi.
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69286 )
Change subject: soc/intel/aldrlake: Update ME HFSTS register definition
......................................................................
Patch Set 1: Code-Review+2
(1 comment)
Patchset:
PS1:
Looks like those bit-field changes are not that impactful to the me.c file (i'm no one is actually consuming those bit-fields directly.
--
To view, visit https://review.coreboot.org/c/coreboot/+/69286
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9aeee7a3b41ad59c03391207930a253ffff19ae5
Gerrit-Change-Number: 69286
Gerrit-PatchSet: 1
Gerrit-Owner: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-CC: Reka Norman <rekanorman(a)chromium.org>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 08:08:48 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: V Sowmya, Shahina Shaik, Haribalaraman Ramasubramanian, Paul Menzel, Sridhar Siricilla, Julius Werner, Balaji Manigandan.
Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69221 )
Change subject: security/vboot: Fix different size operands in bitwise operation
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
Please see Julius' comment in https://chromium-review.googlesource.com/c/chromiumos/platform/vboot_refere…:
> Let's not put these casts here. They are unnecessary for now, because we haven't allocated bit 32 or higher yet, so they'll always be 0 anyway, and once we do we'll have to stop using an enum anyway because enums can't be larger than 32-bit (I think?). So at that point we'll have to represent them as macros or something and then we should just define them ULL to begin with.
>
> We definitely don't want to be in a situation where you have to put this cast here or otherwise something is gonna silently break (because sooner or later someone would make that mistake), so we wouldn't build a system that requires that. Then there's no point in having the casts here either. (If you want to be extra proactive, feel free to already rewrite the field definitions now.)
--
To view, visit https://review.coreboot.org/c/coreboot/+/69221
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ifecd5de843bd0229c0cab758d4a641889b4bffd6
Gerrit-Change-Number: 69221
Gerrit-PatchSet: 2
Gerrit-Owner: Shahina Shaik <shahina.shaik(a)intel.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Reviewer: Haribalaraman Ramasubramanian <haribalaraman.r(a)intel.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Shahina Shaik <shahina.shaik(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Attention: Shahina Shaik <shahina.shaik(a)intel.com>
Gerrit-Attention: Haribalaraman Ramasubramanian <haribalaraman.r(a)intel.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Shahina Shaik <shahina.shaik(a)intel.corp-partner.google.com>
Gerrit-Attention: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 08:08:23 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment