Attention is currently required from: V Sowmya, Shahina Shaik, Haribalaraman Ramasubramanian, Sridhar Siricilla, Balaji Manigandan, Yu-Ping Wu.
Shahina Shaik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69220 )
Change subject: UPSTREAM: cbfstool: Fix possible memory leak
......................................................................
Patch Set 4:
(3 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69220/comment/c0b0cc9e_f712be4e
PS4, Line 7: UPSTREAM
> Please remove the `UPSTREAM` prefix.
Removed the "UPSTREAM" prefix from commit message.
File util/cbfstool/cbfstool.c:
https://review.coreboot.org/c/coreboot/+/69220/comment/d072e644_d8ac1c50
PS4, Line 773: header_offset
> Take the chance to fix the indent (by aligning with `&image`)?
Fixed the indent as suggested.
File util/cbfstool/common.c:
https://review.coreboot.org/c/coreboot/+/69220/comment/308a1135_fc03680d
PS4, Line 40: }
> Not related to your change, but I think writing `return -1` here is more straightforward
In line no:30, strdup is using malloc internally to allocate memory for the buffer->name, which has to be freed incase of there is no memory allocated for "buffer->data.
--
To view, visit https://review.coreboot.org/c/coreboot/+/69220
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I01c4643d1e671d9bd9971ac6db8031634fffd61e
Gerrit-Change-Number: 69220
Gerrit-PatchSet: 4
Gerrit-Owner: Shahina Shaik <shahina.shaik(a)intel.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Reviewer: Haribalaraman Ramasubramanian <haribalaraman.r(a)intel.com>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Shahina Shaik <shahina.shaik(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Attention: Shahina Shaik <shahina.shaik(a)intel.com>
Gerrit-Attention: Haribalaraman Ramasubramanian <haribalaraman.r(a)intel.com>
Gerrit-Attention: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Attention: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 06:35:58 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Tarun Tuli, Subrata Banik, Kapil Porwal, Arthur Heymans, Lean Sheng Tan.
Werner Zeh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69227 )
Change subject: soc/intel: Use PCI offset 0x10 over static `Index 0` for PMC
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
The PMC bar is set up in booblock/pch.c for these SoCs (meteorlkae seems to have it in soc_die.c) and here PWRMBASE is used (whihc is 0x10 so matching the BAR0 define).
Should we synchronize these two defines to stay consistent? So either use PWRMBASE in this patch or push another one to fix it in pch.c.
WDYT?
--
To view, visit https://review.coreboot.org/c/coreboot/+/69227
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iee2523876a8045e70effd5824afc327d1113038b
Gerrit-Change-Number: 69227
Gerrit-PatchSet: 2
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 05:57:52 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: David Milosevic.
Maximilian Brune has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68137 )
Change subject: [WIP] mb/prodrive/atlas: Populate smbios table with VPD from ECs EMI
......................................................................
Patch Set 6:
(12 comments)
File src/mainboard/prodrive/atlas/emi.h:
https://review.coreboot.org/c/coreboot/+/68137/comment/f176343d_1809f136
PS6, Line 33: typedef enum {
avoid typedef as per coreboot coding style
https://review.coreboot.org/c/coreboot/+/68137/comment/04168093_d79c0636
PS6, Line 36: EMI_INSTANCE_1 ///< EMI instance 1 (EMI1)
the comment is unnecessary. It would probably make more sense to explain in short what an EMI_INSTANCE/EMI_REGION actually is and how they relate to each other.
https://review.coreboot.org/c/coreboot/+/68137/comment/60c1a9ce_5de4d728
PS6, Line 40: typedef enum {
avoid typedef as per coreboot coding style
https://review.coreboot.org/c/coreboot/+/68137/comment/b9f1d664_35058d6a
PS6, Line 43: EMI_REGION_1 ///< EMI region 1
the comment is unnecessary
https://review.coreboot.org/c/coreboot/+/68137/comment/8b395072_bc0af328
PS6, Line 47: typedef enum {
avoid typedef as per coreboot coding style
https://review.coreboot.org/c/coreboot/+/68137/comment/fd5f3490_141e14a5
PS6, Line 76: const u16 addr,
do not use tabs for this kind of indentation. Since this kind of indentation is supposed to look the same on all editors, spaces are far more appropriate. If jenkins complains about that, ignore it.
File src/mainboard/prodrive/atlas/emi.c:
https://review.coreboot.org/c/coreboot/+/68137/comment/e44d5634_b9f464d3
PS6, Line 41: int emi_read_region(const EMI_INSTANCE instance, const EMI_REGION region,
as far as I can see this function is only used by "emi_read_region_blocK". You can therefore completely remove this function and put only a very small subset of it into "emi_read_region_block", since you don't need the whole switch case then.
https://review.coreboot.org/c/coreboot/+/68137/comment/ada21463_b7d0a76f
PS6, Line 83: {
wouldn't it be easier to directly use an u32 value instead of a pointer? It would remove the need to cast (below) and would also get rid of endianness issues. Also it would be easier to call the function. Also it's generally safer to not use pointers if possible.
Even better: remove the function, since it isn't used anyway (only clutters up code).
https://review.coreboot.org/c/coreboot/+/68137/comment/4ca8989d_73c58c17
PS6, Line 139: inline void emi_write_register(const EMI_INSTANCE instance, const u8 offs, const u8 value)
function can be removed, since it's not used anywhere (only clutters up code).
https://review.coreboot.org/c/coreboot/+/68137/comment/d75db0fa_a2c5bffc
PS6, Line 144: inline u8 emi_read_register(const EMI_INSTANCE instance, const u8 offs)
function can be removed, since it's not used anywhere (only clutters up code).
File src/mainboard/prodrive/atlas/vpd.h:
https://review.coreboot.org/c/coreboot/+/68137/comment/930cc522_d4c82ef0
PS6, Line 26: #define vpd(x) offsetof(vpd_section_t, x)
this macro only makes the rest of the code far less obvious.
File src/mainboard/prodrive/atlas/vpd.c:
https://review.coreboot.org/c/coreboot/+/68137/comment/5bc04c02_34fb7de9
PS6, Line 36: case vpd(part_number): return PN_LENGTH;
as mentioned above, this macro makes it very hard to read (especially considering it has the same name as the parameter). It would be much more readable if you would directly write:
`case offsetof(struct vpd_section, part_number):`
--
To view, visit https://review.coreboot.org/c/coreboot/+/68137
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I47bb4883c43ff344a9bda92c3106dd025533b391
Gerrit-Change-Number: 68137
Gerrit-PatchSet: 6
Gerrit-Owner: David Milosevic <David.Milosevic(a)9elements.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-CC: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: David Milosevic <David.Milosevic(a)9elements.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 04:44:53 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Jason Nien, Martin Roth.
Victor Ding has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69192 )
Change subject: drivers/i2c/sx9324: Add support for Linux's SX9324 driver
......................................................................
Patch Set 7:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69192/comment/394f346c_d90a7af1
PS6, Line 26: TEST=Dump ACPI SSDT then verify _DSD entries related to the legacy
> nit: do you mind including what board(s)/platform(s) you verified the SSDT on
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/69192
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I42cd6841c3a270c242ed2e739db245e858eadb3b
Gerrit-Change-Number: 69192
Gerrit-PatchSet: 7
Gerrit-Owner: Victor Ding <victording(a)google.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Reka Norman <rekanorman(a)chromium.org>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 04:28:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Tarun Tuli <taruntuli(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Victor Ding, Jason Nien, Martin Roth.
Hello build bot (Jenkins), Tarun Tuli, Jason Nien, Reka Norman, Martin Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/69192
to look at the new patch set (#7).
Change subject: drivers/i2c/sx9324: Add support for Linux's SX9324 driver
......................................................................
drivers/i2c/sx9324: Add support for Linux's SX9324 driver
SX9324 driver is updated per Linux's documentation found at
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Doc…
Supporting logic for the deprecated SX932x driver is hence guarded by
DRIVERS_I2C_SX9324_SUPPORT_LEGACY_LINUX_DRIVER
This patch by itself does not introduce functional changes to any board.
The legacy SX932x Linux driver never reached upstream Linux and is only
available in ChromeOS kernel fork of 4.4 and 5.4. Linux later accepted
a different implementation named SX9324 and has been available since
5.4. Ideally all variants should adopt the new driver; however, during
the transition phase, coreboot must support both drivers. It is better
to have a single firmware build that can work with both Linux kernel
drivers by specifying both sets of properties. Legacy driver support
should be deleted once all variants finish migration.
BUG=b:242662878
TEST=Dump ACPI SSDT then verify _DSD entries related to the legacy
SX932x driver are identical w/ and w/o this patch
(Tested on Craask and Nivviks)
Change-Id: I42cd6841c3a270c242ed2e739db245e858eadb3b
Signed-off-by: Victor Ding <victording(a)google.com>
---
M src/drivers/i2c/sx9324/Kconfig
M src/drivers/i2c/sx9324/chip.h
M src/drivers/i2c/sx9324/registers.h
M src/drivers/i2c/sx9324/sx9324.c
M src/mainboard/google/brya/Kconfig.name
M src/mainboard/google/dedede/Kconfig.name
M src/mainboard/google/zork/Kconfig.name
7 files changed, 219 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/92/69192/7
--
To view, visit https://review.coreboot.org/c/coreboot/+/69192
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I42cd6841c3a270c242ed2e739db245e858eadb3b
Gerrit-Change-Number: 69192
Gerrit-PatchSet: 7
Gerrit-Owner: Victor Ding <victording(a)google.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Reka Norman <rekanorman(a)chromium.org>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Victor Ding <victording(a)google.com>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: V Sowmya, Tarun Tuli, Kangheui Won, Sumeet R Pawnikar, Tyler Wang, Nick Vaccaro, Peter Ou.
Vidya Gopalakrishnan has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69197 )
Change subject: mb/google/nissa/var/craask: Add ambient thermal sensor settings
......................................................................
Patch Set 6: Code-Review+1
--
To view, visit https://review.coreboot.org/c/coreboot/+/69197
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I026a8b3e1a27bedc3e0082e15e80a74a2f8adfda
Gerrit-Change-Number: 69197
Gerrit-PatchSet: 6
Gerrit-Owner: Tyler Wang <tyler.wang(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Kangheui Won <khwon(a)chromium.org>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Peter Ou <peter.ou(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Reka Norman <rekanorman(a)chromium.org>
Gerrit-Reviewer: Sumeet R Pawnikar <sumeet.r.pawnikar(a)intel.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: Vidya Gopalakrishnan <vidya.gopalakrishnan(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Cathy Chen <cathy_chen(a)quanta.corp-partner.google.com>
Gerrit-CC: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-CC: Ren Kuo <ren.kuo(a)quanta.corp-partner.google.com>
Gerrit-Attention: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Kangheui Won <khwon(a)chromium.org>
Gerrit-Attention: Sumeet R Pawnikar <sumeet.r.pawnikar(a)intel.com>
Gerrit-Attention: Tyler Wang <tyler.wang(a)quanta.corp-partner.google.com>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Attention: Peter Ou <peter.ou(a)quanta.corp-partner.google.com>
Gerrit-Comment-Date: Mon, 07 Nov 2022 04:07:32 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment