Attention is currently required from: Andrey Petrov.
Hello build bot (Jenkins), Andrey Petrov,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/69223
to look at the new patch set (#6).
Change subject: drivers/fsp2_0/mp_service_ppi: Use struct device to fill in buffer
......................................................................
drivers/fsp2_0/mp_service_ppi: Use struct device to fill in buffer
Now the CPU topology is filled in struct device during mp_init.
Change-Id: I7322b43f5b95dda5fbe81e7427f5269c9d6f8755
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/drivers/intel/fsp2_0/ppi/mp_service_ppi.c
M src/soc/intel/common/block/cpu/cpulib.c
M src/soc/intel/common/block/include/intelblocks/cpulib.h
3 files changed, 19 insertions(+), 67 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/23/69223/6
--
To view, visit https://review.coreboot.org/c/coreboot/+/69223
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7322b43f5b95dda5fbe81e7427f5269c9d6f8755
Gerrit-Change-Number: 69223
Gerrit-PatchSet: 6
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Arthur Heymans.
Hello build bot (Jenkins), Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/68892
to look at the new patch set (#10).
Change subject: cpu/mp_init.c: Only enable CPUs once they execute code
......................................................................
cpu/mp_init.c: Only enable CPUs once they execute code
On some systems the BSP cannot know how many CPUs are present in the
system. A typical use case is a multi socket system. Setting the enable
flag only on CPUs that actually exist makes it more flexible.
Change-Id: I6c8042b4d6127239175924f996f735bf9c83c6e8
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/cpu/x86/mp_init.c
1 file changed, 16 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/92/68892/10
--
To view, visit https://review.coreboot.org/c/coreboot/+/68892
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6c8042b4d6127239175924f996f735bf9c83c6e8
Gerrit-Change-Number: 68892
Gerrit-PatchSet: 10
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-MessageType: newpatchset
Attention is currently required from: Arthur Heymans.
Hello Arthur Heymans, build bot (Jenkins), Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/64802
to look at the new patch set (#14).
Change subject: cpu/smm_module_loader.c: Fix up CPU index locally
......................................................................
cpu/smm_module_loader.c: Fix up CPU index locally
Don't pass the stub params to the mp_init code.
Change-Id: I070bc00ae5e5bceb6c5b90ea833cc057dd41f6cc
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/cpu/x86/mp_init.c
M src/cpu/x86/smm/smm_module_loader.c
M src/include/cpu/x86/smm.h
3 files changed, 28 insertions(+), 20 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/02/64802/14
--
To view, visit https://review.coreboot.org/c/coreboot/+/64802
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I070bc00ae5e5bceb6c5b90ea833cc057dd41f6cc
Gerrit-Change-Number: 64802
Gerrit-PatchSet: 14
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-MessageType: newpatchset
Attention is currently required from: Arthur Heymans, Angel Pons, Kyösti Mälkki.
Hello build bot (Jenkins), Angel Pons, Elyes Haouas,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/64342
to look at the new patch set (#13).
Change subject: cpu/x86/mp_init.c: Keep track of initial lapic ID inside device_path
......................................................................
cpu/x86/mp_init.c: Keep track of initial lapic ID inside device_path
It's quite confusing to keep track of lapic ID inside the device
struct and initial lapic ID inside an array.
Change-Id: I4d9f8d23c0b0e5c142f6907593428d8509e4e7bb
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/arch/x86/cpu.c
M src/cpu/x86/mp_init.c
M src/device/cpu_device.c
M src/include/cpu/cpu.h
M src/include/device/path.h
5 files changed, 22 insertions(+), 31 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/42/64342/13
--
To view, visit https://review.coreboot.org/c/coreboot/+/64342
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4d9f8d23c0b0e5c142f6907593428d8509e4e7bb
Gerrit-Change-Number: 64342
Gerrit-PatchSet: 13
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-CC: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Marc Jones, Johnny Lin, Paul Menzel, Johnny Li, Arthur Heymans, Shuming Chu (Shuming), Angel Pons, Tim Chu.
Hello build bot (Jenkins), Marc Jones, Johnny Lin, Paul Menzel, Johnny Li, Angel Pons, Tim Chu,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/68784
to look at the new patch set (#3).
Change subject: drivers/ocp: add VPD processing framework
......................................................................
drivers/ocp: add VPD processing framework
Add VPD processing framework to be shared by OCP mainboards:
* define VPD configruation items in vpd.h.
* add helper functions:
** get_bool_from_vpd()
** get_int_from_vpd_range()
Change-Id: I705bea348b1611f25ccbd798b77cfee22ec30f0f
Signed-off-by: Johnny Lin <johnny_lin(a)wiwynn.com>
Signed-off-by: Tim Chu <Tim.Chu(a)quantatw.com>
Signed-off-by: Marc Jones <marcjones(a)sysproconsulting.com>
Signed-off-by: Jonathan Zhang <jonzhang(a)meta.com>
---
A src/drivers/ocp/include/vpd.h
A src/drivers/ocp/vpd/Kconfig
A src/drivers/ocp/vpd/Makefile.inc
A src/drivers/ocp/vpd/vpd_util.c
4 files changed, 153 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/84/68784/3
--
To view, visit https://review.coreboot.org/c/coreboot/+/68784
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I705bea348b1611f25ccbd798b77cfee22ec30f0f
Gerrit-Change-Number: 68784
Gerrit-PatchSet: 3
Gerrit-Owner: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Angel Pons <angel.pons(a)9elements.com>
Gerrit-Reviewer: Johnny Li <johnny_li(a)wistron.corp-partner.google.com>
Gerrit-Reviewer: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Reviewer: Marc Jones <marc(a)marcjonesconsulting.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-CC: Shuming Chu (Shuming) <s1218944(a)gmail.com>
Gerrit-Attention: Marc Jones <marc(a)marcjonesconsulting.com>
Gerrit-Attention: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Johnny Li <johnny_li(a)wistron.corp-partner.google.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Shuming Chu (Shuming) <s1218944(a)gmail.com>
Gerrit-Attention: Angel Pons <angel.pons(a)9elements.com>
Gerrit-Attention: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Marc Jones, Johnny Lin, Paul Menzel, Johnny Li, Arthur Heymans, Shuming Chu (Shuming), Angel Pons, Tim Chu.
Jonathan Zhang has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68784 )
Change subject: drivers/ocp: add VPD processing framework
......................................................................
Patch Set 2:
(2 comments)
Patchset:
PS2:
Johnny, please check out this thread.
File src/drivers/ocp/vpd/Makefile.inc:
https://review.coreboot.org/c/coreboot/+/68784/comment/ef1b035e_f7f0d8bf
PS2, Line 3: smm-$(C
> It's not a good idea to fetch VPD in the smihandler. Do you really need this? […]
We do need to customize SMI handler behavior based on firmware configuration (in this case, VPD), to configure things such as the SMI handler log level.
We think that we need to fetch VPD at least once in the smihandler. Another option is to fetch it in the ramstage and save it somewhere for smi handlers to pick up. @Johnny, could you comment on this?
CONFIG_VPD_SMM_SUPPORT is defined in our SPR production codebase, and we could use it for DeltaLake as well.
For this patch itself, let me remove this statement, while we continue the discussion on CONFIG_VPD_SMM_SUPPORT.
--
To view, visit https://review.coreboot.org/c/coreboot/+/68784
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I705bea348b1611f25ccbd798b77cfee22ec30f0f
Gerrit-Change-Number: 68784
Gerrit-PatchSet: 2
Gerrit-Owner: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Angel Pons <angel.pons(a)9elements.com>
Gerrit-Reviewer: Johnny Li <johnny_li(a)wistron.corp-partner.google.com>
Gerrit-Reviewer: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Reviewer: Marc Jones <marc(a)marcjonesconsulting.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-CC: Shuming Chu (Shuming) <s1218944(a)gmail.com>
Gerrit-Attention: Marc Jones <marc(a)marcjonesconsulting.com>
Gerrit-Attention: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Johnny Li <johnny_li(a)wistron.corp-partner.google.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Shuming Chu (Shuming) <s1218944(a)gmail.com>
Gerrit-Attention: Angel Pons <angel.pons(a)9elements.com>
Gerrit-Attention: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Comment-Date: Sat, 12 Nov 2022 18:55:13 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Raul Rangel, Marshall Dawson, Matt DeVillier, Arthur Heymans.
Fred Reitberger has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63727 )
Change subject: soc/amd/picasso: Add support for 64bit builds
......................................................................
Patch Set 8:
(1 comment)
File src/soc/amd/picasso/Makefile.inc:
https://review.coreboot.org/c/coreboot/+/63727/comment/e47eaca3_44a382fc
PS8, Line 146: ifeq ($(CONFIG_ARCH_BOOTBLOCK_X86_64),y)
: PSP_BIOSBIN_SIZE=$(shell $(READELF_bootblock) -l $(PSP_ELF_FILE) | grep -A1 LOAD | tr -d '\n' | awk '{print $$5}')
: else
: PSP_BIOSBIN_SIZE=$(shell $(READELF_bootblock) -l $(PSP_ELF_FILE) | grep LOAD | awk '{print $$5}')
: endif
If you pass the wide option to readelf (-lW instead of -l), it will still be on a single line for the grep/awk commands. Should work for both 32-bit and 64-bit cases.
--
To view, visit https://review.coreboot.org/c/coreboot/+/63727
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Icd72c4eef7805aacba6378632cbac7de9527673b
Gerrit-Change-Number: 63727
Gerrit-PatchSet: 8
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Sat, 12 Nov 2022 18:12:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Vadim Bendebury, Julius Werner, Aaron Durbin, Elyes Haouas.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68267 )
Change subject: treewide: Replace ALIGN(x, a) by ALIGN_UP(x, a) for clarity
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/68267
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I2a255cdcbcd38406f008a26fc0ed68d532e7a721
Gerrit-Change-Number: 68267
Gerrit-PatchSet: 3
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Vadim Bendebury <vbendeb(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Vadim Bendebury <vbendeb(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Attention: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Comment-Date: Sat, 12 Nov 2022 18:00:11 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment