Nico Huber has submitted this change. ( https://review.coreboot.org/c/libgfxinit/+/68110 )
Change subject: gma: Make HW.GFX.GMA.SPLL package private
......................................................................
gma: Make HW.GFX.GMA.SPLL package private
If it's not private, newer GNATprove versions assume the less
specific `GMA.Device_State` would be used as global input/output.
Change-Id: I8a8258fecc5433510555f9a1165356a769c02be7
Signed-off-by: Nico Huber <nico.h(a)gmx.de>
Reviewed-on: https://review.coreboot.org/c/libgfxinit/+/68110
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
---
M common/broxton/hw-gfx-gma-spll.ads
M common/haswell/hw-gfx-gma-spll.ads
M common/skylake/hw-gfx-gma-spll.ads
3 files changed, 18 insertions(+), 3 deletions(-)
Approvals:
Nico Huber: Verified
Angel Pons: Looks good to me, approved
diff --git a/common/broxton/hw-gfx-gma-spll.ads b/common/broxton/hw-gfx-gma-spll.ads
index 571dde9..277a8c1 100644
--- a/common/broxton/hw-gfx-gma-spll.ads
+++ b/common/broxton/hw-gfx-gma-spll.ads
@@ -12,7 +12,7 @@
-- GNU General Public License for more details.
--
-package HW.GFX.GMA.SPLL is
+private package HW.GFX.GMA.SPLL is
-- Just for a common interface with Haswell's DDI.
-- There is no SPLL (no FDI) on Broxton.
diff --git a/common/haswell/hw-gfx-gma-spll.ads b/common/haswell/hw-gfx-gma-spll.ads
index 60222ed..bd1402c 100644
--- a/common/haswell/hw-gfx-gma-spll.ads
+++ b/common/haswell/hw-gfx-gma-spll.ads
@@ -12,7 +12,7 @@
-- GNU General Public License for more details.
--
-package HW.GFX.GMA.SPLL is
+private package HW.GFX.GMA.SPLL is
procedure On;
diff --git a/common/skylake/hw-gfx-gma-spll.ads b/common/skylake/hw-gfx-gma-spll.ads
index 6b9dc01..7b038df 100644
--- a/common/skylake/hw-gfx-gma-spll.ads
+++ b/common/skylake/hw-gfx-gma-spll.ads
@@ -12,7 +12,7 @@
-- GNU General Public License for more details.
--
-package HW.GFX.GMA.SPLL is
+private package HW.GFX.GMA.SPLL is
-- Just for a common interface with Haswell's DDI.
-- There is no SPLL (no FDI) on Skylake.
--
To view, visit https://review.coreboot.org/c/libgfxinit/+/68110
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: libgfxinit
Gerrit-Branch: master
Gerrit-Change-Id: I8a8258fecc5433510555f9a1165356a769c02be7
Gerrit-Change-Number: 68110
Gerrit-PatchSet: 2
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: merged
Attention is currently required from: Jamie Chen, Stanley Wu, Marco Chen, Eric Lai.
Karthik Ramasubramanian has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69925 )
Change subject: mb/google/octopus/variants/phaser: Implement variant_memory_sku()
......................................................................
Patch Set 5:
(1 comment)
File src/mainboard/google/octopus/variants/phaser/memory.c:
https://review.coreboot.org/c/coreboot/+/69925/comment/1c683ee5_7bb64af0
PS5, Line 15: rt = gpio_base2_value(pads, ARRAY_SIZE(pads));
I would recommend translating this only for the impacted SKU. For other SKUs, please assert RAM_ID != 3. That way we can ensure that RAM_ID 3 is not accidentally chosen.
--
To view, visit https://review.coreboot.org/c/coreboot/+/69925
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I36ec6bad7096e5de666ac6500c8419fc6e383ae1
Gerrit-Change-Number: 69925
Gerrit-PatchSet: 5
Gerrit-Owner: Stanley Wu <stanley1.wu(a)lcfc.corp-partner.google.com>
Gerrit-Reviewer: Derek Huang <derekhuang(a)google.com>
Gerrit-Reviewer: Jamie Chen <jamie.chen(a)intel.com>
Gerrit-Reviewer: Jamie Chen <jamie.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Marco Chen <marcochen(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-CC: Joey Peng <joey.peng(a)lcfc.corp-partner.google.com>
Gerrit-CC: Leo Chou <leo.chou(a)lcfc.corp-partner.google.com>
Gerrit-Attention: Jamie Chen <jamie.chen(a)intel.corp-partner.google.com>
Gerrit-Attention: Stanley Wu <stanley1.wu(a)lcfc.corp-partner.google.com>
Gerrit-Attention: Marco Chen <marcochen(a)google.com>
Gerrit-Attention: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Comment-Date: Mon, 28 Nov 2022 17:03:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Nico Huber has submitted this change. ( https://review.coreboot.org/c/libgfxinit/+/68108 )
Change subject: gma: Shuffle warning justifications to support old and new tooling
......................................................................
gma: Shuffle warning justifications to support old and new tooling
We annotate a check message because the actual behaviour of Power_Up_VGA
depends on the platform we compile for. For the same reason we have to
justify a warning that the annotation may be spurious. SPARK rules state
that the annotation has to directly follow the subprogram's body. Appa-
rently that also accounts for the warning justification, so move it
above the subprogram body.
Change-Id: I8f879e73b3ea43de7e10532fba6a9b2bb9eecfcf
Signed-off-by: Nico Huber <nico.h(a)gmx.de>
Reviewed-on: https://review.coreboot.org/c/libgfxinit/+/68108
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
---
M common/hw-gfx-gma.adb
1 file changed, 21 insertions(+), 2 deletions(-)
Approvals:
Nico Huber: Verified
Angel Pons: Looks good to me, approved
diff --git a/common/hw-gfx-gma.adb b/common/hw-gfx-gma.adb
index 851686e..87c8fb0 100644
--- a/common/hw-gfx-gma.adb
+++ b/common/hw-gfx-gma.adb
@@ -606,6 +606,8 @@
pragma Warnings
(GNATprove, Off, """Registers.Register_State"" * is not modified*",
Reason => "Power_Up_VGA is only effective in certain configurations.");
+ pragma Warnings
+ (GNATprove, Off, "no check message justified*", Reason => "see below");
procedure Power_Up_VGA
with
Refined_Global =>
@@ -627,8 +629,6 @@
begin
Power_And_Clocks.Power_Up (Cur_Configs, Fake_Config);
end Power_Up_VGA;
- pragma Warnings
- (GNATprove, Off, "no check message justified*", Reason => "see below");
pragma Annotate
(GNATprove, Intentional, "unused global",
"Power_Up_VGA is only effective in certain configurations.");
--
To view, visit https://review.coreboot.org/c/libgfxinit/+/68108
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: libgfxinit
Gerrit-Branch: master
Gerrit-Change-Id: I8f879e73b3ea43de7e10532fba6a9b2bb9eecfcf
Gerrit-Change-Number: 68108
Gerrit-PatchSet: 2
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: merged
Attention is currently required from: Tim Wawrzynczak.
Sven van Ashbrook has uploaded a new patch set (#2) to the change originally created by Gaggery Tsai. ( https://review.coreboot.org/c/coreboot/+/68526 )
Change subject: mb/google/brya: Enable crashlog
......................................................................
mb/google/brya: Enable crashlog
This patch enables crashlog for all brya projects.
BUG=b:190756531
BRANCH=None
TEST=emerge-brya coreboot chromeos-bootimage & ensure the crashlog
PCIe device 0xa.0 is enabled and intel-pmt kernel driver is
loaded.
Signed-off-by: Gaggery Tsai <gaggery.tsai(a)intel.com>
Change-Id: Ib632c8ac9ea7a4f0e0b08b96eb149f8ef1386be0
---
M src/mainboard/google/brya/Kconfig
1 file changed, 19 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/26/68526/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/68526
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ib632c8ac9ea7a4f0e0b08b96eb149f8ef1386be0
Gerrit-Change-Number: 68526
Gerrit-PatchSet: 2
Gerrit-Owner: Gaggery Tsai <gaggery.tsai(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-MessageType: newpatchset
Nico Huber has submitted this change. ( https://review.coreboot.org/c/libgfxinit/+/68107 )
Change subject: display probing: Update warning justification
......................................................................
display probing: Update warning justification
The wording for the unused-assignment warning changed. To support
both older and newer version of GNATprove, add another justification
to the existing one.
Change-Id: I832d40a8e515eff63be2b196b18ca7b6f0114914
Signed-off-by: Nico Huber <nico.h(a)gmx.de>
Reviewed-on: https://review.coreboot.org/c/libgfxinit/+/68107
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
---
M common/hw-gfx-gma-display_probing.adb
1 file changed, 19 insertions(+), 0 deletions(-)
Approvals:
Nico Huber: Verified
Angel Pons: Looks good to me, approved
diff --git a/common/hw-gfx-gma-display_probing.adb b/common/hw-gfx-gma-display_probing.adb
index 79421c9..67f8ddf 100644
--- a/common/hw-gfx-gma-display_probing.adb
+++ b/common/hw-gfx-gma-display_probing.adb
@@ -132,6 +132,8 @@
pragma Warnings (GNATprove, Off, "unused assignment to ""Raw_EDID""",
Reason => "We just want to check if it's readable.");
+ pragma Warnings (GNATprove, Off, """Raw_EDID"" is set by * but*",
+ Reason => "We just want to check if it's readable.");
if Has_Sibling_Port (Port) then
-- Probe sibling port too and bail out if something is detected.
-- This is a precaution for adapters that expose the pins of a
@@ -148,6 +150,7 @@
end if;
end;
end if;
+ pragma Warnings (GNATprove, On, """Raw_EDID"" is set by * but*");
pragma Warnings (GNATprove, On, "unused assignment to ""Raw_EDID""");
else
Success := False;
--
To view, visit https://review.coreboot.org/c/libgfxinit/+/68107
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: libgfxinit
Gerrit-Branch: master
Gerrit-Change-Id: I832d40a8e515eff63be2b196b18ca7b6f0114914
Gerrit-Change-Number: 68107
Gerrit-PatchSet: 2
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: merged
Nico Huber has submitted this change. ( https://review.coreboot.org/c/libgfxinit/+/68105 )
(
1 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: dp info: Provide Link_Status'Object_Size and padding
......................................................................
dp info: Provide Link_Status'Object_Size and padding
We convert a plane byte buffer to a `Link_Status` object via an
`Unchecked_Conversion`. While the situation is actually clear
to the compiler because of the record representation clause for
`Link_Status`, SPARK rules demand an explicit `'Object_Size`.
The `'Object_Size` attribute specifies the exact size the
compiler should allocate for objects of the given type. The
`Padding` field is added to fill the gap left by reserved
bits.
Change-Id: Id7f6b9f50105d9357adcb60fd551b719d9eccd30
Signed-off-by: Nico Huber <nico.h(a)gmx.de>
Reviewed-on: https://review.coreboot.org/c/libgfxinit/+/68105
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
---
M common/hw-gfx-dp_info.adb
M common/hw-gfx-dp_info.ads
2 files changed, 30 insertions(+), 1 deletion(-)
Approvals:
Nico Huber: Verified
Angel Pons: Looks good to me, approved
diff --git a/common/hw-gfx-dp_info.adb b/common/hw-gfx-dp_info.adb
index 392fee1..74e77a2 100644
--- a/common/hw-gfx-dp_info.adb
+++ b/common/hw-gfx-dp_info.adb
@@ -356,7 +356,9 @@
Success : out Boolean)
is
subtype Status_Index is DP_Defs.Aux_Payload_Index range 0 .. 5;
- subtype Status_Buffer is Buffer (Status_Index);
+ subtype Status_Buffer is Buffer (Status_Index)
+ with
+ Object_Size => 48;
function Buffer_As_Status is new Ada.Unchecked_Conversion
(Source => Status_Buffer, Target => Link_Status);
diff --git a/common/hw-gfx-dp_info.ads b/common/hw-gfx-dp_info.ads
index 6d22bcc..732894b 100644
--- a/common/hw-gfx-dp_info.ads
+++ b/common/hw-gfx-dp_info.ads
@@ -63,16 +63,21 @@
type Adjust_Requests_Array is array (Lane_Index) of Adjust_Request;
pragma Pack (Adjust_Requests_Array);
+ type Link_Status_Padding is mod 2**15;
type Link_Status is record
Lanes : Lanes_Status;
Interlane_Align_Done : Boolean;
+ Padding : Link_Status_Padding;
Adjust_Requests : Adjust_Requests_Array;
end record;
for Link_Status use record
Lanes at 16#00# range 0 .. 15;
Interlane_Align_Done at 16#02# range 0 .. 0;
+ Padding at 16#02# range 1 .. 15;
Adjust_Requests at 16#04# range 0 .. 15;
end record;
+ for Link_Status'Size use 48;
+ for Link_Status'Object_Size use 48;
----------------------------------------------------------------------------
--
To view, visit https://review.coreboot.org/c/libgfxinit/+/68105
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: libgfxinit
Gerrit-Branch: master
Gerrit-Change-Id: Id7f6b9f50105d9357adcb60fd551b719d9eccd30
Gerrit-Change-Number: 68105
Gerrit-PatchSet: 3
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Attention is currently required from: Jason Glenesk, Raul Rangel, Matt DeVillier, Angel Pons, Martin Roth, Fred Reitberger, Karthik Ramasubramanian, Felix Held.
Robert Zieba has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/67938 )
Change subject: soc/amd/mendocino: Set up SoC-specific XHCI defines
......................................................................
Patch Set 10:
(4 comments)
File src/soc/amd/mendocino/Kconfig:
https://review.coreboot.org/c/coreboot/+/67938/comment/4738bfd1_7202fe7c
PS7, Line 51: select SMM_PCI_BAR_STORE
> Put this in the amd/common XHCI Kconfig?
Done
File src/soc/amd/mendocino/xhci.c:
PS7:
> Different CL please
Done
File src/soc/amd/mendocino/xhci_elog.c:
https://review.coreboot.org/c/coreboot/+/67938/comment/353c661a_6dd8d7f0
PS7, Line 6:
> Does this need to be a struct that's defined in a C file? The preference for these sorts of things […]
`DEV_PTR` can't be used to initialize static structs so I've restructured the code to use defines instead.
https://review.coreboot.org/c/coreboot/+/67938/comment/b385a9a1_3bb17971
PS7, Line 9: .usb2_port_status_reg = 0x420,
: .num_usb2_ports = 2,
: .usb3_port_status_reg = 0x440,
: .num_usb3_ports = 1
> Why the magic numbers? We can use the functions in https://source.chromium. […]
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/67938
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I16c789ff673c26ded84e4d46ab6dc743f33c5bb7
Gerrit-Change-Number: 67938
Gerrit-PatchSet: 10
Gerrit-Owner: Robert Zieba <robertzieba(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 28 Nov 2022 16:49:04 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Comment-In-Reply-To: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Raul Rangel, Matt DeVillier, Paul Menzel, Fred Reitberger, Felix Held.
Robert Zieba has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69916 )
Change subject: soc/amd/mendocino: Update XHCI GPE to use constant
......................................................................
Patch Set 3:
(4 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69916/comment/8ba22678_fec29b60
PS2, Line 9: The GPE number used for XHCI has now been defined
: in AMD's common code.
> Please reference the commit.
Done
https://review.coreboot.org/c/coreboot/+/69916/comment/a7184e1d_7120d9ba
PS2, Line 10: This commit changes
> This is redundant, and imperative mood could be used. […]
Done
https://review.coreboot.org/c/coreboot/+/69916/comment/9c31220a_fb0ce304
PS2, Line 9: The GPE number used for XHCI has now been defined
: in AMD's common code. This commit changes over existing
: code to use this new definition.
> Please reflow for 72 characters per line. (It fits in two lines. […]
Done
File src/soc/amd/common/block/xhci/elog.c:
https://review.coreboot.org/c/coreboot/+/69916/comment/3ab8d1ba_fbd98a41
PS2, Line 56: switch (protocol->major_rev) {
> This seems like a separate bug fix. Please split it into a separate commit.
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/69916
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3bfc2256ea2ca851afe88f2cdb419f39eee76fdd
Gerrit-Change-Number: 69916
Gerrit-PatchSet: 3
Gerrit-Owner: Robert Zieba <robertzieba(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 28 Nov 2022 16:46:35 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: comment