Raul Rangel has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/56225 )
Change subject: soc/amd/common/block/apob: Fix incorrect printf format
......................................................................
soc/amd/common/block/apob: Fix incorrect printf format
The %p format specifier already prints out 0x, so remove the 0x from the
string. I also updated the other format specifiers to use the %# syntax
to print out the 0x.
BUG=b:179699789
TEST=see correct format.
Signed-off-by: Raul E Rangel <rrangel(a)chromium.org>
Change-Id: I5b00d2c06687e549f69486eb5e18f7bed560b2ec
---
M src/soc/amd/common/block/apob/apob_cache.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/25/56225/1
diff --git a/src/soc/amd/common/block/apob/apob_cache.c b/src/soc/amd/common/block/apob/apob_cache.c
index 238ae7a..34d5472 100644
--- a/src/soc/amd/common/block/apob/apob_cache.c
+++ b/src/soc/amd/common/block/apob/apob_cache.c
@@ -131,7 +131,7 @@
return;
}
- printk(BIOS_SPEW, "Copy APOB from RAM 0x%p/0x%x to flash 0x%zx/0x%zx\n",
+ printk(BIOS_SPEW, "Copy APOB from RAM %p/%#x to flash %#zx/%#zx\n",
apob_src_ram, apob_src_ram->size,
region_offset(®ion), region_sz(®ion));
--
To view, visit https://review.coreboot.org/c/coreboot/+/56225
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5b00d2c06687e549f69486eb5e18f7bed560b2ec
Gerrit-Change-Number: 56225
Gerrit-PatchSet: 1
Gerrit-Owner: Raul Rangel <rrangel(a)chromium.org>
Gerrit-MessageType: newchange
Patrick Georgi has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/56224 )
Change subject: [DO NOT SUBMIT] util/kconfig: Get more information on failure
......................................................................
Abandoned
not needed anymore
--
To view, visit https://review.coreboot.org/c/coreboot/+/56224
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I26a32836fea7cf42d3c0ca3f9398e566d69690da
Gerrit-Change-Number: 56224
Gerrit-PatchSet: 1
Gerrit-Owner: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: abandon
Attention is currently required from: Ravi kumar, Julius Werner, mturney mturney.
Shelley Chen has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/55959 )
Change subject: trogdor: sc7180: Rename header files as per common QUP driver changes
......................................................................
Patch Set 5:
(3 comments)
Patchset:
PS5:
This CL seems like it should be split among the various sc7180 refactors previously in the CL stack. Please split it out accordingly so we don't get into a state where sc7180 is in a broken state.
File src/mainboard/google/trogdor/bootblock.c:
https://review.coreboot.org/c/coreboot/+/55959/comment/0569df8f_664c15f6
PS5, Line 5: #include <soc/qupv3_spi_common.h>
Shouldn't this be included in the sc7180 spi driver refactor? Otherwise it won't compile at this point...
File src/mainboard/google/trogdor/mainboard.c:
https://review.coreboot.org/c/coreboot/+/55959/comment/05456ada_11e6e94a
PS5, Line 12: #include <soc/qupv3_config_common.h>
Seems like these should be included in their respective sc7180 driver refactors. Otherwise sc7180 will be at a point where it won't compile anymore.
--
To view, visit https://review.coreboot.org/c/coreboot/+/55959
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I36a4f28b77e3942a4c6069b1785b0c6ac5b7e0a2
Gerrit-Change-Number: 55959
Gerrit-PatchSet: 5
Gerrit-Owner: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: mturney mturney <mturney(a)codeaurora.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rajesh Patil <rajpat(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Ravi Kumar Bokka <c_rbokka(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Roja Rani Yarubandi <c_rojay(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: mturney mturney <mturney(a)codeaurora.org>
Gerrit-Comment-Date: Mon, 12 Jul 2021 21:49:17 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/56187 )
Change subject: security/intel/txt: use mca_get_bank_count()
......................................................................
security/intel/txt: use mca_get_bank_count()
Use the common mca_get_bank_count function instead of open-coding the
functionality to get the MCA bank number.
Change-Id: I28244c975ee34d36d0b44df092d4a62a01c3c79c
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/56187
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Marshall Dawson <marshalldawson3rd(a)gmail.com>
---
M src/security/intel/txt/common.c
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
build bot (Jenkins): Verified
Marshall Dawson: Looks good to me, approved
diff --git a/src/security/intel/txt/common.c b/src/security/intel/txt/common.c
index 239e152..011e8cc 100644
--- a/src/security/intel/txt/common.c
+++ b/src/security/intel/txt/common.c
@@ -481,8 +481,7 @@
* Make sure there are no uncorrectable MCE errors.
* Intel 64 and IA-32 Architectures Software Developer Manuals Vol 2D
*/
- msr = rdmsr(IA32_MCG_CAP);
- size_t max_mc_msr = msr.lo & MCA_BANKS_MASK;
+ size_t max_mc_msr = mca_get_bank_count();
for (size_t i = 0; i < max_mc_msr; i++) {
msr = rdmsr(IA32_MC0_STATUS + 4 * i);
if (!(msr.hi & MCA_STATUS_HI_UC))
--
To view, visit https://review.coreboot.org/c/coreboot/+/56187
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I28244c975ee34d36d0b44df092d4a62a01c3c79c
Gerrit-Change-Number: 56187
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Philipp Deppenwiese <philipp.deppenwiese(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Attention is currently required from: Ravi kumar, mturney mturney, Julius Werner.
Shelley Chen has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/55954 )
Change subject: soc/qualcomm/common/uart: Add support for UART common driver
......................................................................
Patch Set 5:
(1 comment)
Patchset:
PS5:
Can you put in the commit message that these files were copied over from soc/qualcomm/sc7180 so people know that you are just moving code as opposed to creating brand new code?
--
To view, visit https://review.coreboot.org/c/coreboot/+/55954
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7bc2d3765f956e04bae3e45c3a9b9e2ad424c7b1
Gerrit-Change-Number: 55954
Gerrit-PatchSet: 5
Gerrit-Owner: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: mturney mturney <mturney(a)codeaurora.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rajesh Patil <rajpat(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Ravi Kumar Bokka <c_rbokka(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Roja Rani Yarubandi <c_rojay(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Attention: mturney mturney <mturney(a)codeaurora.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Comment-Date: Mon, 12 Jul 2021 21:37:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Ravi kumar, mturney mturney, Julius Werner.
Shelley Chen has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/55957 )
Change subject: sc7180: Refactor SPI driver
......................................................................
Patch Set 5:
(1 comment)
Patchset:
PS5:
Can you put in the commit message that these files were copied over from soc/qualcomm/sc7180 so people know that you are just moving code as opposed to creating brand new code?
--
To view, visit https://review.coreboot.org/c/coreboot/+/55957
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I0c57f8650271287a1b3ccce9bd62fce6987d785e
Gerrit-Change-Number: 55957
Gerrit-PatchSet: 5
Gerrit-Owner: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: mturney mturney <mturney(a)codeaurora.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rajesh Patil <rajpat(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Ravi Kumar Bokka <c_rbokka(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Roja Rani Yarubandi <c_rojay(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Ravi kumar <rbokka(a)codeaurora.org>
Gerrit-Attention: mturney mturney <mturney(a)codeaurora.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Comment-Date: Mon, 12 Jul 2021 21:35:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer.
Felix Singer has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/56219 )
Change subject: mb/intel/kblrvp: Rework Kconfig
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/56219
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I2a9c12a15c098fcb64c006a707c94a1aed93d73a
Gerrit-Change-Number: 56219
Gerrit-PatchSet: 3
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Comment-Date: Mon, 12 Jul 2021 21:34:57 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment