Attention is currently required from: Furquan Shaikh, Angel Pons, Subrata Banik, Aaron Durbin.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51445 )
Change subject: timestamp: Add helper fucntions
......................................................................
Patch Set 3:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/51445/comment/6d5896cd_ef968479
PS3, Line 7: Add helper fucntions
> > ... and for this you need some way to add relative ones. […]
Yes, I think timestamp_add_relative() sounds a bit better.
--
To view, visit https://review.coreboot.org/c/coreboot/+/51445
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6b7065ed26e231fc898ae44bcc15cba6fb42b308
Gerrit-Change-Number: 51445
Gerrit-PatchSet: 3
Gerrit-Owner: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Comment-Date: Wed, 07 Apr 2021 23:16:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Julius Werner, Angel Pons, Subrata Banik, Aaron Durbin.
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51445 )
Change subject: timestamp: Add helper fucntions
......................................................................
Patch Set 3:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/51445/comment/f58c7349_1ae27c62
PS3, Line 7: Add helper fucntions
> ... and for this you need some way to add relative ones.
Do you think `timestamp_add_relative()` is clearer than `timestamp_add_time_from_base()`? Shorter names are easier to read too, but I was afraid if it seemed too ambiguous.
> BTW, am I seeing this right that in this particular case, your rewind_base() would cause ts->base_time to underflow and become a large positive uint64_t?
Your observation is absolutely right. I had noticed this when reading the picasso/ code(it already underflows base_time), but like you said, it should still work out and we never really should see values wrapping around, so it isn't a problem. But I agree with you that it looks a little weird and changing to int64_t might be better. We can fix that as part of this effort.
--
To view, visit https://review.coreboot.org/c/coreboot/+/51445
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6b7065ed26e231fc898ae44bcc15cba6fb42b308
Gerrit-Change-Number: 51445
Gerrit-PatchSet: 3
Gerrit-Owner: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Comment-Date: Wed, 07 Apr 2021 23:08:11 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Furquan Shaikh, Angel Pons, Subrata Banik, Aaron Durbin.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51445 )
Change subject: timestamp: Add helper fucntions
......................................................................
Patch Set 3:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/51445/comment/5feb4718_d84d75d9
PS3, Line 7: Add helper fucntions
> > I think the time_from_base in your naming is confusing, because all timestamp_add()s are relative […]
Sorry, yeah, I confused myself somehow there. You're right that we currently add absolute timestamps and for this you need some way to add relative ones. Switching to microseconds won't change that (although it would remove the need for extra frequency arguments everywhere).
(BTW, am I seeing this right that in this particular case, your rewind_base() would cause ts->base_time to underflow and become a large positive uint64_t? I guess fundamentally that should still work out right in the end, but it looks a bit weird. Maybe we should consider changing it to int64_t if we do that?)
--
To view, visit https://review.coreboot.org/c/coreboot/+/51445
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6b7065ed26e231fc898ae44bcc15cba6fb42b308
Gerrit-Change-Number: 51445
Gerrit-PatchSet: 3
Gerrit-Owner: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Comment-Date: Wed, 07 Apr 2021 22:58:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Martin Roth, Marshall Dawson, Karthik Ramasubramanian.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51924 )
Change subject: soc/amd/common: Handle power resume after power failure
......................................................................
Patch Set 6:
(1 comment)
File src/soc/amd/common/block/pm/Kconfig:
https://review.coreboot.org/c/coreboot/+/51924/comment/2da90b30_d2659c74
PS6, Line 10: config POWER_STATE_DEFAULT_ON_AFTER_FAILURE
isn't this already defined in the mainboard directory\s kconfig? not sure if this needs to be written here again; i'd assume that just selecting it in the block above should be sufficient
--
To view, visit https://review.coreboot.org/c/coreboot/+/51924
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iea4ea57d747425fe6714d40ba6e60f2447febf28
Gerrit-Change-Number: 51924
Gerrit-PatchSet: 6
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Wed, 07 Apr 2021 22:55:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/52045 )
Change subject: mb/amd/majolica: add PCIe devices to devicetree
......................................................................
mb/amd/majolica: add PCIe devices to devicetree
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Change-Id: I838aeda2e6c403eaa3388a6b934e7ab6b4e918e3
Reviewed-on: https://review.coreboot.org/c/coreboot/+/52045
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Raul Rangel <rrangel(a)chromium.org>
---
M src/mainboard/amd/majolica/devicetree.cb
1 file changed, 7 insertions(+), 0 deletions(-)
Approvals:
build bot (Jenkins): Verified
Raul Rangel: Looks good to me, approved
diff --git a/src/mainboard/amd/majolica/devicetree.cb b/src/mainboard/amd/majolica/devicetree.cb
index 5efe709..088b259 100644
--- a/src/mainboard/amd/majolica/devicetree.cb
+++ b/src/mainboard/amd/majolica/devicetree.cb
@@ -15,6 +15,13 @@
}"
device domain 0 on
+ device ref gpp_gfx_bridge_0 on end # MXM
+ device ref gpp_bridge_0 on end # NVMe
+ device ref gpp_bridge_1 on end
+ device ref gpp_bridge_2 on end # WWAN
+ device ref gpp_bridge_3 on end # LAN
+ device ref gpp_bridge_4 on end # WLAN
+ device ref gpp_bridge_5 on end
device ref gpp_bridge_a on # Internal GPP Bridge 0 to Bus A
device ref gfx on end # Internal GPU (GFX)
device ref xhci_0 on # USB 3.1 (USB0)
--
To view, visit https://review.coreboot.org/c/coreboot/+/52045
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I838aeda2e6c403eaa3388a6b934e7ab6b4e918e3
Gerrit-Change-Number: 52045
Gerrit-PatchSet: 4
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: merged