Attention is currently required from: Jason Glenesk, Raul Rangel, Felix Held.
Hello build bot (Jenkins), Jason Glenesk, Raul Rangel, Marshall Dawson,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/50537
to look at the new patch set (#2).
Change subject: soc/amd/cezanne/smihandler: add psp_notify_smm call
......................................................................
soc/amd/cezanne/smihandler: add psp_notify_smm call
TEST=Majolica still gets to SeaBIOS. Like before this patch the PSP
still has the recovery flag set in its return value, but we likely still
miss some PSP initialization in FSP.
Change-Id: I9f343452ef2ea6b01f9b2fd0cf6371218d046046
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
---
M src/soc/amd/cezanne/smihandler.c
1 file changed, 5 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/37/50537/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/50537
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9f343452ef2ea6b01f9b2fd0cf6371218d046046
Gerrit-Change-Number: 50537
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: Jason Glenesk, Martin Roth, Angel Pons, Felix Held.
Raul Rangel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/50509 )
Change subject: soc/amd: Move southbridge_write_acpi_tables
......................................................................
Patch Set 1:
(1 comment)
File src/soc/amd/common/block/acpi/tables.c:
PS1:
> nit: rename to `acpi_tables. […]
It's already under the acpi directory, so acpi/acpi_tables.c seems redundant don't you agree?
--
To view, visit https://review.coreboot.org/c/coreboot/+/50509
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I361dfabfe0c04667a2c112955133831a985d5cc0
Gerrit-Change-Number: 50509
Gerrit-PatchSet: 1
Gerrit-Owner: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Thu, 11 Feb 2021 16:23:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/50486 )
Change subject: soc/amd/*/smihandler: use size_t and unsigned int
......................................................................
soc/amd/*/smihandler: use size_t and unsigned int
signed int should only be used when we need negative values and in those
cases the value shouldn't became negative.
Change-Id: Iefac021260ff363c76bf5cd3fe3619ea1dbabdba
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/50486
Reviewed-by: Martin Roth <martinroth(a)google.com>
Reviewed-by: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M src/soc/amd/picasso/smihandler.c
M src/soc/amd/stoneyridge/smihandler.c
2 files changed, 6 insertions(+), 4 deletions(-)
Approvals:
build bot (Jenkins): Verified
Martin Roth: Looks good to me, approved
Marshall Dawson: Looks good to me, approved
diff --git a/src/soc/amd/picasso/smihandler.c b/src/soc/amd/picasso/smihandler.c
index 735fd77..d478aad 100644
--- a/src/soc/amd/picasso/smihandler.c
+++ b/src/soc/amd/picasso/smihandler.c
@@ -18,6 +18,7 @@
#include <amdblocks/smm.h>
#include <elog.h>
#include <soc/smu.h>
+#include <types.h>
/* bits in smm_io_trap */
#define SMM_IO_TRAP_PORT_OFFSET 16
@@ -33,7 +34,7 @@
static void *find_save_state(int cmd)
{
- int core;
+ unsigned int core;
amd64_smm_state_save_area_t *state;
u32 smm_io_trap;
u8 reg_al;
@@ -225,7 +226,7 @@
void *get_smi_source_handler(int source)
{
- int i;
+ size_t i;
for (i = 0 ; i < ARRAY_SIZE(smi_sources) ; i++)
if (smi_sources[i].type == source)
diff --git a/src/soc/amd/stoneyridge/smihandler.c b/src/soc/amd/stoneyridge/smihandler.c
index 3a65f55..23951b2 100644
--- a/src/soc/amd/stoneyridge/smihandler.c
+++ b/src/soc/amd/stoneyridge/smihandler.c
@@ -16,6 +16,7 @@
#include <amdblocks/smi.h>
#include <amdblocks/smm.h>
#include <elog.h>
+#include <types.h>
/* bits in smm_io_trap */
#define SMM_IO_TRAP_PORT_OFFSET 16
@@ -31,7 +32,7 @@
static void *find_save_state(int cmd)
{
- int core;
+ unsigned int core;
amd64_smm_state_save_area_t *state;
u32 smm_io_trap;
u8 reg_al;
@@ -220,7 +221,7 @@
void *get_smi_source_handler(int source)
{
- int i;
+ size_t i;
for (i = 0 ; i < ARRAY_SIZE(smi_sources) ; i++)
if (smi_sources[i].type == source)
--
To view, visit https://review.coreboot.org/c/coreboot/+/50486
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iefac021260ff363c76bf5cd3fe3619ea1dbabdba
Gerrit-Change-Number: 50486
Gerrit-PatchSet: 4
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: merged
Attention is currently required from: Jason Glenesk, Marshall Dawson, Felix Held.
Raul Rangel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/50451 )
Change subject: soc/amd/cezanne: Add PCI IRQ Router definitions
......................................................................
Patch Set 2:
(2 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/50451/comment/013b1095_fa9aff95
PS2, Line 10: I renamed Misc1 and Misc2 to HPET_L and HPET_H.
> I'm struggling to find anything in the PPR to support this. […]
IOx00C01_x0A [Intr_Misc1Map] (FCH::IO::IntrMisc1Map)
7:0 HPET. Read-write. Reset: 00h. Writes to this register update the bits in
FCH::TMR::HPET::TMR0_CONF_CAP_H [7:0], FCH::TMR::HPET::TMR1_CONF_CAP_H [7:0] and
FCH::TMR::HPET::TMR2_CONF_CAP_H [7:0];
IOx00C01_x0B [Intr_Misc2Map] (FCH::IO::IntrMisc2Map)
HPET. Read-write. Reset: 00h. Writes to this register update this bits in
FCH::TMR::HPET::TMR0_CONF_CAP_H [15:8], FCH::TMR::HPET::TMR1_CONF_CAP_H [15:8] and
FCH::TMR::HPET::TMR2_CONF_CAP_H [15:8];
HPETx00000104 (FCH::TMR::HPET::TMR0_CONF_CAP_H)
31:0 tmrintroutecap. Read-only. Reset: 00C0_0000h. Indicates which INT entry of IoAPIC can be assigned to the
timer interrupt. Read only.
I never knew how the HPET was configured to route interrupts until I actually read the Misc descriptions.
Should I rename HPET_X to something else?
File src/soc/amd/cezanne/include/soc/amd_pci_int_defs.h:
https://review.coreboot.org/c/coreboot/+/50451/comment/946e85ce_0aa4545a
PS1, Line 61: #define PIRQ_UART2 0x78 /* UART2 */
: #define PIRQ_UART3 0x79 /* UART3 */
> By don't exist, do you perhaps mean that they're not pinned out for FP6 and are made unavailable? ( […]
There are only 2 UARTs on the device: UARTx[A:9]000
I can mark these as reserved if you have sent a request to update the PPR.
--
To view, visit https://review.coreboot.org/c/coreboot/+/50451
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic7e637f234d3af426959a9bbd82a0dcf25bb3c8e
Gerrit-Change-Number: 50451
Gerrit-PatchSet: 2
Gerrit-Owner: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Thu, 11 Feb 2021 16:17:06 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Comment-In-Reply-To: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-MessageType: comment