Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/47653 )
Change subject: soc/intel/tigerlake: Define TCSS AUX pin bias control
......................................................................
Patch Set 3: -Code-Review
(2 comments)
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
File src/soc/intel/tigerlake/include/soc/early_tcss.h:
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 106: 0x09000000
> What is this value? And how was it determined?
A chipset specific constant that the FSP consumes; it looks like it will ignore values that don't have this in the upper byte
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 109: (((group) & 0xff) << 16) | ((pin) & 0xff))
> In my opinion, rather than doing this in all macros and expecting mainboard to know group # pin #, i […]
That's even cleaner, I like it.
--
To view, visit https://review.coreboot.org/c/coreboot/+/47653
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I001aede139c2503ce9cae3af8d625624ff6e1af7
Gerrit-Change-Number: 47653
Gerrit-PatchSet: 3
Gerrit-Owner: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Brandon Breitenstein <brandon.breitenstein(a)intel.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Furquan Shaikh <furquan(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Fri, 20 Nov 2020 18:23:36 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Gerrit-MessageType: comment
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/47653 )
Change subject: soc/intel/tigerlake: Define TCSS AUX pin bias control
......................................................................
Patch Set 3:
(5 comments)
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
File src/soc/intel/tigerlake/include/soc/early_tcss.h:
PS3:
Probably should rename the file to tcss.h since it is not just used for early_tcss support any more.
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 106: 0x09000000
What is this value? And how was it determined?
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 108: group
I am guessing this is pad group? A comment here would be very helpful.
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 108: pin
Is this relative offset of the pad within the group?
https://review.coreboot.org/c/coreboot/+/47653/3/src/soc/intel/tigerlake/in…
PS3, Line 109: (((group) & 0xff) << 16) | ((pin) & 0xff))
In my opinion, rather than doing this in all macros and expecting mainboard to know group # pin #, it would be better to have clearly named fields in chip.h instead of IomTypeCPortPadConfig (https://source.chromium.org/chromiumos/chromiumos/codesearch/+/master:src/t…):
Probably something like this:
int tcss_bias_ctrl_pad[MAX_TCSS_PORTS];
And the mainboard only needs to set something like:
register "tcss_bias_ctrl_pad[0]" = "GPP_E10"
register "tcss_bias_ctrl_pad[1]" = "GPP_E13"
and the rest of the calculations to convert this into the values expected by FSP can be handled by the SoC code.
In fact, you can also make this more organized by combining the information into a structure for pad and orientation:
struct tcss_config {
bool bias_control_enable;
int bias_control_pad;
uint8_t orientation;
bool enable_internal_mux;
} [MAX_TCSS_PORTS];
And mainboard can have:
register "tcss_config[0]" = "{
.bias_control_enable = true,
.bias_control_pad = GPP_E10,
.orientation = IOM_TCSS_ORI_NORMAL,
.enable_internal_mux = true,
}"
And the variants that don't need this don't really need to do anything since bias_control_enable and enable_internal_mux will default to false.
--
To view, visit https://review.coreboot.org/c/coreboot/+/47653
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I001aede139c2503ce9cae3af8d625624ff6e1af7
Gerrit-Change-Number: 47653
Gerrit-PatchSet: 3
Gerrit-Owner: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Brandon Breitenstein <brandon.breitenstein(a)intel.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Furquan Shaikh <furquan(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Fri, 20 Nov 2020 17:59:55 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Marshall Dawson has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/47727 )
Change subject: soc/amd/picasso: Generate ACPI CRAT objects in cb
......................................................................
Patch Set 3:
(1 comment)
https://review.coreboot.org/c/coreboot/+/47727/3/src/include/acpi/acpi.h
File src/include/acpi/acpi.h:
https://review.coreboot.org/c/coreboot/+/47727/3/src/include/acpi/acpi.h@311
PS3, Line 311: struct acpi_crat_header
> not using typedefs here might not be completely consistent, but is the better option in the long run […]
I agree with the argument about not using typedefs (not to mention using name_t). However in this case, I think it will help readability and consistency because it matches the rest of the file, with one other excption. It also makes the callers to all these functions appear consistent with each other.
IMO it would be better to revamp this entire file as one effort or topic vs. addressing it piecemeal.
--
To view, visit https://review.coreboot.org/c/coreboot/+/47727
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If64fd624597b2ced014ba7f0332a6a48143c0e8c
Gerrit-Change-Number: 47727
Gerrit-PatchSet: 3
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Justin Frodsham <justin.frodsham(a)protonmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Matt Papageorge <matthewpapa07(a)gmail.com>
Gerrit-Reviewer: Nikolai Vyssotski <nikolai.vyssotski(a)amd.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Fri, 20 Nov 2020 16:09:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-MessageType: comment
Maxim Polyakov has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/42609 )
Change subject: Makefile.inc: Add CARRIER_DIR to component discovery
......................................................................
Makefile.inc: Add CARRIER_DIR to component discovery
The configuration of the COMe module contains an additional carriers
directory, which contains the source codes for configuration for the
different carrierboards into which this module is plugged. Let's take
this into account in the build system to use CARRIER_DIR to select the
type of board in the local Makefile.inc, as it has done for VARIANT_DIR.
Used to build an image for the Kontron COMe-mAL10 module together with
the Kontron Ref.Carrier-i T10 TNI.
Change-Id: Ic6b2f8994b1293ae6f5bda8c9cc95128ba0abf7a
Signed-off-by: Maxim Polyakov <max.senia.poliak(a)gmail.com>
---
M Makefile.inc
1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/09/42609/1
diff --git a/Makefile.inc b/Makefile.inc
index 86335d9..0f9d635 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -34,6 +34,7 @@
# Basic component discovery
MAINBOARDDIR=$(call strip_quotes,$(CONFIG_MAINBOARD_DIR))
VARIANT_DIR:=$(call strip_quotes,$(CONFIG_VARIANT_DIR))
+CARRIER_DIR:=$(call strip_quotes,$(CONFIG_CARRIER_DIR))
COREBOOT_EXPORTS += MAINBOARDDIR VARIANT_DIR
## Final build results, which CBFSTOOL uses to create the final
--
To view, visit https://review.coreboot.org/c/coreboot/+/42609
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic6b2f8994b1293ae6f5bda8c9cc95128ba0abf7a
Gerrit-Change-Number: 42609
Gerrit-PatchSet: 1
Gerrit-Owner: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-MessageType: newchange