Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46588 )
Change subject: cpu/intel/common: rework code previously moved to common cpu code
......................................................................
Patch Set 3:
(1 comment)
https://review.coreboot.org/c/coreboot/+/46588/3/src/include/cpu/x86/msr.h
File src/include/cpu/x86/msr.h:
https://review.coreboot.org/c/coreboot/+/46588/3/src/include/cpu/x86/msr.h@…
PS3, Line 24: #define CPUID_EPP (1 << 3)
Should be named after it's location, e.g. CPUID_6_ECX_SOMETHING.
Is it really about EPP?
And it looks like a completely random location? Even for the entries
below... they are bits in cpuid(1).ecx AFAICT.
--
To view, visit https://review.coreboot.org/c/coreboot/+/46588
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7615fc26625c44931577216ea42f0a733b99e131
Gerrit-Change-Number: 46588
Gerrit-PatchSet: 3
Gerrit-Owner: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 20 Oct 2020 21:45:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45747 )
Change subject: soc/intel/tigerlake: Replace soc_get_pmc_mux_device with device pointers
......................................................................
Patch Set 8:
> Patch Set 7:
>
> Just curious: Should the device tree update go together with this CL? If that CL gets delayed for some unknown reason, will this CL break any functionality?
Not yet, we haven't fully switched to using the type-c connector class
--
To view, visit https://review.coreboot.org/c/coreboot/+/45747
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie00834c79bd5304998adaccb388ae74a108192b1
Gerrit-Change-Number: 45747
Gerrit-PatchSet: 8
Gerrit-Owner: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Tue, 20 Oct 2020 21:36:44 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Tim Wawrzynczak has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/45877 )
Change subject: acpi: Skip writing references for disabled devices in Type-C config
......................................................................
acpi: Skip writing references for disabled devices in Type-C config
When emitting ACPI tables for the Type-C connector class, skip writing
out a device reference if it is to a disabled device.
Signed-off-by: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Change-Id: I84cc3e1a54e2b654239ad6e1a4662d582f3465cf
---
M src/acpi/acpigen_usb.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/77/45877/1
diff --git a/src/acpi/acpigen_usb.c b/src/acpi/acpigen_usb.c
index 90a9b77..7448b3b 100644
--- a/src/acpi/acpigen_usb.c
+++ b/src/acpi/acpigen_usb.c
@@ -71,7 +71,7 @@
const char *path;
char *fresh;
- if (!dev)
+ if (!dev || !dev->enabled)
return;
/*
--
To view, visit https://review.coreboot.org/c/coreboot/+/45877
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I84cc3e1a54e2b654239ad6e1a4662d582f3465cf
Gerrit-Change-Number: 45877
Gerrit-PatchSet: 1
Gerrit-Owner: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-MessageType: newchange
Hello build bot (Jenkins), Furquan Shaikh, Caveh Jalali, Duncan Laurie, Nick Vaccaro, Patrick Rudolph, Karthik Ramasubramanian,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/45747
to look at the new patch set (#8).
Change subject: soc/intel/tigerlake: Replace soc_get_pmc_mux_device with device pointers
......................................................................
soc/intel/tigerlake: Replace soc_get_pmc_mux_device with device pointers
Now that device aliases can be used in the devicetree, the hacky function
'soc_get_pmc_mux_device' can be removed and replaced with pointers to the
devices the function was supposed to return (1 for each port).
Signed-off-by: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Change-Id: Ie00834c79bd5304998adaccb388ae74a108192b1
---
M src/ec/google/chromeec/chip.h
M src/ec/google/chromeec/ec_acpi.c
M src/soc/intel/common/block/include/intelblocks/pmc.h
M src/soc/intel/tigerlake/pmc.c
4 files changed, 13 insertions(+), 72 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/47/45747/8
--
To view, visit https://review.coreboot.org/c/coreboot/+/45747
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie00834c79bd5304998adaccb388ae74a108192b1
Gerrit-Change-Number: 45747
Gerrit-PatchSet: 8
Gerrit-Owner: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: newpatchset