Hello Arthur Heymans, Matt DeVillier, build bot (Jenkins), Nico Huber,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/19931
to look at the new patch set (#3).
Change subject: purism/librem13v1: Rename librem13 to librem13v1
......................................................................
purism/librem13v1: Rename librem13 to librem13v1
A simple rename of the directory and the config values
and string in Kconfig/Kconfig.name/board_info.txt
It will be less confusing for users since the first models
are referred to as 'v1' everywhere now.
Change-Id: I23fa977717230c2001868741bb684e9633a2c0bb
Signed-off-by: Youness Alaoui <youness.alaoui(a)puri.sm>
---
D src/mainboard/purism/librem13/Kconfig.name
D src/mainboard/purism/librem13/board_info.txt
R src/mainboard/purism/librem13v1/Kconfig
A src/mainboard/purism/librem13v1/Kconfig.name
R src/mainboard/purism/librem13v1/Makefile.inc
R src/mainboard/purism/librem13v1/acpi/ec.asl
R src/mainboard/purism/librem13v1/acpi/mainboard.asl
R src/mainboard/purism/librem13v1/acpi/superio.asl
R src/mainboard/purism/librem13v1/acpi_tables.c
A src/mainboard/purism/librem13v1/board_info.txt
R src/mainboard/purism/librem13v1/devicetree.cb
R src/mainboard/purism/librem13v1/dsdt.asl
R src/mainboard/purism/librem13v1/fadt.c
R src/mainboard/purism/librem13v1/gpio.h
R src/mainboard/purism/librem13v1/hda_verb.c
R src/mainboard/purism/librem13v1/mainboard.c
R src/mainboard/purism/librem13v1/pei_data.c
R src/mainboard/purism/librem13v1/romstage.c
18 files changed, 14 insertions(+), 14 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/31/19931/3
--
To view, visit https://review.coreboot.org/19931
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I23fa977717230c2001868741bb684e9633a2c0bb
Gerrit-PatchSet: 3
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Hello Matt DeVillier,
I'd like you to do a code review. Please visit
https://review.coreboot.org/19985
to review the following change.
Change subject: purism/librem13v1: Set FADT revision to ACPI 3.0
......................................................................
purism/librem13v1: Set FADT revision to ACPI 3.0
The FADT revision was set to 5, but we do not implement the
ACPI v5.0 specification, which prevented Windows from booting.
Setting it to v3 (matching most other boards) fixes the issue
and Windows now boots normally.
Bug found by Matt DeVillier, fix tested by Youness Alaoui on
Librem 13 v1 hardware.
Change-Id: Ide97cbf64f7b05018433436431ab4723b217fe22
Signed-off-by: Youness Alaoui <youness.alaoui(a)puri.sm>
Signed-off-by: Matt DeVillier <matt.devillier(a)gmail.com>
---
M src/mainboard/purism/librem13v1/fadt.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/85/19985/1
diff --git a/src/mainboard/purism/librem13v1/fadt.c b/src/mainboard/purism/librem13v1/fadt.c
index 980ff03..9cbcd3f 100644
--- a/src/mainboard/purism/librem13v1/fadt.c
+++ b/src/mainboard/purism/librem13v1/fadt.c
@@ -23,7 +23,7 @@
memset(fadt, 0, sizeof(acpi_fadt_t));
memcpy(header->signature, "FACP", 4);
header->length = sizeof(acpi_fadt_t);
- header->revision = 5;
+ header->revision = ACPI_FADT_REV_ACPI_3_0;
memcpy(header->oem_id, OEM_ID, 6);
memcpy(header->oem_table_id, ACPI_TABLE_CREATOR, 8);
memcpy(header->asl_compiler_id, ASLC, 4);
--
To view, visit https://review.coreboot.org/19985
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: Ide97cbf64f7b05018433436431ab4723b217fe22
Gerrit-PatchSet: 1
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Hello Arthur Heymans, Matt DeVillier, build bot (Jenkins), Nico Huber,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/19931
to look at the new patch set (#2).
Change subject: purism/librem13v1: Rename librem13 to librem13v1
......................................................................
purism/librem13v1: Rename librem13 to librem13v1
A simple rename of the directory and the config values
and string in Kconfig/Kconfig.name/board_info.txt
It will be less confusing for users since the first models
are referred to as 'v1' everywhere now.
Change-Id: I23fa977717230c2001868741bb684e9633a2c0bb
Signed-off-by: Youness Alaoui <youness.alaoui(a)puri.sm>
---
D src/mainboard/purism/librem13/Kconfig.name
R src/mainboard/purism/librem13v1/Kconfig
A src/mainboard/purism/librem13v1/Kconfig.name
R src/mainboard/purism/librem13v1/Makefile.inc
R src/mainboard/purism/librem13v1/acpi/ec.asl
R src/mainboard/purism/librem13v1/acpi/mainboard.asl
R src/mainboard/purism/librem13v1/acpi/superio.asl
R src/mainboard/purism/librem13v1/acpi_tables.c
R src/mainboard/purism/librem13v1/board_info.txt
R src/mainboard/purism/librem13v1/devicetree.cb
R src/mainboard/purism/librem13v1/dsdt.asl
R src/mainboard/purism/librem13v1/fadt.c
R src/mainboard/purism/librem13v1/gpio.h
R src/mainboard/purism/librem13v1/hda_verb.c
R src/mainboard/purism/librem13v1/mainboard.c
R src/mainboard/purism/librem13v1/pei_data.c
R src/mainboard/purism/librem13v1/romstage.c
17 files changed, 6 insertions(+), 6 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/31/19931/2
--
To view, visit https://review.coreboot.org/19931
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I23fa977717230c2001868741bb684e9633a2c0bb
Gerrit-PatchSet: 2
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Martin Roth has posted comments on this change. ( https://review.coreboot.org/19931 )
Change subject: purism/librem13v1: Rename librem13 to librem13v1
......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/#/c/19931/1/src/mainboard/purism/librem13v1/boa…
File src/mainboard/purism/librem13v1/board_info.txt:
Line 4: Board URL: https://puri.sm/librem-13/
> I don't think it's necessary to drop this, that URL is still better than no
Link to it through archive.org?
https://web.archive.org/web/20170105173944/https://puri.sm/products/librem-…
--
To view, visit https://review.coreboot.org/19931
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I23fa977717230c2001868741bb684e9633a2c0bb
Gerrit-PatchSet: 1
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Youness Alaoui <snifikino(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
Marshall Dawson has posted comments on this change. ( https://review.coreboot.org/19983 )
Change subject: binaryPI: Define AGESA blob in CBFS as Kconfig string
......................................................................
Patch Set 1:
I like this change. I'd recommend also modifying vendorcode/amd/pi/Makefile.inc to use the config name (see the very bottom) where cbfs-files += AGESA.
--
To view, visit https://review.coreboot.org/19983
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I0f78cb275ecad732f81c609564a0640f03d2559e
Gerrit-PatchSet: 1
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Marc Jones <marc(a)marcjonesconsulting.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: No
Martin Roth has posted comments on this change. ( https://review.coreboot.org/19954 )
Change subject: sb/intel/bd82x6x/early_usb: Use register name
......................................................................
Patch Set 2: Code-Review+2
(1 comment)
https://review.coreboot.org/#/c/19954/1/src/southbridge/intel/bd82x6x/early…
File src/southbridge/intel/bd82x6x/early_usb.c:
PS1, Line 74: inw(DEFAULT_PMBASE | UPRWC) & ~UPRWC_WR_EN
> your commit description is "Use register name" but this commit actually doe
Agreed. It just needs a bit more in the commit message.
--
To view, visit https://review.coreboot.org/19954
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I4f2f3f196c12489613333ab9f6098443edda927f
Gerrit-PatchSet: 2
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Philippe Mathieu-Daudé <philippe.mathieu.daude(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
Hello Philippe Mathieu-Daudé, Arthur Heymans, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/19954
to look at the new patch set (#2).
Change subject: sb/intel/bd82x6x/early_usb: Use register name
......................................................................
sb/intel/bd82x6x/early_usb: Use register name
Use register name instead of magic value.
Only reset previously set bit instead of all bits.
Change-Id: I4f2f3f196c12489613333ab9f6098443edda927f
Signed-off-by: Patrick Rudolph <siro(a)das-labor.org>
---
M src/southbridge/intel/bd82x6x/early_usb.c
M src/southbridge/intel/bd82x6x/pch.h
2 files changed, 9 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/54/19954/2
--
To view, visit https://review.coreboot.org/19954
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I4f2f3f196c12489613333ab9f6098443edda927f
Gerrit-PatchSet: 2
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Philippe Mathieu-Daudé <philippe.mathieu.daude(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>