Martin Roth has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/31890
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
mainboard/google/kahlee: Don't use AMD's secure OS
Disable the use of AMD's Secure OS through the Kconfig option.
BUG=chromium:903833 TEST=Building aleena with the updated AMDFWTool and a 0-byte secure OS file works correctly
Signed-off-by: Martin Roth martinroth@chromium.org Change-Id: Iabb0632eef88170dde45dea2e2e15b54b3a06f7b --- M src/mainboard/google/kahlee/Kconfig 1 file changed, 4 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/90/31890/1
diff --git a/src/mainboard/google/kahlee/Kconfig b/src/mainboard/google/kahlee/Kconfig index 1c46625..fe29870 100644 --- a/src/mainboard/google/kahlee/Kconfig +++ b/src/mainboard/google/kahlee/Kconfig @@ -141,4 +141,8 @@ depends on USE_OEM_BIN default ""
+# Don't use AMD's Secure OS +config USE_PSPSCUREOS + def_bool n + endif # BOARD_GOOGLE_BASEBOARD_KAHLEE
Patrick Georgi has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig File src/mainboard/google/kahlee/Kconfig:
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig@... PS1, Line 145: SCURE is that right?
Martin Roth has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig File src/mainboard/google/kahlee/Kconfig:
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig@... PS1, Line 145: SCURE
is that right?
Yes, this is what the variable is named. https://review.coreboot.org/cgit/coreboot.git/tree/src/soc/amd/stoneyridge/K...
Marshall, did you want to change this name?
Richard Spiegel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 1: Code-Review+2
(1 comment)
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig File src/mainboard/google/kahlee/Kconfig:
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig@... PS1, Line 145: SCURE
Yes, this is what the variable is named. […]
This is truly the current name of the variable, I checked. That said, if we want to change it, it should be a separate patch. Personally, I would prefer PSP_SECURE_OS.
Marshall Dawson has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 1:
(3 comments)
https://review.coreboot.org/#/c/31890/1//COMMIT_MSG Commit Message:
https://review.coreboot.org/#/c/31890/1//COMMIT_MSG@11 PS1, Line 11: chromium I haven't noticed this before.
https://review.coreboot.org/#/c/31890/1//COMMIT_MSG@12 PS1, Line 12: the updated AMDFWTool and a 0-byte secure OS If I understand your test, this statement seems a bit irrelevant. This patch ought to prevent there from being a SecureOS entry in the directory table, and the --secureos <0-byte filename> shouldn't be passed to amdfwtool.
Maybe rm -rf build/amdfw.rom && make V=1 * verify no --secureos argument
Or hexdump -C build/coreboot.rom | less Search with /20000\ \ aa Goto addr at offset 0x14 b[24:0] /f40000 (currently on mine) Should see $PSP cookie * verify no type=02 in the first column
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig File src/mainboard/google/kahlee/Kconfig:
https://review.coreboot.org/#/c/31890/1/src/mainboard/google/kahlee/Kconfig@... PS1, Line 145: SCURE
Yes, this is what the variable is named. […]
I've been going back and forth over changing the name, however now's the time to do it if we're going to.
So since the name may propagate, I think I would like to change it. I'd still keep some sort of prefix on the symbol though; e.g. USE_, ADD_, etc.
Marshall Dawson has uploaded a new patch set (#2) to the change originally created by Martin Roth. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
mainboard/google/kahlee: Don't use AMD's secure OS
Disable the use of AMD's Secure OS through the Kconfig option.
BUG=chromium:903833 TEST=Build google/aleena, verify types 02, 0c, 0d are removed from PSP directory table
Signed-off-by: Martin Roth martinroth@chromium.org Change-Id: Iabb0632eef88170dde45dea2e2e15b54b3a06f7b --- M src/mainboard/google/kahlee/Kconfig 1 file changed, 4 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/90/31890/2
Paul Menzel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 2: Code-Review+1
Richard Spiegel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
Patch Set 2: Code-Review+2
(1 comment)
https://review.coreboot.org/#/c/31890/2/src/mainboard/google/kahlee/Kconfig File src/mainboard/google/kahlee/Kconfig:
https://review.coreboot.org/#/c/31890/2/src/mainboard/google/kahlee/Kconfig@... PS2, Line 145: USE_PSPSECUREOS As I mentioned before, my preference is USE_PSP_SECURE_OS for readability...but that's just my opinion.
Patrick Georgi has submitted this change and it was merged. ( https://review.coreboot.org/c/coreboot/+/31890 )
Change subject: mainboard/google/kahlee: Don't use AMD's secure OS ......................................................................
mainboard/google/kahlee: Don't use AMD's secure OS
Disable the use of AMD's Secure OS through the Kconfig option.
BUG=chromium:903833 TEST=Build google/aleena, verify types 02, 0c, 0d are removed from PSP directory table
Signed-off-by: Martin Roth martinroth@chromium.org Change-Id: Iabb0632eef88170dde45dea2e2e15b54b3a06f7b Reviewed-on: https://review.coreboot.org/c/coreboot/+/31890 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Paul Menzel paulepanter@users.sourceforge.net Reviewed-by: Richard Spiegel richard.spiegel@silverbackltd.com --- M src/mainboard/google/kahlee/Kconfig 1 file changed, 4 insertions(+), 0 deletions(-)
Approvals: build bot (Jenkins): Verified Paul Menzel: Looks good to me, but someone else must approve Richard Spiegel: Looks good to me, approved
diff --git a/src/mainboard/google/kahlee/Kconfig b/src/mainboard/google/kahlee/Kconfig index 1c46625..921f1be 100644 --- a/src/mainboard/google/kahlee/Kconfig +++ b/src/mainboard/google/kahlee/Kconfig @@ -141,4 +141,8 @@ depends on USE_OEM_BIN default ""
+# Don't use AMD's Secure OS +config USE_PSPSECUREOS + def_bool n + endif # BOARD_GOOGLE_BASEBOARD_KAHLEE