Patrick Georgi has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/43135 )
Change subject: azalia: rename TYPE_OTHER to not conflict with smbios' ......................................................................
azalia: rename TYPE_OTHER to not conflict with smbios'
Change-Id: Ic66f7c919a71cb53773d5056e5f756cd6faf4909 Signed-off-by: Patrick Georgi pgeorgi@google.com --- M src/include/device/azalia_device.h M src/mainboard/prodrive/hermes/hda_verb.c 2 files changed, 4 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/35/43135/1
diff --git a/src/include/device/azalia_device.h b/src/include/device/azalia_device.h index 9026091..f2a2cb8 100644 --- a/src/include/device/azalia_device.h +++ b/src/include/device/azalia_device.h @@ -39,7 +39,7 @@ };
enum azalia_pin_type { - TYPE_UNKNOWN = 0, + PIN_TYPE_UNKNOWN = 0, STEREO_MONO_1_8, STEREO_MONO_1_4, ATAPI, @@ -51,7 +51,7 @@ XLR, RJ_11, COMBINATION, - TYPE_OTHER = 0xf + PIN_TYPE_OTHER = 0xf };
enum azalia_pin_device { diff --git a/src/mainboard/prodrive/hermes/hda_verb.c b/src/mainboard/prodrive/hermes/hda_verb.c index 59b8aa6..260b9a5 100644 --- a/src/mainboard/prodrive/hermes/hda_verb.c +++ b/src/mainboard/prodrive/hermes/hda_verb.c @@ -87,7 +87,7 @@ LOCATION_OTHER, NA, DEVICE_OTHER, - TYPE_OTHER, + PIN_TYPE_OTHER, COLOR_OTHER, true, 0, @@ -99,7 +99,7 @@ LOCATION_OTHER, NA, DEVICE_OTHER, - TYPE_OTHER, + PIN_TYPE_OTHER, COLOR_OTHER, true, 0,
Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/43135 )
Change subject: azalia: rename TYPE_OTHER to not conflict with smbios' ......................................................................
Patch Set 1: Code-Review+2
Hello build bot (Jenkins), Patrick Rudolph,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/43135
to look at the new patch set (#2).
Change subject: smbios: TYPE_NONE and TYPE_OTHER are already taken ......................................................................
smbios: TYPE_NONE and TYPE_OTHER are already taken
Change-Id: Ic66f7c919a71cb53773d5056e5f756cd6faf4909 Signed-off-by: Patrick Georgi pgeorgi@google.com --- M src/include/smbios.h 1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/35/43135/2
HAOUAS Elyes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/43135 )
Change subject: smbios: TYPE_NONE and TYPE_OTHER are already taken ......................................................................
Patch Set 2: Code-Review+2
Patrick Georgi has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/43135 )
Change subject: smbios: TYPE_NONE and TYPE_OTHER are already taken ......................................................................
Patch Set 2:
The smbios side enums of that name are never used but it fails the build, so pushing it in early.
Patrick Georgi has submitted this change. ( https://review.coreboot.org/c/coreboot/+/43135 )
Change subject: smbios: TYPE_NONE and TYPE_OTHER are already taken ......................................................................
smbios: TYPE_NONE and TYPE_OTHER are already taken
Change-Id: Ic66f7c919a71cb53773d5056e5f756cd6faf4909 Signed-off-by: Patrick Georgi pgeorgi@google.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/43135 Reviewed-by: HAOUAS Elyes ehaouas@noos.fr Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M src/include/smbios.h 1 file changed, 2 insertions(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified HAOUAS Elyes: Looks good to me, approved
diff --git a/src/include/smbios.h b/src/include/smbios.h index 8283a4c..ed09d64 100644 --- a/src/include/smbios.h +++ b/src/include/smbios.h @@ -540,7 +540,7 @@
/* enum for port types */ typedef enum { - TYPE_NONE = 0x00, + TYPE_NONE_PORT = 0x00, TYPE_PARALLEL_PORT_XT_AT_COMPATIBLE = 0x01, TYPE_PARALLEL_PORT_PS_2 = 0x02, TYPE_PARALLEL_PORT_ECP = 0x03, @@ -578,7 +578,7 @@ TYPE_THUNDERBOLT = 0x23, TYPE_8251_COMPATIBLE = 0xA0, TYPE_8251_FIFO_COMPATIBLE = 0xA1, - TYPE_OTHER = 0xFF, + TYPE_OTHER_PORT = 0xFF, } type8_port_types;
struct port_information {