Attention is currently required from: Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya.
Nick Kochlowski has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
Patch Set 17:
(4 comments)
File src/drivers/amd/opensil/memmap.c:
https://…
[View More]review.coreboot.org/c/coreboot/+/85634/comment/9747469b_3ed0c6f8?us… :
PS16, Line 18: int
> i'd expect this to be an unsigned int. iirc this is implementation defined though. […]
Done
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/5e9aaf75_47115384?us… :
PS16, Line 10: int
> i'd expect this to be an unsigned int or possibly uint32_t
Done
https://review.coreboot.org/c/coreboot/+/85634/comment/c1c3fe33_2c395782?us… :
PS16, Line 37: for (i = 0; i < ARRAY_SIZE(types); i++)
: if (enum_type == types[i].type)
: break;
: if (i == ARRAY_SIZE(types))
: return "Unknown type";
: return types[i].string;
> something for another patch, which is why i mark it as resolved, but this code can be rewritten to m […]
Agreed, it's much easier to read this way. I added this change to the new patchset. Is that OK or should I push a separate add-on patch just for this?
https://review.coreboot.org/c/coreboot/+/85634/comment/16c007d9_b8e2f127?us… :
PS16, Line 51: *hole_info = NULL;
> i'd also set n_holes to 0 in the error case just to be sure. […]
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 17
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Fri, 31 Jan 2025 18:42:47 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
[View Less]
Attention is currently required from: Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Nick Kochlowski, Varshit Pandya.
Hello Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/85634?usp=email
to look at the new patch set (#17).
The following approvals got outdated and were removed:
Verified+1 by build bot (Jenkins)
…
[View More]Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
Refactor the vendercode openSIL memory map code and move all common
calls that do not require any openSIL headers to the driver.
Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Signed-off-by: Nicolas Kochlowski <nickkochlowski(a)gmail.com>
---
M src/drivers/amd/opensil/Makefile.mk
A src/drivers/amd/opensil/memmap.c
M src/drivers/amd/opensil/opensil.h
M src/soc/amd/genoa_poc/domain.c
M src/soc/amd/phoenix/memmap.c
M src/vendorcode/amd/opensil/genoa_poc/memmap.c
M src/vendorcode/amd/opensil/opensil.h
M src/vendorcode/amd/opensil/stub/ramstage.c
8 files changed, 120 insertions(+), 90 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/34/85634/17
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 17
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
[View Less]
Attention is currently required from: Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Nick Kochlowski, Varshit Pandya.
Felix Held has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
Patch Set 16:
(4 comments)
File src/drivers/amd/opensil/memmap.c:
https://…
[View More]review.coreboot.org/c/coreboot/+/85634/comment/1d5d3b2f_629fa159?us… :
PS16, Line 18: int
i'd expect this to be an unsigned int. iirc this is implementation defined though.
from looking at the uint32_t padding after the type field, i'd expect the type field to be assumed to always be an uint32_t so that the struct has a total size of 3 QWORDs. in coreboot unsigned int and uint32_t are identical, so i'd use uint32_t here
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/01c755ee_2fadd06d?us… :
PS16, Line 10: int
i'd expect this to be an unsigned int or possibly uint32_t
https://review.coreboot.org/c/coreboot/+/85634/comment/0866af67_04a0b235?us… :
PS16, Line 37: for (i = 0; i < ARRAY_SIZE(types); i++)
: if (enum_type == types[i].type)
: break;
: if (i == ARRAY_SIZE(types))
: return "Unknown type";
: return types[i].string;
something for another patch, which is why i mark it as resolved, but this code can be rewritten to make it easier to read:
for (i = 0; i < ARRAY_SIZE(types); i++)
if (enum_type == types[i].type)
return types[i].string;
return "Unknown type";
https://review.coreboot.org/c/coreboot/+/85634/comment/f635fea7_b838da13?us… :
PS16, Line 51: *hole_info = NULL;
i'd also set n_holes to 0 in the error case just to be sure. maybe top_of_mem too?
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 16
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Fri, 31 Jan 2025 17:04:43 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
[View Less]
Attention is currently required from: Elyes Haouas, Julius Werner, Paul Menzel.
Maximilian Brune has posted comments on this change by Elyes Haouas. ( https://review.coreboot.org/c/coreboot/+/86233?usp=email )
Change subject: soc/intel/denverton_ns: Remove unused memcpy_s function
......................................................................
Patch Set 7: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/86233?usp=email
To unsubscribe, or for help writing …
[View More]mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I0d32c838e94ae760907efe55ed00bab3faaaa8c5
Gerrit-Change-Number: 86233
Gerrit-PatchSet: 7
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Reviewer: Jeff Daly <jeffd(a)silicom-usa.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: Philipp Hug <philipp(a)hug.cx>
Gerrit-Reviewer: Vanessa Eusebio <vanessa.f.eusebio(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Comment-Date: Fri, 31 Jan 2025 14:56:29 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
[View Less]
Attention is currently required from: Alicja Michalska, Arthur Heymans, Felix Held.
Angel Pons has posted comments on this change by Alicja Michalska. ( https://review.coreboot.org/c/coreboot/+/86131?usp=email )
Change subject: device/Kconfig: Make option to allocate above 4G appear in Kconfig
......................................................................
Patch Set 4:
(2 comments)
File src/device/Kconfig:
https://review.coreboot.org/c/coreboot/+/86131/comment/e62b1510_7517687f?us……
[View More] :
PS4, Line 1015: default y
> According to Arthur Heymans, it should be on for non-x86. […]
Looks like the latest patchset changes the default for non-x86 to n. Made a suggestion to undo this change.
https://review.coreboot.org/c/coreboot/+/86131/comment/765cc93e_f8ef5de5?us… :
PS4, Line 1014: default n
```suggestion
default n if ARCH_X86
default y
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/86131?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ia17b3312016409d8fd6bcce4321481a7b7e35ce5
Gerrit-Change-Number: 86131
Gerrit-PatchSet: 4
Gerrit-Owner: Alicja Michalska <ahplka19(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Alicja Michalska <ahplka19(a)gmail.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Fri, 31 Jan 2025 14:10:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Alicja Michalska <ahplka19(a)gmail.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
[View Less]