Attention is currently required from: Michał Kopeć, Sean Rhodes.
Nicholas Sudsgaard has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/84605?usp=email )
Change subject: drivers/tpm: Fix FUNC Method
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/84605?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If5e402579a2caff169e12253e5d9c2c493902ec7
Gerrit-Change-Number: 84605
Gerrit-PatchSet: 2
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Michał Kopeć <michal.kopec(a)3mdeb.com>
Gerrit-Reviewer: Nicholas Sudsgaard <devel+coreboot(a)nsudsgaard.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Attention: Michał Kopeć <michal.kopec(a)3mdeb.com>
Gerrit-Comment-Date: Tue, 01 Oct 2024 05:26:49 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: Kapil Porwal, Paul Menzel, Pranava Y N, Ronak Kanabar, Subrata Banik.
Jérémy Compostella has posted comments on this change by Jérémy Compostella. ( https://review.coreboot.org/c/coreboot/+/84552?usp=email )
Change subject: soc/intel/pantherlake: Add FSP-S programming
......................................................................
Patch Set 13:
(3 comments)
File src/soc/intel/pantherlake/fsp_params.c:
https://review.coreboot.org/c/coreboot/+/84552/comment/17c378b3_7dac1b79?us… :
PS11, Line 250: static void fill_fsps_cpu_params(FSP_S_CONFIG *s_cfg,
: const struct soc_intel_pantherlake_config *config)
: {
: const struct microcode *microcode;
: size_t length;
:
: if (CONFIG(USE_INTEL_FSP_TO_CALL_COREBOOT_PUBLISH_MP_PPI))
: s_cfg->CpuMpPpi = (uintptr_t)mp_fill_ppi_services_data();
:
: if (CONFIG(USE_FSP_FEATURE_PROGRAM_ON_APS)) {
: /* Locate microcode and pass to FSP-S for 2nd microcode loading */
: microcode = intel_microcode_find();
: if (!microcode)
: return;
:
: length = get_microcode_size(microcode);
: if (!length)
: return;
:
: /* Update CPU Microcode patch base address/size */
: s_cfg->MicrocodeRegionBase = (uint32_t)(uintptr_t)microcode;
: s_cfg->MicrocodeRegionSize = (uint32_t)length;
: }
: }
> > Could you please provide details about why you want it that way ? Here are few notes: […]
2. USE_INTEL_FSP_TO_CALL_COREBOOT_PUBLISH_MP_PPI is not enforced by pantherlake Kconfig which only relies on the default settings so I believe it should be guard as a mainboard could decide otherwise. This kconfig is specific to this use-case where coreboot let FSP use coreboot MP PPI. In addition, we should not be worried about loosing any CPU cycles thanks to compiler optimization anyway.
3. Sure, I'll do that tomorrow.
https://review.coreboot.org/c/coreboot/+/84552/comment/71aae0fc_209c0aa4?us… :
PS11, Line 301: max_port = get_max_tcss_port();
: for (i = 0; i < max_port; i++)
> > `get_max_tcss_port()` is what has been used everywhere in the pantherlake SoC code to get the numb […]
It would definitely save few CPU cycles. Should I replace the call to `get_max_tcss_port()` everywhere ? What about `get_max_pcie_port()`? or `get_max_i2c_port()`? Do you think we should also replace them with their corresponding constants ? At this point we could even get rid of the soc_info.c saving a few bytes of binary space and as a result a few extra cycles in the process. I am sure this is going to hurt code readability and as a result maintainability but if it is really what you desire, I can do it.
File src/soc/intel/pantherlake/fsp_params.c:
https://review.coreboot.org/c/coreboot/+/84552/comment/375bc07b_34016b94?us… :
PS13, Line 637: if (is_devfn_enabled(PCI_DEVFN_HDA)) {
> ``` […]
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/84552?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iea26d962748116fa84afdb4afcba1098a64b6989
Gerrit-Change-Number: 84552
Gerrit-PatchSet: 13
Gerrit-Owner: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: Pranava Y N <pranavayn(a)google.com>
Gerrit-Reviewer: Ronak Kanabar <ronak.kanabar(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Ronak Kanabar <ronak.kanabar(a)intel.com>
Gerrit-Attention: Pranava Y N <pranavayn(a)google.com>
Gerrit-Comment-Date: Tue, 01 Oct 2024 05:17:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Jérémy Compostella <jeremy.compostella(a)intel.com>
Attention is currently required from: Angel Pons.
Nicholas Chin has posted comments on this change by Nicholas Chin. ( https://review.coreboot.org/c/coreboot/+/84585?usp=email )
Change subject: nb/intel/*: Explicitly include static.h for config_of_soc
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
> Leaving this open to do some more build testing with static.h removed.
Actually never mind. This commit just handles users of `config_of_soc`. Any other possible requirements of static.h will be handled in a separate commit.
--
To view, visit https://review.coreboot.org/c/coreboot/+/84585?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iac8063d2021af83203be8a10b2962c9fb3dd106a
Gerrit-Change-Number: 84585
Gerrit-PatchSet: 2
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Tue, 01 Oct 2024 04:56:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nicholas Chin <nic.c3.14(a)gmail.com>
Attention is currently required from: Angel Pons.
Nicholas Chin has posted comments on this change by Nicholas Chin. ( https://review.coreboot.org/c/coreboot/+/84585?usp=email )
Change subject: nb/intel/*: Explicitly include static.h for config_of_soc
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
Leaving this open to do some more build testing with static.h removed.
--
To view, visit https://review.coreboot.org/c/coreboot/+/84585?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iac8063d2021af83203be8a10b2962c9fb3dd106a
Gerrit-Change-Number: 84585
Gerrit-PatchSet: 2
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Tue, 01 Oct 2024 04:54:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Jérémy Compostella, Kapil Porwal, Paul Menzel, Pranava Y N, Ronak Kanabar.
Subrata Banik has posted comments on this change by Jérémy Compostella. ( https://review.coreboot.org/c/coreboot/+/84552?usp=email )
Change subject: soc/intel/pantherlake: Add FSP-S programming
......................................................................
Patch Set 13:
(3 comments)
File src/soc/intel/pantherlake/fsp_params.c:
https://review.coreboot.org/c/coreboot/+/84552/comment/6b0d3550_10e83072?us… :
PS11, Line 250: static void fill_fsps_cpu_params(FSP_S_CONFIG *s_cfg,
: const struct soc_intel_pantherlake_config *config)
: {
: const struct microcode *microcode;
: size_t length;
:
: if (CONFIG(USE_INTEL_FSP_TO_CALL_COREBOOT_PUBLISH_MP_PPI))
: s_cfg->CpuMpPpi = (uintptr_t)mp_fill_ppi_services_data();
:
: if (CONFIG(USE_FSP_FEATURE_PROGRAM_ON_APS)) {
: /* Locate microcode and pass to FSP-S for 2nd microcode loading */
: microcode = intel_microcode_find();
: if (!microcode)
: return;
:
: length = get_microcode_size(microcode);
: if (!length)
: return;
:
: /* Update CPU Microcode patch base address/size */
: s_cfg->MicrocodeRegionBase = (uint32_t)(uintptr_t)microcode;
: s_cfg->MicrocodeRegionSize = (uint32_t)length;
: }
: }
> Could you please provide details about why you want it that way ? Here are few notes:
> 1. `SkipMpInit` UPD does not exist anymore so the comment and the "workaround" do not mean anything anymore.
> 2. IMO, creating an separate `fill_fsps_microcode_params()` to be called from `fill_fsps_cpu_params()` do not make sense. It should either not be separated (as I am suggesting) or be called directly from `soc_silicon_init_params()`. Otherwise it makes the code unnecessarily cumbersome.
The `CONFIG_USE_FSP_FEATURE_PROGRAM_ON_APS` config is enabled in MTL, with an agreement between Google and Intel's FSP team that Intel would follow up during the SOC generation. (b/219061518) I agree that if we don't have a way to drop `CONFIG_USE_FSP_FEATURE_PROGRAM_ON_APS=n`, then the `fill_fsps_microcode_params()` API call might not be valuable.
to summarize my request
1. Hopefully the Intel FSP team will pick `CONFIG_USE_FSP_FEATURE_PROGRAM_ON_APS=n` like we discussion
2. Do we need the below `if` guard. looks like we don't need any guarding.
```
if (CONFIG(USE_INTEL_FSP_TO_CALL_COREBOOT_PUBLISH_MP_PPI))
s_cfg->CpuMpPpi = (uintptr_t)mp_fill_ppi_services_data();
```
3. Can we use a helper function for below code to just make the code modular.
```
if (CONFIG(USE_FSP_FEATURE_PROGRAM_ON_APS)) {
/* Locate microcode and pass to FSP-S for 2nd microcode loading */
microcode = intel_microcode_find();
if (!microcode)
return;
length = get_microcode_size(microcode);
if (!length)
return;
/* Update CPU Microcode patch base address/size */
s_cfg->MicrocodeRegionBase = (uint32_t)(uintptr_t)microcode;
s_cfg->MicrocodeRegionSize = (uint32_t)length;
}
```
https://review.coreboot.org/c/coreboot/+/84552/comment/d3399a9f_0e6202e8?us… :
PS11, Line 301: max_port = get_max_tcss_port();
: for (i = 0; i < max_port; i++)
> `get_max_tcss_port()` is what has been used everywhere in the pantherlake SoC code to get the number of TCSS port.
my point is `MAX_TYPE_C_PORTS` will return the same port number statically w/o an overhead of function call ?
File src/soc/intel/pantherlake/fsp_params.c:
https://review.coreboot.org/c/coreboot/+/84552/comment/497d463c_8472b73f?us… :
PS13, Line 637: if (is_devfn_enabled(PCI_DEVFN_HDA)) {
```
if (!is_devfn_enabled(PCI_DEVFN_HDA))
return;
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/84552?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iea26d962748116fa84afdb4afcba1098a64b6989
Gerrit-Change-Number: 84552
Gerrit-PatchSet: 13
Gerrit-Owner: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: Pranava Y N <pranavayn(a)google.com>
Gerrit-Reviewer: Ronak Kanabar <ronak.kanabar(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Ronak Kanabar <ronak.kanabar(a)intel.com>
Gerrit-Attention: Pranava Y N <pranavayn(a)google.com>
Gerrit-Comment-Date: Tue, 01 Oct 2024 04:15:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Jérémy Compostella <jeremy.compostella(a)intel.com>
Attention is currently required from: Angel Pons, Arthur Heymans, Christian Walter, Dinesh Gehlot, Eran Mitrani, Eric Lai, Felix Held, Fred Reitberger, Jakub Czapiga, Jason Glenesk, Jason Nien, Jayvik Desai, Johnny Lin, Kapil Porwal, Martin Roth, Nick Vaccaro, Patrick Rudolph, Sean Rhodes, Subrata Banik, Tarun, Tim Chu.
Nicholas Chin has posted comments on this change by Nicholas Chin. ( https://review.coreboot.org/c/coreboot/+/84588?usp=email )
Change subject: mb/*: Explicitly include static.h for config_of_soc
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS1:
> Seems to be missing some other files that use `config_of_soc`
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/84588?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ia793666fda47678764fd33891fddb4aecf207bd4
Gerrit-Change-Number: 84588
Gerrit-PatchSet: 2
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Reviewer: Eran Mitrani <mitrani(a)google.com>
Gerrit-Reviewer: Eric Lai <ericllai(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Jayvik Desai <jayvik(a)google.com>
Gerrit-Reviewer: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun <tstuli(a)gmail.com>
Gerrit-Reviewer: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Eric Lai <ericllai(a)google.com>
Gerrit-Attention: Eran Mitrani <mitrani(a)google.com>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Tarun <tstuli(a)gmail.com>
Gerrit-Attention: Jayvik Desai <jayvik(a)google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Tue, 01 Oct 2024 02:54:55 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nicholas Chin <nic.c3.14(a)gmail.com>
Attention is currently required from: Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya.
Nicholas Chin has posted comments on this change by Nicholas Chin. ( https://review.coreboot.org/c/coreboot/+/84587?usp=email )
Change subject: soc/amd/*: Explicitly include static.h for config_of_soc
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS1:
> Seems to be missing some files that use `config_of_soc`
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/84587?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I9db5d80ca0a75ccff3b8e24db0ccbd6b36c84dcb
Gerrit-Change-Number: 84587
Gerrit-PatchSet: 2
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Tue, 01 Oct 2024 02:54:43 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nicholas Chin <nic.c3.14(a)gmail.com>