Attention is currently required from: Jason Glenesk, Raul Rangel, Marshall Dawson, Kyösti Mälkki, Fred Reitberger, Yu-Ping Wu, Felix Held.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58956 )
Change subject: [RFC] ChromeOS: Declare CHROMEOS_NO_GPIOS
......................................................................
Patch Set 7:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/58956/comment/049d901d_0a7ab6dc
PS1, Line 9: Implementation of fill_lb_gpios() is not about VBOOT
> fill_Lb_gpios() is an ugly piece of open-coding. The identifier strings should be enumerations, as the allowed choices come from the history of depthcharge so the specification is depthcharge git history?
No objections there in principle, but the interface is long-entrenched and the coreboot table struct is designed to take strings, etc... overall, I think the effort and churn of replacing it with an enum isn't really worth it. I do however agree that the risk of typos is stupid, and a really easy fix for that would be to just put a bunch of #defines in a file (ideally in commonlib/bsd so both coreboot and depthcharge can share it) to lock down the available strings, e.g.:
#define CHROMEOS_GPIO_LID "lid"
#define CHROMEOS_GPIO_SPEAKER_ENABLE "speaker enable"
...etc....
I think that would solve the practical issue with much less churn, so if you have time to spend on a little cleanup here, how about doing that?
(The allowed choices are just specified by historical practice, yes, and technically every board is allowed to make up its own but for practical reasons we have been trying to keep using the same names for the same things across all boards. It does happen from time to time that a new board needs a shared GPIO for something that we don't have an existing concept for yet, though, so the option for easily adding new kinds of pins needs to remain.)
> We should be able to remove the fill_lb_gpios. We override them in depthcharge anyway: https://source.chromium.org/chromiumos/chromiumos/codesearch/+/main:src/pla…
Well, that looks like a temporary hack for early bring-up code, so I think in general my earlier suggestion still makes sense that usually every Chrome OS board needs fill_lb_gpios some point, and so there should be no option to leave it out (i.e. weak implementation). For bring-up, boards can just write an empty stub to fill out later. (Also, btw, you don't need to handcraft that fake_gpio stuff you have there, we do have new_gpio_low()/new_gpio_high() for that in depthcharge already.)
--
To view, visit https://review.coreboot.org/c/coreboot/+/58956
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9f1eaaeffe388a7f8a7fc2430b6593eb8298461b
Gerrit-Change-Number: 58956
Gerrit-PatchSet: 7
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Wed, 13 Apr 2022 00:22:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Comment-In-Reply-To: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Comment-In-Reply-To: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-MessageType: comment
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63602 )
Change subject: [WIP]cpu/x86/smm: Use struct region to check overlapping sections
......................................................................
Patch Set 1:
(1 comment)
File src/cpu/x86/smm/smm_module_loader.c:
https://review.coreboot.org/c/coreboot/+/63602/comment/9a7ef304_8cd1691a
PS1, Line 399: struct region_list *entry = list;
: struct region_list *next_entry;
: while (1) {
: if (entry == NULL)
: return;
: next_entry = entry->next;
: free(entry);
: entry = next_entry;
: }
won't work. Only the last allocated element is freed.
--
To view, visit https://review.coreboot.org/c/coreboot/+/63602
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ib7e2e3ae16c223ecfd8d5bce6ff6c17c53496925
Gerrit-Change-Number: 63602
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Wed, 13 Apr 2022 00:15:27 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/63558
to look at the new patch set (#2).
Change subject: drivers/usb/acpi: acpi_power_res_params: Add use_gpio_for_status
......................................................................
drivers/usb/acpi: acpi_power_res_params: Add use_gpio_for_status
Add the member `use_gpio_for_status` to the structure
`drivers_usb_acpi_config`, so the `devicetree.cb` can specify it.
This field is then used to initialize the corresponding field in the
structure `acpi_power_res_params` in `usb_acpi_fill_ssdt_generator()`.
The member `acpi_power_res_params::use_gpio_for_status()` is already
being used by `acpi_device_add_power_res()` to determine which version
of the `_STA()` method to output.
This field now also allows for checking if the device is already enabled
and skipping re-enabling it (and the corresponding sleep) if it already
is.
BRANCH=None
Signed-off-by: Tim Van Patten <timvp(a)google.com>
BUG=b:225022810
TEST=Dump SSDT table for guybrush
Change-Id: I69eb5f1ad79f3b2980f43dcf4a36585fca198ec9
---
M src/acpi/device.c
M src/drivers/usb/acpi/chip.h
M src/drivers/usb/acpi/usb_acpi.c
3 files changed, 39 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/58/63558/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/63558
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I69eb5f1ad79f3b2980f43dcf4a36585fca198ec9
Gerrit-Change-Number: 63558
Gerrit-PatchSet: 2
Gerrit-Owner: Tim Van Patten <timvp(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: Shelley Chen, Taniya Das, Paul Menzel.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63289 )
Change subject: soc/qualcomm/common: Make clock_configure() check for exact matches
......................................................................
Patch Set 10:
(1 comment)
Patchset:
PS10:
> Seems to be a problem on the build node: […]
So the weird thing is, I retriggered this build and it seemed to have finished successfully the second time (https://qa.coreboot.org/job/coreboot-gerrit/201800/), but the Jenkins bot didn't update this patch.
+Martin, isn't the whole point of retriggering that it would then give us the Verified+1? Does something no longer work as intended here?
In the meantime, I'd suggest trying a rebase...
--
To view, visit https://review.coreboot.org/c/coreboot/+/63289
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9cfad7236241f4d03ff1a56683654649658b68fc
Gerrit-Change-Number: 63289
Gerrit-PatchSet: 10
Gerrit-Owner: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Martin Roth <martinroth(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Ravi Kumar Bokka <rbokka(a)codeaurora.org>
Gerrit-CC: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-CC: mturney mturney <quic_mturney(a)quicinc.com>
Gerrit-Attention: Shelley Chen <shchen(a)google.com>
Gerrit-Attention: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Wed, 13 Apr 2022 00:03:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Shelley Chen <shchen(a)google.com>
Comment-In-Reply-To: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: comment
Attention is currently required from: Raul Rangel, Rob Barnes, Karthik Ramasubramanian.
Jon Murphy has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63598 )
Change subject: util/apcb/apcb_v3_edit.py: Edit APCB based on different SPD magic
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://review.coreboot.org/c/coreboot/+/63598
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I8e96c89e4e5ce8e0567a17bf7685b69080fa1708
Gerrit-Change-Number: 63598
Gerrit-PatchSet: 1
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Rob Barnes <robbarnes(a)google.com>
Gerrit-Reviewer: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Rob Barnes <robbarnes(a)google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Tue, 12 Apr 2022 23:51:22 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Robert Zieba, Raul Rangel.
Karthik Ramasubramanian has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63600 )
Change subject: mb/google/skyrim: Inject SPDs into APCB
......................................................................
Patch Set 2:
(1 comment)
File src/mainboard/google/skyrim/Makefile.inc:
https://review.coreboot.org/c/coreboot/+/63600/comment/fa87e3bc_243e929c
PS1, Line 31: --spd_magic '2311130E'
> If possible you should mention where this value is coming from.
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/63600
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3b3f6f248d54681c6f55c00660d1f2988ae906ba
Gerrit-Change-Number: 63600
Gerrit-PatchSet: 2
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Comment-Date: Tue, 12 Apr 2022 23:48:53 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Robert Zieba <robertzieba(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Raul Rangel, Karthik Ramasubramanian.
Hello Robert Zieba, Raul Rangel, Jon Murphy,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/63600
to look at the new patch set (#2).
Change subject: mb/google/skyrim: Inject SPDs into APCB
......................................................................
mb/google/skyrim: Inject SPDs into APCB
Update the build scripts to inject variant specific SPDs into APCB.
BUG=None
TEST=Build and boot to OS in Skyrim boards with all the concerned memory
parts.
Signed-off-by: Karthikeyan Ramasubramanian <kramasub(a)google.com>
Change-Id: I3b3f6f248d54681c6f55c00660d1f2988ae906ba
---
M src/mainboard/google/skyrim/Makefile.inc
1 file changed, 18 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/00/63600/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/63600
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3b3f6f248d54681c6f55c00660d1f2988ae906ba
Gerrit-Change-Number: 63600
Gerrit-PatchSet: 2
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-MessageType: newpatchset