Subrata Banik has submitted this change. ( https://review.coreboot.org/c/coreboot/+/69970 )
(
2 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: {soc/intel/cmn/pcie, mb/google/volteer}: Rename `is_external` variable
......................................................................
{soc/intel/cmn/pcie, mb/google/volteer}: Rename `is_external` variable
Name a variable based on its utility. `is_external` variable adds
`ExternalFacingPort` _DSD property to an ACPI device hence
rename it to `add_acpi_external_facing_port`.
BUG=b:259716145
TEST=Build google/rex with this flag and verify it in SSDT at
runtime.
SSDT snippet:
Name (_DSD, Package (0x04) // _DSD: Device-Specific Data
{
ToUUID ("6211e2c0-58a3-4af3-90e1-927a4e0c55a4"),
Package (0x01)
{
Package (0x02)
{
"HotPlugSupportInD3",
One
}
},
ToUUID ("efcc06cc-73ac-4bc3-bff0-76143807c389"),
Package (0x01)
{
Package (0x02)
{
"ExternalFacingPort",
One
}
}
})
Signed-off-by: Kapil Porwal <kapilporwal(a)google.com>
Change-Id: I65100283ed9b65037c9890f28ecab41fcfa25d83
Reviewed-on: https://review.coreboot.org/c/coreboot/+/69970
Reviewed-by: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Reviewed-by: Subrata Banik <subratabanik(a)google.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M src/mainboard/google/volteer/variants/baseboard/devicetree.cb
M src/soc/intel/common/block/pcie/rtd3/chip.h
M src/soc/intel/common/block/pcie/rtd3/rtd3.c
3 files changed, 49 insertions(+), 3 deletions(-)
Approvals:
build bot (Jenkins): Verified
Subrata Banik: Looks good to me, approved
Eric Lai: Looks good to me, approved
diff --git a/src/mainboard/google/volteer/variants/baseboard/devicetree.cb b/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
index 9f3987e..3a54d3b 100644
--- a/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
+++ b/src/mainboard/google/volteer/variants/baseboard/devicetree.cb
@@ -489,7 +489,7 @@
chip soc/intel/common/block/pcie/rtd3
register "reset_gpio" = "ACPI_GPIO_OUTPUT_ACTIVE_LOW(GPP_H3)"
register "srcclk_pin" = "3"
- register "is_external" = "1"
+ register "add_acpi_external_facing_port" = "1"
device generic 1 on
probe DB_SD SD_RTS5261
end
diff --git a/src/soc/intel/common/block/pcie/rtd3/chip.h b/src/soc/intel/common/block/pcie/rtd3/chip.h
index 652aaff..8b62406 100644
--- a/src/soc/intel/common/block/pcie/rtd3/chip.h
+++ b/src/soc/intel/common/block/pcie/rtd3/chip.h
@@ -44,7 +44,7 @@
* Add device property indicating the device provides an external PCI port
* for the OS to apply security restrictions.
*/
- bool is_external;
+ bool add_acpi_external_facing_port;
/*
* Allow a device to add the RuntimeD3Storage property even if the detected
diff --git a/src/soc/intel/common/block/pcie/rtd3/rtd3.c b/src/soc/intel/common/block/pcie/rtd3/rtd3.c
index 7a64734..85ee24f 100644
--- a/src/soc/intel/common/block/pcie/rtd3/rtd3.c
+++ b/src/soc/intel/common/block/pcie/rtd3/rtd3.c
@@ -479,7 +479,7 @@
acpi_dp_add_package(dsd, pkg);
/* Indicate to the OS if the device provides an External facing port. */
- if (config->is_external) {
+ if (config->add_acpi_external_facing_port) {
pkg = acpi_dp_new_table(PCIE_EXTERNAL_PORT_UUID);
acpi_dp_add_integer(pkg, PCIE_EXTERNAL_PORT_PROPERTY, 1);
acpi_dp_add_package(dsd, pkg);
--
To view, visit https://review.coreboot.org/c/coreboot/+/69970
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I65100283ed9b65037c9890f28ecab41fcfa25d83
Gerrit-Change-Number: 69970
Gerrit-PatchSet: 6
Gerrit-Owner: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Eran Mitrani <mitrani(a)google.com>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Martin L Roth <gaumless(a)gmail.com>
Gerrit-MessageType: merged
Attention is currently required from: Subrata Banik, Kane Chen, Tim Wawrzynczak, Arthur Heymans.
Eric Lai has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/64467 )
Change subject: cpu/x86/mtrr: Print apic id in when set up MTRRs for BSP/APs
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/64467
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ifd2e1e411f86fa3ea42ed50546facec31b89c3e1
Gerrit-Change-Number: 64467
Gerrit-PatchSet: 3
Gerrit-Owner: Kane Chen <kane.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Kane Chen <kane.chen(a)intel.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Kane Chen <kane.chen(a)intel.corp-partner.google.com>
Gerrit-Attention: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Tue, 29 Nov 2022 05:09:08 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Bora Guvendik, Anil Kumar K, Cliff Huang.
Eric Lai has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/70119 )
Change subject: mb/intel/adlrvp: Add RTD3 support for PCIe slot1
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/70119
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ieb7d207a7ec3763bad3e82522e86a825c1ed00b6
Gerrit-Change-Number: 70119
Gerrit-PatchSet: 1
Gerrit-Owner: Cliff Huang <cliff.huang(a)intel.com>
Gerrit-Reviewer: Anil Kumar K <anil.kumar.k(a)intel.com>
Gerrit-Reviewer: Bora Guvendik <bora.guvendik(a)intel.com>
Gerrit-Reviewer: Cliff Huang <cliff.huang(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Bora Guvendik <bora.guvendik(a)intel.com>
Gerrit-Attention: Anil Kumar K <anil.kumar.k(a)intel.com>
Gerrit-Attention: Cliff Huang <cliff.huang(a)intel.com>
Gerrit-Attention: Cliff Huang <cliff.huang(a)intel.corp-partner.google.com>
Gerrit-Comment-Date: Tue, 29 Nov 2022 05:07:07 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Lance Zhao, Tarun Tuli, Subrata Banik, Tim Wawrzynczak.
build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/70063 )
Change subject: acpi: Helper functions to add certain _DSD properties
......................................................................
Patch Set 4:
(1 comment)
File src/include/acpi/acpi_device.h:
Robot Comment from checkpatch (run ID jenkins-coreboot-checkpatch-164731):
https://review.coreboot.org/c/coreboot/+/70063/comment/effd1ad4_7169d290
PS4, Line 599: * value - Value of the interger property.
'interger' may be misspelled - perhaps 'integer'?
--
To view, visit https://review.coreboot.org/c/coreboot/+/70063
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5bb432dd4e8f320d2c0d7f378dc2d7b3a770b541
Gerrit-Change-Number: 70063
Gerrit-PatchSet: 4
Gerrit-Owner: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Lance Zhao
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Lance Zhao
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Comment-Date: Tue, 29 Nov 2022 04:09:47 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Lance Zhao, Tarun Tuli, Subrata Banik, Tim Wawrzynczak.
build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/70063 )
Change subject: acpi: Helper functions to add certain _DSD properties
......................................................................
Patch Set 3:
(1 comment)
File src/include/acpi/acpi_device.h:
Robot Comment from checkpatch (run ID jenkins-coreboot-checkpatch-164722):
https://review.coreboot.org/c/coreboot/+/70063/comment/837f5811_2af16622
PS3, Line 599: * value - Value of the interger property.
'interger' may be misspelled - perhaps 'integer'?
--
To view, visit https://review.coreboot.org/c/coreboot/+/70063
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5bb432dd4e8f320d2c0d7f378dc2d7b3a770b541
Gerrit-Change-Number: 70063
Gerrit-PatchSet: 3
Gerrit-Owner: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Lance Zhao
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Lance Zhao
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Comment-Date: Tue, 29 Nov 2022 03:59:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment