Attention is currently required from: Jason Nien, Martin Roth.
Hello build bot (Jenkins), Jason Nien, Martin Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/68634
to look at the new patch set (#3).
Change subject: mb/google/kahlee: use override devicetrees for variants
......................................................................
mb/google/kahlee: use override devicetrees for variants
This helps with deduplicating the identical parts of the variants'
devicetrees.
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Change-Id: Ie050c4624327b904e8cb0959b40421339e43f825
---
M src/mainboard/google/kahlee/Kconfig
R src/mainboard/google/kahlee/variants/aleena/overridetree.cb
A src/mainboard/google/kahlee/variants/baseboard/devicetree.cb
R src/mainboard/google/kahlee/variants/careena/overridetree.cb
R src/mainboard/google/kahlee/variants/grunt/overridetree.cb
R src/mainboard/google/kahlee/variants/liara/overridetree.cb
R src/mainboard/google/kahlee/variants/nuwani/overridetree.cb
R src/mainboard/google/kahlee/variants/treeya/overridetree.cb
8 files changed, 66 insertions(+), 225 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/34/68634/3
--
To view, visit https://review.coreboot.org/c/coreboot/+/68634
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie050c4624327b904e8cb0959b40421339e43f825
Gerrit-Change-Number: 68634
Gerrit-PatchSet: 3
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Nico Huber, Maximilian Brune, Arthur Heymans.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68160 )
Change subject: util/cbfstool: Add a new mechanism to provide a memory mapped
......................................................................
Patch Set 3:
(4 comments)
File src/soc/intel/common/block/fast_spi/Makefile.inc:
https://review.coreboot.org/c/coreboot/+/68160/comment/fdbebbf7_d934b25b
PS3, Line 91: $(call int-subtract, $(CONFIG_ROM_SIZE) 0x1000000)
Can we factor this term out into a separate variable (e.g. ext_rom_size or something like that)? I think that would make this easier to read.
File util/cbfstool/cbfstool.c:
https://review.coreboot.org/c/coreboot/+/68160/comment/97cdcc45_f4becb8a
PS3, Line 317: static int next_window;
nit: namespace a bit better since it's a global (e.g. mmap_next_window)
https://review.coreboot.org/c/coreboot/+/68160/comment/41d6bfd0_c4ee0141
PS3, Line 338: MMAP_SIZE
nit: That's a bit of an odd way to name fields in an array, particularly since these constants are global and not very well namespaced. How about this instead?
```
union {
unsigned long int array[3];
struct {
unsigned long int flash_base;
unsigned long int mmap_base;
unsigned long int mmap_size;
};
} mmap_args;
```
https://review.coreboot.org/c/coreboot/+/68160/comment/8b5af9cb_428c45df
PS3, Line 358: optarg);
Note that this will no longer print the full argument because strtok() cuts it into pieces in-place. Not sure if we care.
--
To view, visit https://review.coreboot.org/c/coreboot/+/68160
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I38ab4c369704497f711e14ecda3ff3a8cdc0d089
Gerrit-Change-Number: 68160
Gerrit-PatchSet: 3
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Thu, 20 Oct 2022 21:44:56 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Paul Menzel, Fred Reitberger.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68477 )
Change subject: soc/amd/morgana/smi: Update smi definitions for morgana
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/68477
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6a9f05bcc6a6e4c94114ccbd07628629bdfabcba
Gerrit-Change-Number: 68477
Gerrit-PatchSet: 2
Gerrit-Owner: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Thu, 20 Oct 2022 21:40:11 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Jason Nien, Martin Roth.
Hello Jason Nien, Martin Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/68634
to look at the new patch set (#2).
Change subject: mb/google/kahlee: use override devicetrees for variants
......................................................................
mb/google/kahlee: use override devicetrees for variants
This helps with deduplicating the identical parts of the variants'
devicetrees.
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Change-Id: Ie050c4624327b904e8cb0959b40421339e43f825
---
M src/mainboard/google/kahlee/Kconfig
R src/mainboard/google/kahlee/variants/aleena/overridetree.cb
A src/mainboard/google/kahlee/variants/baseboard/devicetree.cb
R src/mainboard/google/kahlee/variants/careena/overridetree.cb
R src/mainboard/google/kahlee/variants/grunt/overridetree.cb
R src/mainboard/google/kahlee/variants/liara/overridetree.cb
R src/mainboard/google/kahlee/variants/nuwani/overridetree.cb
R src/mainboard/google/kahlee/variants/treeya/overridetree.cb
8 files changed, 65 insertions(+), 193 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/34/68634/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/68634
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie050c4624327b904e8cb0959b40421339e43f825
Gerrit-Change-Number: 68634
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: newpatchset