Attention is currently required from: Felix Held.
Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/56244 )
Change subject: cpu/intel/*/*_init: use mca_get_bank_count()
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/56244
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I245b15f57e77edca179e9e28965383a227617174
Gerrit-Change-Number: 56244
Gerrit-PatchSet: 1
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Tue, 13 Jul 2021 04:13:31 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Dtrain Hsu has uploaded a new patch set (#2). ( https://review.coreboot.org/c/coreboot/+/56248 )
Change subject: mb/google/dedede/var/cret: Enable/disable Touchscreen based on FW_CONFIG
......................................................................
mb/google/dedede/var/cret: Enable/disable Touchscreen based on FW_CONFIG
Enable/disable Touchscreen function based on Touchscreen bit of FW_CONFIG.
The Touchscreen settings are included GPIO settings and I2C bus settings.
BUG=b:xxxxxxxx
BRANCH=dedede
TEST=Build and test the change on cret.
Signed-off-by: Dtrain Hsu <dtrain_hsu(a)compal.corp-partner.google.com>
Change-Id: Ice517c034e2dab93bb27e75dccf06d9a0936526b
---
M src/mainboard/google/dedede/variants/baseboard/devicetree.cb
M src/mainboard/google/dedede/variants/cret/gpio.c
M src/mainboard/google/dedede/variants/cret/overridetree.cb
3 files changed, 37 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/48/56248/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/56248
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ice517c034e2dab93bb27e75dccf06d9a0936526b
Gerrit-Change-Number: 56248
Gerrit-PatchSet: 2
Gerrit-Owner: Dtrain Hsu <dtrain_hsu(a)compal.corp-partner.google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Patrick Rudolph.
Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/56245 )
Change subject: soc/intel/common/block/cpu/cpulib: use mca_get_bank_count()
......................................................................
soc/intel/common/block/cpu/cpulib: use mca_get_bank_count()
Use the common mca_get_bank_count function instead of open-coding the
functionality to get the MCA bank number. Also re-type the num_banks
variable from signed in to unsigned int, since the number of MCA bank is
always positive, and make it constant.
Change-Id: I449c74629ff16057c4559d7fd3620208230560f5
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
---
M src/soc/intel/common/block/cpu/cpulib.c
1 file changed, 1 insertion(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/45/56245/1
diff --git a/src/soc/intel/common/block/cpu/cpulib.c b/src/soc/intel/common/block/cpu/cpulib.c
index 9e95b0f..a245824 100644
--- a/src/soc/intel/common/block/cpu/cpulib.c
+++ b/src/soc/intel/common/block/cpu/cpulib.c
@@ -338,12 +338,10 @@
{
msr_t msr;
int i;
- int num_banks;
+ const unsigned int num_banks = mca_get_bank_count();
printk(BIOS_DEBUG, "Clearing out pending MCEs\n");
- msr = rdmsr(IA32_MCG_CAP);
- num_banks = msr.lo & 0xff;
msr.lo = msr.hi = 0;
for (i = 0; i < num_banks; i++) {
--
To view, visit https://review.coreboot.org/c/coreboot/+/56245
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I449c74629ff16057c4559d7fd3620208230560f5
Gerrit-Change-Number: 56245
Gerrit-PatchSet: 1
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-MessageType: newchange
Attention is currently required from: Patrick Rudolph.
Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/56244 )
Change subject: cpu/intel/*/*_init: use mca_get_bank_count()
......................................................................
cpu/intel/*/*_init: use mca_get_bank_count()
Use the common mca_get_bank_count function instead of open-coding the
functionality to get the MCA bank number. Also re-type the num_banks
variable from signed in to unsigned int, since the number of MCA bank is
always positive, and make it constant.
In the case of Intel model 2065x the mca_get_bank_count() call replaces
a magic number.
Change-Id: I245b15f57e77edca179e9e28965383a227617174
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
---
M src/cpu/intel/haswell/haswell_init.c
M src/cpu/intel/model_2065x/model_2065x_init.c
M src/cpu/intel/model_206ax/model_206ax_init.c
3 files changed, 4 insertions(+), 9 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/44/56244/1
diff --git a/src/cpu/intel/haswell/haswell_init.c b/src/cpu/intel/haswell/haswell_init.c
index 2d8bd15..29c663e 100644
--- a/src/cpu/intel/haswell/haswell_init.c
+++ b/src/cpu/intel/haswell/haswell_init.c
@@ -520,10 +520,7 @@
{
msr_t msr;
int i;
- int num_banks;
-
- msr = rdmsr(IA32_MCG_CAP);
- num_banks = msr.lo & 0xff;
+ const unsigned int num_banks = mca_get_bank_count();
/* Enable all error reporting */
msr.lo = msr.hi = ~0;
diff --git a/src/cpu/intel/model_2065x/model_2065x_init.c b/src/cpu/intel/model_2065x/model_2065x_init.c
index abf8f61..fe5ac56 100644
--- a/src/cpu/intel/model_2065x/model_2065x_init.c
+++ b/src/cpu/intel/model_2065x/model_2065x_init.c
@@ -77,10 +77,11 @@
{
msr_t msr;
int i;
+ const unsigned int num_banks = mca_get_bank_count();
msr.lo = msr.hi = 0;
/* This should only be done on a cold boot */
- for (i = 0; i < 7; i++)
+ for (i = 0; i < num_banks; i++)
wrmsr(IA32_MC_STATUS(i), msr);
}
diff --git a/src/cpu/intel/model_206ax/model_206ax_init.c b/src/cpu/intel/model_206ax/model_206ax_init.c
index bfe1fa5..541cb3b 100644
--- a/src/cpu/intel/model_206ax/model_206ax_init.c
+++ b/src/cpu/intel/model_206ax/model_206ax_init.c
@@ -301,10 +301,7 @@
{
msr_t msr;
int i;
- int num_banks;
-
- msr = rdmsr(IA32_MCG_CAP);
- num_banks = msr.lo & 0xff;
+ const unsigned int num_banks = mca_get_bank_count();
msr.lo = msr.hi = 0;
/* This should only be done on a cold boot */
--
To view, visit https://review.coreboot.org/c/coreboot/+/56244
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I245b15f57e77edca179e9e28965383a227617174
Gerrit-Change-Number: 56244
Gerrit-PatchSet: 1
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-MessageType: newchange