Attention is currently required from: Kyösti Mälkki.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58949 )
Change subject: soc/nvidia,qualcomm: Fix indirect includes
......................................................................
Patch Set 5: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/58949
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic02bd5dcdde0bb5c8be0e2c52c20048ed0d4ad94
Gerrit-Change-Number: 58949
Gerrit-PatchSet: 5
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:39:52 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Paul Menzel, Arthur Heymans.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58934 )
Change subject: Documentation/coding_style.md: Avoid weakly linked symbols
......................................................................
Patch Set 2: Code-Review-1
(2 comments)
Patchset:
PS2:
Has there been some recent discussion about this somewhere that I may have missed? There's not a lot of context on this CL (commit message?) and it seems to go against practice that has been established in many parts of coreboot for years.
I don't really agree with this at least in the form provided here -- I think weak functions are fine in the right context and cluttering Kconfig with a billion PLATFORM_USES_HOOK_XYZ isn't fundamentally a better alternative. We can discuss which situations are and aren't a good fit for weak symbols and then try to agree on some guidelines based on that, but I don't think a blanket "they're bad" is the right approach.
Personally, I think weak functions are a good solution whenever generic code has a hook that can optionally be implemented by more specific (e.g. SoC or mainboard) code. Good examples for this are things like bootblock_soc_init(), bootblock_mainboard_init(), bootblock_mainboard_early_init(), etc... most platforms implement most of these functions, but sometimes not all of them. Hiding each of them behind a Kconfig and splattering every soc/.../Kconfig file with `select HAS_BOOTBLOCK_SOC_INIT`, `select HAS_BOOTBLOCK_SOC_EARLY_INIT`, etc. would just create a lot more config boilerplate (making it harder to read the meaningful options in between) and I don't think it would really help anyone's understanding of the code. The other alternative would be to add empty stub functions to each individual mainboard/SoC file when they're not using those hooks, but that's just adding more boilerplate there and I don't see how it would really make anything better either... also, it is a really annoying maintenance burden because whenever you need to add a new hook somewhere, you would have to add empty stubs to a billion SoC/mainboard files. I think weak functions solve this problem well and without causing any real issues... I mean, it's a hook, either you do something there or you don't, when you forgot to implement it then I guess your platform didn't need it anyway and the default weak no-op function was the right choice for you.
On the other hand, I do agree that weak functions can make things very confusing when the weak function actually implements meaningful behavior, and then overriding the function means you're missing that behavior. That's a terrible pattern that I think/hope we don't really use in coreboot anyway, and I think codifying that in the style guide would be fine. Weak functions should only be allowed when the weak implementation is a no-op or otherwise represents the most simple and "default" way the function could be implemented (and when that default implementation is generally "safe" from a security standpoint -- e.g. the weak implementation of vboot's get_recovery_mode_switch() is behind an extra Kconfig for a reason), but for those cases I think they can be an appropriate tool.
File Documentation/contributing/coding_style.md:
https://review.coreboot.org/c/coreboot/+/58934/comment/c8088e6a_bfe9c6d2
PS2, Line 967: result in runtime
: problems due to the lack of a proper implementation, where they could
: otherwise be caught at compiletime
Can you provide a concrete example of where this happened? I'm not really sure what you mean by this / don't think you can say this as an absolute.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58934
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If70d38c5c646c1e8365bb16d3292cebb2787eba2
Gerrit-Change-Number: 58934
Gerrit-PatchSet: 2
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:31:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Martin Roth, Jason Glenesk, Felix Held.
Matt DeVillier has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58975 )
Change subject: Documentation/releases: Update 4.15 vboot supported boards
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
I think it would be a lot more helpful if the various Google boards were arranged/grouped based on baseboard/variant, something like:
- Poppy
-- Nami
--- Akali (Acer Chromebook 13 / Spin 13)
--- Pantheon (Lenovo Yoga Chromebook C630)
--- Sona (HP Chromebook x360 14)
--- Syndra (HP Chromebook 15 G1)
--- Vayne (Dell Inspiron Chromebook 14 7460)
-- Nautilus (Samsung Chromebook Plus V2, V2 LTE)
Not sure how feasible it would be to script that, but hand corrections wouldn't be too bad (and I'm happy to do so)
--
To view, visit https://review.coreboot.org/c/coreboot/+/58975
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id5d4d18202bf85c5ba407efd690eee5cba88a8a7
Gerrit-Change-Number: 58975
Gerrit-PatchSet: 2
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:25:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Martin Roth, Jason Glenesk, Felix Held.
Matt DeVillier has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59022 )
Change subject: Documentation/releases: Update 4.16 target date and cadence information
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/59022
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6c8327a7cf47217d32359b304b21e806c10dcc62
Gerrit-Change-Number: 59022
Gerrit-PatchSet: 3
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:11:41 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Sean Rhodes, Martin Roth, Matt DeVillier, Paul Menzel, Tim Wawrzynczak, Angel Pons.
Hello build bot (Jenkins), Martin Roth, Matt DeVillier, Tim Wawrzynczak, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/58854
to look at the new patch set (#32).
Change subject: [WIP] util: Add coreboot Configurator
......................................................................
[WIP] util: Add coreboot Configurator
A simply GUI to change settings in coreboot's CBFS, via the nvramtool utility.
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: Ie654f6aca57a792be0c295afc081a95ed4d875d1
---
M 3rdparty/blobs
A util/coreboot-configurator/README.md
A util/coreboot-configurator/contrib/PKGBUILD
A util/coreboot-configurator/contrib/README.md
A util/coreboot-configurator/contrib/debian/changelog
A util/coreboot-configurator/contrib/debian/compat
A util/coreboot-configurator/contrib/debian/control
A util/coreboot-configurator/contrib/debian/files
A util/coreboot-configurator/contrib/debian/rules
A util/coreboot-configurator/contrib/debian/source/format
A util/coreboot-configurator/contrib/flatpak/coreboot-configurator.json
A util/coreboot-configurator/contrib/flatpak/org.coreboot.coreboot-configurator.json
A util/coreboot-configurator/meson.build
A util/coreboot-configurator/meson_options.txt
A util/coreboot-configurator/screenshots/coreboot-configurator.gif
A util/coreboot-configurator/screenshots/coreboot-configurator.png
A util/coreboot-configurator/src/application/aboutwindow.cpp
A util/coreboot-configurator/src/application/aboutwindow.h
A util/coreboot-configurator/src/application/aboutwindow.ui
A util/coreboot-configurator/src/application/categories.yaml
A util/coreboot-configurator/src/application/configuration.cpp
A util/coreboot-configurator/src/application/configuration.h
A util/coreboot-configurator/src/application/corebootconfigurator.cpp
A util/coreboot-configurator/src/application/corebootconfigurator.h
A util/coreboot-configurator/src/application/corebootconfigurator.ui
A util/coreboot-configurator/src/application/images.qrc
A util/coreboot-configurator/src/application/main.cpp
A util/coreboot-configurator/src/application/meson.build
A util/coreboot-configurator/src/application/nvramtoolcli.cpp
A util/coreboot-configurator/src/application/nvramtoolcli.h
A util/coreboot-configurator/src/application/qtyaml.h
A util/coreboot-configurator/src/application/toggle-off.svg
A util/coreboot-configurator/src/application/toggle-on.svg
A util/coreboot-configurator/src/application/toggleswitch.cpp
A util/coreboot-configurator/src/application/toggleswitch.h
A util/coreboot-configurator/src/application/util.h
A util/coreboot-configurator/src/meson.build
A util/coreboot-configurator/src/static/aboutIcon.png
A util/coreboot-configurator/src/static/categories.yaml
A util/coreboot-configurator/src/static/coreboot-configurator.desktop
A util/coreboot-configurator/src/static/coreboot_configurator.svg
A util/coreboot-configurator/src/static/meson.build
A util/coreboot-configurator/src/static/org.coreboot.nvramtool.policy
A util/coreboot-configurator/src/static/org.coreboot.reboot.policy
44 files changed, 3,175 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/54/58854/32
--
To view, visit https://review.coreboot.org/c/coreboot/+/58854
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie654f6aca57a792be0c295afc081a95ed4d875d1
Gerrit-Change-Number: 58854
Gerrit-PatchSet: 32
Gerrit-Owner: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Reviewer: Angel Pons <angel.pons(a)9elements.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)google.com>
Gerrit-Attention: Angel Pons <angel.pons(a)9elements.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Martin Roth, Jason Glenesk.
Matt DeVillier has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58974 )
Change subject: Documentation/releases: Update 4.15 release notes
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/58974
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie4d47456cce38e7ec4329f8cb839167017c7e26b
Gerrit-Change-Number: 58974
Gerrit-PatchSet: 1
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:05:21 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Martin Roth, Felix Held.
Jason Glenesk has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58975 )
Change subject: Documentation/releases: Update 4.15 vboot supported boards
......................................................................
Patch Set 2:
(1 comment)
File Documentation/security/vboot/list_vboot.md:
https://review.coreboot.org/c/coreboot/+/58975/comment/f9f0eb17_3129a5b5
PS1, Line 137: (Asus Chromebook C425, Flip C433, Flip C434)
> this probably shouldn't be removed; at least that comment is in the current source code, so i assume […]
It looks like the devices were moved into the help of the Kconfig vs having them in the name. I think we will have to modify the generation script in the future to account for this. I have manually replaced them for now.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58975
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id5d4d18202bf85c5ba407efd690eee5cba88a8a7
Gerrit-Change-Number: 58975
Gerrit-PatchSet: 2
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 08 Nov 2021 21:02:35 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Martin Roth.
Hello Felix Singer, build bot (Jenkins), Martin Roth, Felix Held,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/58975
to look at the new patch set (#2).
Change subject: Documentation/releases: Update 4.15 vboot supported boards
......................................................................
Documentation/releases: Update 4.15 vboot supported boards
Update list of boards that support vboot.
Change-Id: Id5d4d18202bf85c5ba407efd690eee5cba88a8a7
Signed-off-by: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
---
M Documentation/security/vboot/list_vboot.md
1 file changed, 44 insertions(+), 34 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/75/58975/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/58975
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id5d4d18202bf85c5ba407efd690eee5cba88a8a7
Gerrit-Change-Number: 58975
Gerrit-PatchSet: 2
Gerrit-Owner: Jason Glenesk <jason.glenesk(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-MessageType: newpatchset