Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19757 )
Change subject: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure
......................................................................
Patch Set 5:
(1 comment)
https://review.coreboot.org/#/c/19757/5/src/include/spi_flash.h
File src/include/spi_flash.h:
PS5, Line 37: spi_flash_ctrlr
> Ya. It might be better named like that. However, noting that the probe func
Agreed. It will avoid lot of confusion around the use of structure and who needs to define what and how it has to be used. I will update the CLs.
--
To view, visit https://review.coreboot.org/19757
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I550cc4556fc4b63ebc174a7e2fde42251fe56052
Gerrit-PatchSet: 5
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19757 )
Change subject: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure
......................................................................
Patch Set 5:
(3 comments)
https://review.coreboot.org/#/c/19757/5/src/drivers/spi/spi_flash.c
File src/drivers/spi/spi_flash.c:
Line 392: if (flash->ctrlr->status)
> I take it status() wasn't always available? Yes, that indeed does look that
Yeah, status() isn't provided by every driver.
https://review.coreboot.org/#/c/19757/5/src/drivers/spi/winbond.c
File src/drivers/spi/winbond.c:
Line 187: const struct spi_flash_ctrlr spi_flash_ctrlr = {
> static const
Done
https://review.coreboot.org/#/c/19757/5/src/include/spi_flash.h
File src/include/spi_flash.h:
PS5, Line 37: spi_flash_ctrlr
> The one issue is that the spi part drivers aren't really controllers. Howev
Yeah, even I did not like the _ctrlr since its not truly a controller. Does "spi_flash_ops" seem like a better name for this structure?
--
To view, visit https://review.coreboot.org/19757
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I550cc4556fc4b63ebc174a7e2fde42251fe56052
Gerrit-PatchSet: 5
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19708 )
Change subject: drivers/spi: Define spi_flash_ctrlr structure
......................................................................
Patch Set 8:
(1 comment)
https://review.coreboot.org/#/c/19708/8/src/southbridge/intel/common/spi.c
File src/southbridge/intel/common/spi.c:
Line 947: int spi_setup_slave(unsigned int bus, unsigned int cs, struct spi_slave *slave)
> We use spi_setup_slave() strong symbol because we never implemented the bus
Yeah, I have that on my todo for a while.. Just haven't been able to get to it yet.
--
To view, visit https://review.coreboot.org/19708
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I35f3bd8ddc5e71515df3ef0c1c4b1a68ee56bf4b
Gerrit-PatchSet: 8
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19708 )
Change subject: drivers/spi: Define spi_flash_ctrlr structure
......................................................................
Patch Set 11:
> This'll work, but I think Julius' idea is a good one to implement.
Yeah I have implemented Julius' idea and uploaded as a separate patchset.
--
To view, visit https://review.coreboot.org/19708
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I35f3bd8ddc5e71515df3ef0c1c4b1a68ee56bf4b
Gerrit-PatchSet: 11
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: No
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/19757
to look at the new patch set (#5).
Change subject: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure
......................................................................
drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure
Now that we have a spi_flash_ctrlr structure, move all spi flash
operations to this structure and add a pointer to this structure in
struct spi_flash.
BUG=b:38330715
Change-Id: I550cc4556fc4b63ebc174a7e2fde42251fe56052
Signed-off-by: Furquan Shaikh <furquan(a)chromium.org>
---
M src/drivers/spi/adesto.c
M src/drivers/spi/amic.c
M src/drivers/spi/atmel.c
M src/drivers/spi/eon.c
M src/drivers/spi/gigadevice.c
M src/drivers/spi/macronix.c
M src/drivers/spi/spansion.c
M src/drivers/spi/spi_flash.c
M src/drivers/spi/sst.c
M src/drivers/spi/stmicro.c
M src/drivers/spi/winbond.c
M src/include/spi_flash.h
M src/soc/intel/common/block/fast_spi/fast_spi_flash.c
M src/soc/mediatek/mt8173/flash_controller.c
M src/southbridge/intel/common/spi.c
15 files changed, 179 insertions(+), 119 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/57/19757/5
--
To view, visit https://review.coreboot.org/19757
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I550cc4556fc4b63ebc174a7e2fde42251fe56052
Gerrit-PatchSet: 5
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>