HAOUAS Elyes has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/45328 )
Change subject: include/device/pnp_ops.h: Use 'PNP_IDX_EN' instead of magic number ......................................................................
include/device/pnp_ops.h: Use 'PNP_IDX_EN' instead of magic number
Change-Id: I8edfbadc83e48e3a74dbb8d85fc2857d6f4283d4 Signed-off-by: Elyes HAOUAS ehaouas@noos.fr --- M src/include/device/pnp_ops.h 1 file changed, 3 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/28/45328/1
diff --git a/src/include/device/pnp_ops.h b/src/include/device/pnp_ops.h index 0cfdd61..18b35be 100644 --- a/src/include/device/pnp_ops.h +++ b/src/include/device/pnp_ops.h @@ -6,6 +6,7 @@ #include <stdint.h> #include <arch/io.h> #include <device/pnp.h> +#include <device/pnp_def.h> #include <device/pnp_type.h>
#if ENV_PNP_SIMPLE_DEVICE @@ -32,13 +33,13 @@ static __always_inline void pnp_set_enable(pnp_devfn_t dev, int enable) { - pnp_write_config(dev, 0x30, enable?0x1:0x0); + pnp_write_config(dev, PNP_IDX_EN, enable?0x1:0x0); }
static __always_inline int pnp_read_enable(pnp_devfn_t dev) { - return !!pnp_read_config(dev, 0x30); + return !!pnp_read_config(dev, PNP_IDX_EN); }
static __always_inline
HAOUAS Elyes has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/45328 )
Change subject: include/device/pnp_ops.h: Use 'PNP_IDX_EN' instead of magic number ......................................................................
Abandoned
duplicated