Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/73498 )
Change subject: soc/amd/common/block/acpi/cpu_power_state: use definition for bit_offset ......................................................................
soc/amd/common/block/acpi/cpu_power_state: use definition for bit_offset
Instead of using a magic constant in the bit_offset field of the C state resource for the C1 state that's entered via the MWAIT instruction, use the existing ACPI_FFIXEDHW_CLASS_MWAIT define. This value is checked by acpi_processor_ffh_cstate_probe in the Linux kernel.
Signed-off-by: Felix Held felix-coreboot@felixheld.de Change-Id: I9edc681efab15b5ceba91c8105f7dc6d687d8be8 --- M src/soc/amd/common/block/acpi/cpu_power_state.c 1 file changed, 16 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/98/73498/1
diff --git a/src/soc/amd/common/block/acpi/cpu_power_state.c b/src/soc/amd/common/block/acpi/cpu_power_state.c index 875de2b..d6b1eb3 100644 --- a/src/soc/amd/common/block/acpi/cpu_power_state.c +++ b/src/soc/amd/common/block/acpi/cpu_power_state.c @@ -24,7 +24,7 @@ entry->resource = (acpi_addr_t){ .space_id = ACPI_ADDRESS_SPACE_FIXED, .bit_width = 2, - .bit_offset = 2, + .bit_offset = ACPI_FFIXEDHW_CLASS_MWAIT, .addrl = 0, .addrh = 0, };