Attention is currently required from: Arthur Heymans, Philipp Hug, ron minnich.
Maximilian Brune has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/81286?usp=email )
Change subject: arch/riscv: add constants for Base Extension ......................................................................
Patch Set 1:
(2 comments)
File src/arch/riscv/include/sbi.h:
https://review.coreboot.org/c/coreboot/+/81286/comment/0dac053a_20f59f1c : PS1, Line 20: #define SBI_EXTENSION_ID 0x10 I would change the name to SBI_BASE_EXTENSION (makes it more easy to find the appropriate place in the SBI spec).
https://review.coreboot.org/c/coreboot/+/81286/comment/fc9d4b6d_62b94c35 : PS1, Line 20: define SBI_EXTENSION_ID 0x10 : #define SBI_GET_SBI_SPEC_VERSION 0 : #define SBI_GET_SBI_IMPL_ID 1 : #define SBI_GET_SBI_IMPL_VERSION 2 : #define SBI_PROBE_EXTENSION 3 : #define SBI_GET_MVENDORID 4 : #define SBI_GET_MARCHID 5 : #define SBI_GET_MIMPID 6 maybe something like this: ``` #define SBI_BASE_EXTENSION 0x10 # define SBI_GET_SBI_SPEC_VERSION 0 # define SBI_GET_SBI_IMPL_ID 1 # define SBI_GET_SBI_IMPL_VERSION 2 # define SBI_PROBE_EXTENSION 3 # define SBI_GET_MVENDORID 4 # define SBI_GET_MARCHID 5 # define SBI_GET_MIMPID 6 ``` to visualize the attachment of the FIDs to the specific EID.