insomniac has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/41720 )
Change subject: mb/ocp/deltalake: Update SMBIOS type 0 firmware version by VPD variable ......................................................................
Patch Set 11:
(1 comment)
https://review.coreboot.org/c/coreboot/+/41720/11/src/mainboard/ocp/deltalak... File src/mainboard/ocp/deltalake/ramstage.c:
https://review.coreboot.org/c/coreboot/+/41720/11/src/mainboard/ocp/deltalak... PS11, Line 79: const char *smbios_mainboard_bios_version(void) this feature would be useful beyond just DeltaLake. I am wondering whether we can generalize it in a way that: * doesn't change coreboot's default behaviour * allows more granular control (e.g. what is the fallback if the VPD variable is missing?)
Some ideas to do that: 1. make this a global Kconfig tunable (e.g. CONFIG_VERSION_VPD, or any better name), whose value is the name of the VPD variable to read (instead of the hard-coded "version") 2. if this is set, override the default behaviour, otherwise use the normal versioning system 3. add a dependent config value for default value if the VPD var is missing (e.g. CONFIG_VERSION_VPD_DEFAULT_IF_MISSING), whose value would be used if VPD version is missing; and if not set, will return `coreboot_version`