Attention is currently required from: Maximilian Brune.
Martin L Roth has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/76689?usp=email )
Change subject: soc/sifive/fu740: Add FU740 SOC ......................................................................
Patch Set 12:
(8 comments)
File src/soc/sifive/fu740/cbmem.c:
https://review.coreboot.org/c/coreboot/+/76689/comment/5d2c80c3_116a20b0 : PS12, Line 11: #define FU740_MAXDRAM 0x800000000ULL // 32 GiB Can we move this outside of the function?
File src/soc/sifive/fu740/clint.c:
https://review.coreboot.org/c/coreboot/+/76689/comment/4e0be3c7_a057fca8 : PS12, Line 11: (uint64_t *)(FU740_CLINT + 0xbff8); : HLS()->timecmp = (uint64_t *)(FU740_CLINT + 0x4000 + 8 * hart_id); Can the magic numbers be made into #defines?
https://review.coreboot.org/c/coreboot/+/76689/comment/ca322a35_15c19bd6 : PS12, Line 17: 4 * (uintptr_t)hartid I assume this means we're always 32-bit? If that's not the case, should hartid be cast to a 32-bit value?
File src/soc/sifive/fu740/clock.c:
https://review.coreboot.org/c/coreboot/+/76689/comment/d9d6e01a_b2ae9372 : PS12, Line 16: * Nit: Add some spaces around '*'?
https://review.coreboot.org/c/coreboot/+/76689/comment/dd838532_642f88b8 : PS12, Line 153: Oszillator oscillator?
File src/soc/sifive/fu740/ddrregs.c:
https://review.coreboot.org/c/coreboot/+/76689/comment/ca504f2e_6798e480 : PS12, Line 1: /* SPDX-License-Identifier: Apache-2.0 */ Did this file come from somewhere else? Why not just GPL?
https://review.coreboot.org/c/coreboot/+/76689/comment/e20a3b76_fd1eb4e3 : PS12, Line 9: DENALI_PHY_00_DATA Why bother with the #defines? why not just include the data directly?
File src/soc/sifive/fu740/spi_internal.h:
https://review.coreboot.org/c/coreboot/+/76689/comment/919fcd69_e8a9fc45 : PS12, Line 1: /* SPDX-License-Identifier: GPL-2.0-only */ Put this into the include directory?