Attention is currently required from: Jason Glenesk, Raul Rangel, Anjaneya "Reddy" Chagam, Marshall Dawson, Jonathan Zhang, Johnny Lin, Paul Menzel, Arthur Heymans, Morgan Jang, Patrick Rudolph, Felix Held.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/55063 )
Change subject: use initial_lapicid() instead of opencoding it
......................................................................
Patch Set 1:
(6 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/55063/comment/01103bc9_e6aa140e
PS1, Line 7: opencoding
I believe `open coding` is spelled with a space
https://review.coreboot.org/c/coreboot/+/55063/comment/df06e502_7bcf519f
PS1, Line 7: use
Nit: Use
I'd also add a prefix:
src: Use initial_lapicid() ...
File src/drivers/amd/agesa/eventlog.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/babf5a4e_1c374566
PS1, Line 101: task->apic_id = (u8)initial_lapicid();
Would this work in x2APIC mode?
File src/drivers/amd/agesa/romstage.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/60538480_9ef56621
PS1, Line 39: u32
`unsigned int`
File src/soc/amd/stoneyridge/mca.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/f2bc8f77_b407a836
PS1, Line 169: uint32_t
`initial_lapicid()` returns `unsigned int`. Any reason to change this type, though?
https://review.coreboot.org/c/coreboot/+/55063/comment/dd8bef98_a99942b7
PS1, Line 171: %d
Needs to be changed to `%u` now that `core` is of unsigned type. Even easier would be to leave the type of `core` as-is, as done for Picasso.
--
To view, visit
https://review.coreboot.org/c/coreboot/+/55063
To unsubscribe, or for help writing mail filters, visit
https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I289015b81b2a9d915c4cab9b0544fc19b85df7a3
Gerrit-Change-Number: 55063
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans
arthur@aheymans.xyz
Gerrit-Reviewer: Anjaneya "Reddy" Chagam
anjaneya.chagam@intel.com
Gerrit-Reviewer: Felix Held
felix-coreboot@felixheld.de
Gerrit-Reviewer: Jason Glenesk
jason.glenesk@gmail.com
Gerrit-Reviewer: Johnny Lin
Johnny_Lin@wiwynn.com
Gerrit-Reviewer: Jonathan Zhang
jonzhang@fb.com
Gerrit-Reviewer: Marshall Dawson
marshalldawson3rd@gmail.com
Gerrit-Reviewer: Morgan Jang
Morgan_Jang@wiwynn.com
Gerrit-Reviewer: Patrick Rudolph
siro@das-labor.org
Gerrit-Reviewer: Raul Rangel
rrangel@chromium.org
Gerrit-Reviewer: build bot (Jenkins)
no-reply@coreboot.org
Gerrit-CC: Angel Pons
th3fanbus@gmail.com
Gerrit-CC: Paul Menzel
paulepanter@mailbox.org
Gerrit-Attention: Jason Glenesk
jason.glenesk@gmail.com
Gerrit-Attention: Raul Rangel
rrangel@chromium.org
Gerrit-Attention: Anjaneya "Reddy" Chagam
anjaneya.chagam@intel.com
Gerrit-Attention: Marshall Dawson
marshalldawson3rd@gmail.com
Gerrit-Attention: Jonathan Zhang
jonzhang@fb.com
Gerrit-Attention: Johnny Lin
Johnny_Lin@wiwynn.com
Gerrit-Attention: Paul Menzel
paulepanter@mailbox.org
Gerrit-Attention: Arthur Heymans
arthur@aheymans.xyz
Gerrit-Attention: Morgan Jang
Morgan_Jang@wiwynn.com
Gerrit-Attention: Patrick Rudolph
siro@das-labor.org
Gerrit-Attention: Felix Held
felix-coreboot@felixheld.de
Gerrit-Comment-Date: Sun, 30 May 2021 09:04:13 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel
paulepanter@mailbox.org
Gerrit-MessageType: comment