Attention is currently required from: Fred Reitberger, Jason Glenesk, Matt DeVillier, Raul Rangel.
Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/76934?usp=email )
Change subject: soc/amd/common/data_fabric/domain: rename add_io_regions ......................................................................
soc/amd/common/data_fabric/domain: rename add_io_regions
Rename add_io_regions to add_data_fabric_io_regions to be consistent with add_data_fabric_mmio_regions.
Signed-off-by: Felix Held felix-coreboot@felixheld.de Change-Id: Ia990cc14dd6dc162ad614a6e9e0b36426cb04670 --- M src/soc/amd/common/block/data_fabric/domain.c 1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/34/76934/1
diff --git a/src/soc/amd/common/block/data_fabric/domain.c b/src/soc/amd/common/block/data_fabric/domain.c index 66ad8b3..cfd4e0f 100644 --- a/src/soc/amd/common/block/data_fabric/domain.c +++ b/src/soc/amd/common/block/data_fabric/domain.c @@ -150,7 +150,7 @@ }
/* Tell the resource allocator about the usable I/O space */ -static void add_io_regions(struct device *domain, unsigned int *idx) +static void add_data_fabric_io_regions(struct device *domain, unsigned int *idx) { /* TODO: Systems with more than one PCI root need to read the data fabric registers to see which IO ranges get decoded to which PCI root. */ @@ -162,7 +162,7 @@ { unsigned int idx = 0;
- add_io_regions(domain, &idx); + add_data_fabric_io_regions(domain, &idx);
add_data_fabric_mmio_regions(domain, &idx);