Yidi Lin has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
soc/mediatek/mt8183: Move dsi driver to common/
The mt8183 dsi driver can be shared with mt819x SoC. Move dsi.c to common/ folder and rename it to dis_v2.c to differentiate it from mt8173's dsi driver.
TEST=emerge-kukuki coreboot
Change-Id: I722d3e67f230ab8eb729900cdf15b922eb91a072 Signed-off-by: Yidi Lin yidi.lin@mediatek.com --- R src/soc/mediatek/common/dsi_v2.c M src/soc/mediatek/mt8183/Makefile.inc 2 files changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/30/48530/1
diff --git a/src/soc/mediatek/mt8183/dsi.c b/src/soc/mediatek/common/dsi_v2.c similarity index 100% rename from src/soc/mediatek/mt8183/dsi.c rename to src/soc/mediatek/common/dsi_v2.c diff --git a/src/soc/mediatek/mt8183/Makefile.inc b/src/soc/mediatek/mt8183/Makefile.inc index b5d5173..6309363 100644 --- a/src/soc/mediatek/mt8183/Makefile.inc +++ b/src/soc/mediatek/mt8183/Makefile.inc @@ -47,7 +47,7 @@ ramstage-y += emi.c ramstage-y += ../common/auxadc.c ramstage-y += ../common/ddp.c ddp.c -ramstage-y += ../common/dsi.c dsi.c +ramstage-y += ../common/dsi.c ../common/dsi_v2.c ramstage-y += ../common/gpio.c gpio.c ramstage-y += ../common/i2c.c i2c.c ramstage-y += ../common/mcu.c
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 2:
sorry, changed my mind.
given the dsi.c for 8173 is probably never going to be moved to common, I think we can call this just 'common/dsi.c', and create dsi_v2 when we really see something different.
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 2:
oh, wait - there's already common/dsi.c. dsi_v2 is not a good name in that case. Do you have some other names or identifiers to help people understanding "this is the dsi implementation for 8183 and 8192, but not 8173"?
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 2:
is it correct to call it dsi_mali.c ? (I'd assume 8183/92 are using mali and that's why dsi.c is the same?)
Hello Hung-Te Lin, build bot (Jenkins), Huijuan Xie, Patrick Georgi, Martin Roth, Yu-Ping Wu,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/48530
to look at the new patch set (#4).
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
soc/mediatek/mt8183: Move dsi driver to common/
The mt8183 dsi driver can be shared with mt819x SoC. Move dsi.c to common/ folder and rename it to dis_v2.c to differentiate it from mt8173's dsi driver.
TEST=emerge-kukuki coreboot
Change-Id: I722d3e67f230ab8eb729900cdf15b922eb91a072 Signed-off-by: Yidi Lin yidi.lin@mediatek.com --- R src/soc/mediatek/common/dsi_v2.c M src/soc/mediatek/mt8183/Makefile.inc 2 files changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/30/48530/4
Yidi Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 4:
Patch Set 2:
is it correct to call it dsi_mali.c ? (I'd assume 8183/92 are using mali and that's why dsi.c is the same?)
Discussed with DSI, the DSI IP (MediaTek MIPI DPHY) used by 8173 is obsolete. What about rename to mtk_mipi_dphy_v2.c ?
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 4:
Discussed with DSI, the DSI IP (MediaTek MIPI DPHY) used by 8173 is obsolete. What about rename to mtk_mipi_dphy_v2.c ?
I think the goal is to have a name that consistent with your internal naming or understanding.
Do you really call that DSI IP "v2"? If yes then we can do it, otherwise I'm fine with just calling this 'common/mtk_mipi_dphy.c' and use it (and just forget about 8173 since it's pretty old and we'll not have more SOCs sharing its code base)
Hello Hung-Te Lin, build bot (Jenkins), Huijuan Xie, Patrick Georgi, Martin Roth, Yu-Ping Wu,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/48530
to look at the new patch set (#5).
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
soc/mediatek/mt8183: Move dsi driver to common/
The mt8183 dsi driver can be shared with mt819x SoC. Move dsi.c to common/ folder and rename it to dis_v2.c to differentiate it from mt8173's dsi driver.
TEST=emerge-kukuki coreboot
Change-Id: I722d3e67f230ab8eb729900cdf15b922eb91a072 Signed-off-by: Yidi Lin yidi.lin@mediatek.com --- R src/soc/mediatek/common/mtk_mipi_dphy.c M src/soc/mediatek/mt8183/Makefile.inc 2 files changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/30/48530/5
Yidi Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 5:
Patch Set 4:
Discussed with DSI, the DSI IP (MediaTek MIPI DPHY) used by 8173 is obsolete. What about rename to mtk_mipi_dphy_v2.c ?
I think the goal is to have a name that consistent with your internal naming or understanding.
Do you really call that DSI IP "v2"? If yes then we can do it, otherwise I'm fine with just calling this 'common/mtk_mipi_dphy.c' and use it (and just forget about 8173 since it's pretty old and we'll not have more SOCs sharing its code base)
OK. just call it 'common/mtk_mipi_dphy.c'.
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
Patch Set 5: Code-Review+2
Hung-Te Lin has submitted this change. ( https://review.coreboot.org/c/coreboot/+/48530 )
Change subject: soc/mediatek/mt8183: Move dsi driver to common/ ......................................................................
soc/mediatek/mt8183: Move dsi driver to common/
The mt8183 dsi driver can be shared with mt819x SoC. Move dsi.c to common/ folder and rename it to dis_v2.c to differentiate it from mt8173's dsi driver.
TEST=emerge-kukuki coreboot
Change-Id: I722d3e67f230ab8eb729900cdf15b922eb91a072 Signed-off-by: Yidi Lin yidi.lin@mediatek.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/48530 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Hung-Te Lin hungte@chromium.org --- R src/soc/mediatek/common/mtk_mipi_dphy.c M src/soc/mediatek/mt8183/Makefile.inc 2 files changed, 1 insertion(+), 1 deletion(-)
Approvals: build bot (Jenkins): Verified Hung-Te Lin: Looks good to me, approved
diff --git a/src/soc/mediatek/mt8183/dsi.c b/src/soc/mediatek/common/mtk_mipi_dphy.c similarity index 100% rename from src/soc/mediatek/mt8183/dsi.c rename to src/soc/mediatek/common/mtk_mipi_dphy.c diff --git a/src/soc/mediatek/mt8183/Makefile.inc b/src/soc/mediatek/mt8183/Makefile.inc index b5d5173..744455d 100644 --- a/src/soc/mediatek/mt8183/Makefile.inc +++ b/src/soc/mediatek/mt8183/Makefile.inc @@ -47,7 +47,7 @@ ramstage-y += emi.c ramstage-y += ../common/auxadc.c ramstage-y += ../common/ddp.c ddp.c -ramstage-y += ../common/dsi.c dsi.c +ramstage-y += ../common/dsi.c ../common/mtk_mipi_dphy.c ramstage-y += ../common/gpio.c gpio.c ramstage-y += ../common/i2c.c i2c.c ramstage-y += ../common/mcu.c