Attention is currently required from: Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya.
Nick Kochlowski has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver ......................................................................
Patch Set 17:
(4 comments)
File src/drivers/amd/opensil/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/9747469b_3ed0c6f8?usp... : PS16, Line 18: int
i'd expect this to be an unsigned int. iirc this is implementation defined though. […]
Done
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/5e9aaf75_47115384?usp... : PS16, Line 10: int
i'd expect this to be an unsigned int or possibly uint32_t
Done
https://review.coreboot.org/c/coreboot/+/85634/comment/c1c3fe33_2c395782?usp... : PS16, Line 37: for (i = 0; i < ARRAY_SIZE(types); i++) : if (enum_type == types[i].type) : break; : if (i == ARRAY_SIZE(types)) : return "Unknown type"; : return types[i].string;
something for another patch, which is why i mark it as resolved, but this code can be rewritten to m […]
Agreed, it's much easier to read this way. I added this change to the new patchset. Is that OK or should I push a separate add-on patch just for this?
https://review.coreboot.org/c/coreboot/+/85634/comment/16c007d9_b8e2f127?usp... : PS16, Line 51: *hole_info = NULL;
i'd also set n_holes to 0 in the error case just to be sure. […]
Done