HAOUAS Elyes has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/44837 )
Change subject: mb/getac/p470: Use PNP_IDX_EN instead of magic number ......................................................................
mb/getac/p470: Use PNP_IDX_EN instead of magic number
Change-Id: Ie75e29ed307647f20a5b74deb6d998278fb99b7d Signed-off-by: Elyes HAOUAS ehaouas@noos.fr --- M src/mainboard/getac/p470/early_init.c 1 file changed, 2 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/37/44837/1
diff --git a/src/mainboard/getac/p470/early_init.c b/src/mainboard/getac/p470/early_init.c index 087e279..c003d48 100644 --- a/src/mainboard/getac/p470/early_init.c +++ b/src/mainboard/getac/p470/early_init.c @@ -3,6 +3,7 @@ #include <bootblock_common.h> #include <stdint.h> #include <arch/io.h> +#include <device/pnp_def.h> #include <device/pnp_ops.h> #include <device/pci_ops.h> #include <option.h> @@ -75,7 +76,7 @@ pnp_write_config(dev, 0x24, (0x3f8 >> 2)); // UART1 base pnp_write_config(dev, 0x28, (4 << 4) | 0); // UART1,2 IRQ pnp_write_config(dev, 0x2c, 0); // DMA0 FIR - pnp_write_config(dev, 0x30, (0x600 >> 4)); // Runtime Register Block Base + pnp_write_config(dev, PNP_IDX_EN, (0x600 >> 4)); // Runtime Register Block Base
pnp_write_config(dev, 0x31, 0xce); // GPIO1 DIR pnp_write_config(dev, 0x32, 0x00); // GPIO1 POL
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/44837 )
Change subject: mb/getac/p470: Use PNP_IDX_EN instead of magic number ......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/c/coreboot/+/44837/1/src/mainboard/getac/p470/ea... File src/mainboard/getac/p470/early_init.c:
https://review.coreboot.org/c/coreboot/+/44837/1/src/mainboard/getac/p470/ea... PS1, Line 79: pnp_write_config(dev, PNP_IDX_EN, (0x600 >> 4)); // Runtime Register Block Base I'm unsure if this one is semantically correct, since the SMSC SIO chips are the ones that don't follow the LDN layout from appendix A of the plug and play ISA specification and the comment points in some other direction. Haven't checked the datasheet
HAOUAS Elyes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/44837 )
Change subject: mb/getac/p470: Use PNP_IDX_EN instead of magic number ......................................................................
Patch Set 1: Code-Review-1
(1 comment)
https://review.coreboot.org/c/coreboot/+/44837/1/src/mainboard/getac/p470/ea... File src/mainboard/getac/p470/early_init.c:
https://review.coreboot.org/c/coreboot/+/44837/1/src/mainboard/getac/p470/ea... PS1, Line 79: pnp_write_config(dev, PNP_IDX_EN, (0x600 >> 4)); // Runtime Register Block Base
I'm unsure if this one is semantically correct, since the SMSC SIO chips are the ones that don't fol […]
You are right Thanks
HAOUAS Elyes has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/44837 )
Change subject: mb/getac/p470: Use PNP_IDX_EN instead of magic number ......................................................................
Abandoned