Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/19757 )
Change subject: drivers/spi/flash: Move flash ops to spi_flash_ctrlr structure ......................................................................
Patch Set 5:
(3 comments)
https://review.coreboot.org/#/c/19757/5/src/drivers/spi/spi_flash.c File src/drivers/spi/spi_flash.c:
Line 392: if (flash->ctrlr->status)
I take it status() wasn't always available? Yes, that indeed does look that
Yeah, status() isn't provided by every driver.
https://review.coreboot.org/#/c/19757/5/src/drivers/spi/winbond.c File src/drivers/spi/winbond.c:
Line 187: const struct spi_flash_ctrlr spi_flash_ctrlr = {
static const
Done
https://review.coreboot.org/#/c/19757/5/src/include/spi_flash.h File src/include/spi_flash.h:
PS5, Line 37: spi_flash_ctrlr
The one issue is that the spi part drivers aren't really controllers. Howev
Yeah, even I did not like the _ctrlr since its not truly a controller. Does "spi_flash_ops" seem like a better name for this structure?