Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/33628
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability
ALIGN_UP is an alias for ALIGN.
Change-Id: Ie723ebe80f8f627021151413cb43adce6c88a0dc Signed-off-by: Felix Held felix-coreboot@felixheld.de --- M src/arch/x86/smbios.c 1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/28/33628/1
diff --git a/src/arch/x86/smbios.c b/src/arch/x86/smbios.c index 54c2b09..50dac7f 100644 --- a/src/arch/x86/smbios.c +++ b/src/arch/x86/smbios.c @@ -1150,12 +1150,12 @@ int max_struct_size = 0; int handle = 0;
- current = ALIGN(current, 16); + current = ALIGN_UP(current, 16); printk(BIOS_DEBUG, "%s: %08lx\n", __func__, current);
se = (struct smbios_entry *)current; current += sizeof(struct smbios_entry); - current = ALIGN(current, 16); + current = ALIGN_UP(current, 16);
tables = current; update_max(len, max_struct_size, smbios_write_type0(¤t,
Paul Menzel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
Patch Set 1: Code-Review+1
Kyösti Mälkki has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
Patch Set 1: Code-Review+2
HAOUAS Elyes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
Patch Set 1: Code-Review+1
(1 comment)
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c File src/arch/x86/smbios.c:
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c@1153 PS1, Line 1153: ALIGN_UP missing include <commonlib/helpers.h> ?
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c File src/arch/x86/smbios.c:
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c@1153 PS1, Line 1153: ALIGN_UP
missing include <commonlib/helpers. […]
yeah, explicitly including that in this file would be a good idea. I'd suggest adding that in a separate round of patches on top of this series. do you want to do that?
HAOUAS Elyes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
Patch Set 1: Code-Review+2
(1 comment)
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c File src/arch/x86/smbios.c:
https://review.coreboot.org/#/c/33628/1/src/arch/x86/smbios.c@1153 PS1, Line 1153: ALIGN_UP
yeah, explicitly including that in this file would be a good idea. […]
it's fine for me
Felix Held has submitted this change and it was merged. ( https://review.coreboot.org/c/coreboot/+/33628 )
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability
ALIGN_UP is an alias for ALIGN.
Change-Id: Ie723ebe80f8f627021151413cb43adce6c88a0dc Signed-off-by: Felix Held felix-coreboot@felixheld.de Reviewed-on: https://review.coreboot.org/c/coreboot/+/33628 Reviewed-by: Paul Menzel paulepanter@users.sourceforge.net Reviewed-by: Kyösti Mälkki kyosti.malkki@gmail.com Reviewed-by: HAOUAS Elyes ehaouas@noos.fr Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M src/arch/x86/smbios.c 1 file changed, 2 insertions(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified Kyösti Mälkki: Looks good to me, approved Paul Menzel: Looks good to me, but someone else must approve HAOUAS Elyes: Looks good to me, approved
diff --git a/src/arch/x86/smbios.c b/src/arch/x86/smbios.c index 7865c7e..be09021 100644 --- a/src/arch/x86/smbios.c +++ b/src/arch/x86/smbios.c @@ -1150,12 +1150,12 @@ int max_struct_size = 0; int handle = 0;
- current = ALIGN(current, 16); + current = ALIGN_UP(current, 16); printk(BIOS_DEBUG, "%s: %08lx\n", __func__, current);
se = (struct smbios_entry *)current; current += sizeof(struct smbios_entry); - current = ALIGN(current, 16); + current = ALIGN_UP(current, 16);
tables = current; update_max(len, max_struct_size, smbios_write_type0(¤t,