Paul Kocialkowski (contact@paulk.fr) just uploaded a new patch set to gerrit, which you can find at http://review.coreboot.org/11498
-gerrit
commit d24592268b2d08fde103f6a09e21e7600bc7b93e Author: Paul Kocialkowski contact@paulk.fr Date: Thu Sep 3 11:44:56 2015 +0200
chromeos: vboot_common: Avoid code duplication when grabbing the handoff info
vboot_handoff_flag was duplicating the logic to grab the handoff info, that is already made available with vboot_get_handoff_info. This uses vboot_get_handoff_info in vboot_handoff_flag instead.
Change-Id: I28f1decce98f988f90c446a3a0dbe7409d714527 Signed-off-by: Paul Kocialkowski contact@paulk.fr --- src/vendorcode/google/chromeos/vboot_common.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/src/vendorcode/google/chromeos/vboot_common.c b/src/vendorcode/google/chromeos/vboot_common.c index 1c216d0..6184b0d 100644 --- a/src/vendorcode/google/chromeos/vboot_common.c +++ b/src/vendorcode/google/chromeos/vboot_common.c @@ -58,10 +58,9 @@ int vboot_get_handoff_info(void **addr, uint32_t *size) static int vboot_handoff_flag(uint32_t flag) { struct vboot_handoff *vbho; + uint32_t size;
- vbho = cbmem_find(CBMEM_ID_VBOOT_HANDOFF); - - if (vbho == NULL) + if (vboot_get_handoff_info((void **)&vbho, &size)) return 0;
return !!(vbho->init_params.out_flags & flag);