Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/29547 )
Change subject: security/vboot: Add measured boot mode ......................................................................
Patch Set 49:
(2 comments)
https://review.coreboot.org/#/c/29547/49/src/security/vboot/vboot_logic.c File src/security/vboot/vboot_logic.c:
https://review.coreboot.org/#/c/29547/49/src/security/vboot/vboot_logic.c@31... PS49, Line 319: if (IS_ENABLED(CONFIG_VBOOT_MEASURED_BOOT) && !vboot_platform_is_resuming()) {
I think it would be cleaner to just check the flag rather than calling platform_is_resuming() twice […]
Done
https://review.coreboot.org/#/c/29547/49/src/security/vboot/vboot_logic.c@35... PS49, Line 353: extend_pcrs(&ctx); /* ignore failures */
Why did you change all of these? I think the tab there was intentional to make it more readable.
clang-format. Now it's fused to everything. Auto linting will be soon the default.