Patrick Georgi has submitted this change. ( https://review.coreboot.org/c/coreboot/+/52133 )
Change subject: drivers/tpm/Kconfig: Rename TPM_INIT to TPM_INIT_RAMSTAGE ......................................................................
drivers/tpm/Kconfig: Rename TPM_INIT to TPM_INIT_RAMSTAGE
Rename the Kconfig parameter to more accurately reflect what it does. TPM can be initialised in a different stage too, for instance with VBOOT it is done in verstage.
Change-Id: Ic0126b356e8430c04c7c9fd46d4e20022a648738 Signed-off-by: Arthur Heymans arthur@aheymans.xyz Reviewed-on: https://review.coreboot.org/c/coreboot/+/52133 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Frans Hendriks fhendriks@eltan.com --- M src/drivers/tpm/Kconfig M src/drivers/tpm/Makefile.inc M src/mainboard/facebook/fbg1701/Kconfig 3 files changed, 3 insertions(+), 3 deletions(-)
Approvals: build bot (Jenkins): Verified Frans Hendriks: Looks good to me, approved
diff --git a/src/drivers/tpm/Kconfig b/src/drivers/tpm/Kconfig index d8a1e10..128f9bf 100644 --- a/src/drivers/tpm/Kconfig +++ b/src/drivers/tpm/Kconfig @@ -1,4 +1,4 @@ -config TPM_INIT +config TPM_INIT_RAMSTAGE bool default y if TPM1 || TPM2 depends on !VBOOT && !VENDORCODE_ELTAN_VBOOT && !VENDORCODE_ELTAN_MBOOT diff --git a/src/drivers/tpm/Makefile.inc b/src/drivers/tpm/Makefile.inc index af6e5a21..9833eb4 100644 --- a/src/drivers/tpm/Makefile.inc +++ b/src/drivers/tpm/Makefile.inc @@ -1,4 +1,4 @@ -ramstage-$(CONFIG_TPM_INIT) += tpm.c +ramstage-$(CONFIG_TPM_INIT_RAMSTAGE) += tpm.c
ifeq ($(CONFIG_TPM_PPI),y) ramstage-$(CONFIG_HAVE_ACPI_TABLES) += ppi.c diff --git a/src/mainboard/facebook/fbg1701/Kconfig b/src/mainboard/facebook/fbg1701/Kconfig index 1c47247..40cf8d9 100644 --- a/src/mainboard/facebook/fbg1701/Kconfig +++ b/src/mainboard/facebook/fbg1701/Kconfig @@ -87,7 +87,7 @@ bool default y
-config TPM_INIT +config TPM_INIT_RAMSTAGE bool "TPM Setup in RAMSTAGE" default n