Attention is currently required from: Sean Rhodes, Patrick Rudolph. Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/56252 )
Change subject: soc/skylake: Make VT-d controllable from CMOS option ......................................................................
Patch Set 6:
(2 comments)
File src/soc/intel/skylake/systemagent.c:
https://review.coreboot.org/c/coreboot/+/56252/comment/0bb69a29_88f76d6a PS6, Line 18: bool soc_is_vtd_capable(void) Could we rename this to make it clear that it does more now? e.g. `soc_vtd_enabled()`.
https://review.coreboot.org/c/coreboot/+/56252/comment/9d9de05b_48ac6b14 PS6, Line 23: (!vtd) & VTD_DISABLE) Isn't this part constant 0?
How about a simple bail-out on top if the user wants it disabled:
const unsigned int vtd = get_uint_option("vtd", 1); if (!vtd) return false;