Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45747 )
Change subject: soc/intel/tigerlake: Replace soc_get_pmc_mux_device with device pointers ......................................................................
Patch Set 2:
(4 comments)
and I just remembered we want the TCSS xhci ports, not the PCH xhci................ that'll be more tricky, b/c that ASL code is a beast... could keep the device definition in ASL and just add
https://review.coreboot.org/c/coreboot/+/45747/1/src/drivers/intel/xhci/xhci... File src/drivers/intel/xhci/xhci.c:
https://review.coreboot.org/c/coreboot/+/45747/1/src/drivers/intel/xhci/xhci... PS1, Line 7: id
usb_rev ?
much better
https://review.coreboot.org/c/coreboot/+/45747/1/src/drivers/intel/xhci/xhci... PS1, Line 23: 9
This buffer is too small to store the string
ha yep
https://review.coreboot.org/c/coreboot/+/45747/1/src/drivers/intel/xhci/xhci... PS1, Line 24: %2d
%2u
Done
https://review.coreboot.org/c/coreboot/+/45747/1/src/drivers/intel/xhci/xhci... PS1, Line 31: const struct drivers_intel_xhci_config *config = dev->chip_info;
nit: move this after the scope/name checks to safeguard against `dev` being null, or use `config_of( […]
Done