Attention is currently required from: Zhi7 Li. Karthik Ramasubramanian has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/56930 )
Change subject: mb/google/dedede/var/sasukette:Add fw_config probe for codec ALC5682I-VD & VS compatibility ......................................................................
Patch Set 8:
(1 comment)
File src/mainboard/google/dedede/variants/sasukette/ramstage.c:
https://review.coreboot.org/c/coreboot/+/56930/comment/083c7a32_7f0e3161 PS7, Line 14: const struct device_path codec_path[] = { : { .type = DEVICE_PATH_PCI, .pci.devfn = PCH_DEVFN_I2C4 }, : { .type = DEVICE_PATH_I2C, .i2c.device = 0x1a } : }; : const struct device *codec = find_dev_nested_path(pci_root_bus(), : codec_path, ARRAY_SIZE(codec_path)); : struct drivers_i2c_generic_config *config; : : if (!codec || (codec->chip_ops != &drivers_i2c_generic_ops) || !codec->chip_info) : return; : : config = codec->chip_info; : if (fw_config_probe(FW_CONFIG(AUDIO_CODEC_SOURCE, AUDIO_CODEC_ALC5682))) : config->hid = "10EC5682"; : else if (fw_config_probe(FW_CONFIG(AUDIO_CODEC_SOURCE, AUDIO_CODEC_ALC5682I_VS))) : config->hid = "RTL5682"; W.r.t CB:56804, move this to a separate function - eg. void audio_codec_update(void), so that the ext_vr can be added as another function.