Raul Rangel has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/50561 )
Change subject: include/acpi/acpi.h: Add ACPI_MADT_LAPIC_NMI_ALL_PROCESSORS ......................................................................
include/acpi/acpi.h: Add ACPI_MADT_LAPIC_NMI_ALL_PROCESSORS
This is a magic value that means all processors.
Signed-off-by: Raul E Rangel rrangel@chromium.org Change-Id: Ic2fc060fda21bec44258bcae62ddb230be542759 --- M src/include/acpi/acpi.h 1 file changed, 2 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/61/50561/1
diff --git a/src/include/acpi/acpi.h b/src/include/acpi/acpi.h index 058c0d0..775fc31 100644 --- a/src/include/acpi/acpi.h +++ b/src/include/acpi/acpi.h @@ -514,6 +514,8 @@ u8 lint; /* Local APIC LINT# */ } __packed acpi_madt_lapic_nmi_t;
+#define ACPI_MADT_LAPIC_NMI_ALL_PROCESSORS 0xff + /* MADT: I/O APIC Structure */ typedef struct acpi_madt_ioapic { u8 type; /* Type (1) */