Attention is currently required from: Martin L Roth.
ron minnich has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/80011?usp=email )
Change subject: arch/riscv: Reformat C files with clang-format v16 ......................................................................
Patch Set 1: Code-Review+2
(9 comments)
File src/arch/riscv/fit_payload.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/af7d959b_1fcecc70 : PS1, Line 31: printk(BIOS_INFO, "FIT: Leaving additional %u MiB of free space after kernel.\n", this improvement in readability could be further improved if we allowed reasonable line lengths <ducks>
File src/arch/riscv/misaligned.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/c01e9d0e_2911d233 : PS1, Line 150: if ((EXTRACT_FIELD(ins, 0x3) == 3) && (EXTRACT_FIELD(ins, 0x1c) != 0x7)) { this is great :-)
File src/arch/riscv/opensbi.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/8fedef19_3514f179 : PS1, Line 12: void run_opensbi(const int hart_id, const void *fdt, const void *opensbi, const void *payload, this is yuck, but, it's the line length we have, so ...
File src/arch/riscv/pmp.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/6bcfa2ac_095cedbb : PS1, Line 67: old = read_csr(pmpcfg0); YAY!
https://review.coreboot.org/c/coreboot/+/80011/comment/954b070f_ff9bf7a5 : PS1, Line 204: static pmpcfg_t generate_pmp_napot(uintptr_t base, uintptr_t size, uintptr_t flags) I'm in heaven here. Readable declarations!
https://review.coreboot.org/c/coreboot/+/80011/comment/f7519fc9_cad520aa : PS1, Line 274: die("Some PMP configurations are locked " yuck.
File src/arch/riscv/tables.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/3c3ca6eb_f3b0c25b : PS1, Line 15: bootmem_add_range((uintptr_t)_opensbi, REGION_SIZE(opensbi), BM_MEM_OPENSBI); nice.
File src/arch/riscv/trap_handler.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/4191be29_c2785383 : PS1, Line 36: case 0x00000000: meh.
File src/arch/riscv/virtual_memory.c:
https://review.coreboot.org/c/coreboot/+/80011/comment/4e445722_55478d26 : PS1, Line 16: static int delegate = 0 | (1 << CAUSE_MISALIGNED_FETCH) | (1 << CAUSE_FETCH_ACCESS) | this is a rare time that I'll confess to disliking the results of clangfmt. If you look on the left, it's super easy when debugging to comment out one mdeleg at a time. One the right, it's a real pain. But, I still feel that clangfmt is the right way to go, so I'll hold my nose and +2.