Aaron Durbin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/37940 )
Change subject: dram-spd: Remove free() ......................................................................
Patch Set 1:
(1 comment)
Patch Set 1:
I think some of the static analysis tools are using it for modelling life times. But perhaps we should rename our malloc to something else instead?
I'm not following. free() in this patch is just incorrect as the objects are allocated from bss section -- not malloc.
https://review.coreboot.org/c/coreboot/+/37940/1/src/vendorcode/cavium/bdk/l... File src/vendorcode/cavium/bdk/libdram/dram-spd.c:
https://review.coreboot.org/c/coreboot/+/37940/1/src/vendorcode/cavium/bdk/l... PS1, Line 63: static uint8_t spd_bufs[4 * 256]; /* FIXME(dhendrix): storage for SPD buffers, assume DDR4 */ This is where the allocation is coming from. Not malloc.