Hello Felix Singer, build bot (Jenkins), Nico Huber, Arthur Heymans, Michael Niewöhner, Patrick Rudolph,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/48346
to look at the new patch set (#5).
Change subject: azalia: Make `set_bits` function non-static ......................................................................
azalia: Make `set_bits` function non-static
There's many copies of this function in the tree. Make the copy in azalia_device.c non-static and rename it to `azalia_set_bits`, then replace all other copies with it. Since azalia_device.c is only built when AZALIA_PLUGIN_SUPPORT is selected, select it where necessary.
This has the side-effect of building hda_verb.c from the mainboard directory. If this patch happens to break audio on a mainboard, it's because its hda_verb.c was always wrong but wasn't being compiled.
Change-Id: Iff3520131ec7bc8554612969e3a2fe9cdbc9305e Signed-off-by: Angel Pons th3fanbus@gmail.com --- M src/device/azalia_device.c M src/include/device/azalia_device.h M src/soc/intel/common/Kconfig.common M src/soc/intel/common/hda_verb.c M src/southbridge/intel/bd82x6x/Kconfig M src/southbridge/intel/bd82x6x/azalia.c M src/southbridge/intel/i82801gx/Kconfig M src/southbridge/intel/i82801gx/azalia.c M src/southbridge/intel/i82801ix/Kconfig M src/southbridge/intel/i82801ix/azalia.c M src/southbridge/intel/i82801jx/Kconfig M src/southbridge/intel/i82801jx/azalia.c M src/southbridge/intel/ibexpeak/Kconfig M src/southbridge/intel/ibexpeak/azalia.c M src/southbridge/intel/lynxpoint/Kconfig M src/southbridge/intel/lynxpoint/hda_verb.c 16 files changed, 32 insertions(+), 213 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/46/48346/5