Angel Pons uploaded patch set #5 to this change.

View Change

azalia: Make `set_bits` function non-static

There's many copies of this function in the tree. Make the copy in
azalia_device.c non-static and rename it to `azalia_set_bits`, then
replace all other copies with it. Since azalia_device.c is only built
when AZALIA_PLUGIN_SUPPORT is selected, select it where necessary.

This has the side-effect of building hda_verb.c from the mainboard
directory. If this patch happens to break audio on a mainboard, it's
because its hda_verb.c was always wrong but wasn't being compiled.

Change-Id: Iff3520131ec7bc8554612969e3a2fe9cdbc9305e
Signed-off-by: Angel Pons <th3fanbus@gmail.com>
---
M src/device/azalia_device.c
M src/include/device/azalia_device.h
M src/soc/intel/common/Kconfig.common
M src/soc/intel/common/hda_verb.c
M src/southbridge/intel/bd82x6x/Kconfig
M src/southbridge/intel/bd82x6x/azalia.c
M src/southbridge/intel/i82801gx/Kconfig
M src/southbridge/intel/i82801gx/azalia.c
M src/southbridge/intel/i82801ix/Kconfig
M src/southbridge/intel/i82801ix/azalia.c
M src/southbridge/intel/i82801jx/Kconfig
M src/southbridge/intel/i82801jx/azalia.c
M src/southbridge/intel/ibexpeak/Kconfig
M src/southbridge/intel/ibexpeak/azalia.c
M src/southbridge/intel/lynxpoint/Kconfig
M src/southbridge/intel/lynxpoint/hda_verb.c
16 files changed, 32 insertions(+), 213 deletions(-)

git pull ssh://review.coreboot.org:29418/coreboot refs/changes/46/48346/5

To view, visit change 48346. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iff3520131ec7bc8554612969e3a2fe9cdbc9305e
Gerrit-Change-Number: 48346
Gerrit-PatchSet: 5
Gerrit-Owner: Angel Pons <th3fanbus@gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger@posteo.net>
Gerrit-Reviewer: Arthur Heymans <arthur@aheymans.xyz>
Gerrit-Reviewer: Michael Niewöhner <foss@mniewoehner.de>
Gerrit-Reviewer: Nico Huber <nico.h@gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro@das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply@coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter@users.sourceforge.net>
Gerrit-MessageType: newpatchset