Attention is currently required from: Angel Pons.
Maxim Polyakov has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/47595 )
Change subject: ec/kontron/kempld: Add minimal GPIO driver
......................................................................
Patch Set 13:
(2 comments)
Patchset:
PS13:
Hi! Thanks for the review again and sorry for the confusion with the "pin/pad" (I fixed this to use "pin" only).
File src/ec/kontron/kempld/kempld_internal.h:
https://review.coreboot.org/c/coreboot/+/47595/comment/a3daf0a2_0173e593
PS12, Line 31: #define KEMPLD_GPIO_MASK(x) (1 << ((x) % 8))
: #define KEMPLD_GPIO_DIR(pad_num) (0x40 + (pad_num) / 8)
: #define KEMPLD_GPIO_LVL(pad_num) (0x42 + (pad_num) / 8)
nit: Use the same name for the macro parameters, e.g. […]
Done
--
To view, visit
https://review.coreboot.org/c/coreboot/+/47595
To unsubscribe, or for help writing mail filters, visit
https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id767aa451fbf2ca1c0dccfc9aa2c024c6f37c1bb
Gerrit-Change-Number: 47595
Gerrit-PatchSet: 13
Gerrit-Owner: Maxim Polyakov
max.senia.poliak@gmail.com
Gerrit-Reviewer: Felix Singer
felixsinger@posteo.net
Gerrit-Reviewer: Angel Pons
th3fanbus@gmail.com
Gerrit-Reviewer: Martin Roth
martinroth@google.com
Gerrit-Reviewer: Nico Huber
nico.h@gmx.de
Gerrit-Reviewer: Patrick Georgi
pgeorgi@google.com
Gerrit-Reviewer: Werner Zeh
werner.zeh@siemens.com
Gerrit-Reviewer: build bot (Jenkins)
no-reply@coreboot.org
Gerrit-CC: Paul Menzel
paulepanter@mailbox.org
Gerrit-Attention: Angel Pons
th3fanbus@gmail.com
Gerrit-Comment-Date: Wed, 14 Jul 2021 14:56:50 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons
th3fanbus@gmail.com
Gerrit-MessageType: comment