Angel Pons has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/57046?usp=email )
Change subject: [RFC] PCI: Introduce `enable_mmconf()` function
......................................................................
Abandoned
No interest in pursuing this
--
To view, visit https://review.coreboot.org/c/coreboot/+/57046?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I3f573f1c0d9a4cc3c25fe907d12778cd5d93241d
Gerrit-Change-Number: 57046
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Tim Wawrzynczak <inforichland(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-MessageType: abandon
Angel Pons has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/70156?usp=email )
Change subject: [WIP] Make UartSub driver bind to LPSS UART
......................................................................
Abandoned
No interest in pursuing this
--
To view, visit https://review.coreboot.org/c/coreboot/+/70156?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I197ff2df2e4506994daa1ae72026b17ff662a9ab
Gerrit-Change-Number: 70156
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-MessageType: abandon
Attention is currently required from: Patrick Rudolph, Paul Menzel.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79784?usp=email )
The change is no longer submittable: All-Comments-Resolved is unsatisfied now.
Change subject: nb/intel/sandybridge/raminit: Set SRT on Sandy Bridge
......................................................................
Patch Set 3:
(1 comment)
File src/northbridge/intel/sandybridge/raminit_common.c:
https://review.coreboot.org/c/coreboot/+/79784/comment/82f25397_eb223d41 :
PS3, Line 784: if ((IS_IVY_CPU(ctrl->cpu) && ctrl->tCK >= TCK_1066MHZ) ||
: IS_SANDY_CPU(ctrl->cpu))
I believe the tCK check is to improve stability at high clock speeds. Sandy Bridge needs to be overclocked quite a bit to run at 1066 MHz (DDR3-2133), and it's likely it would benefit from SRT being disabled. So, we could simplify this check to `ctrl->tCK >= TCK_1066MHZ`.
--
To view, visit https://review.coreboot.org/c/coreboot/+/79784?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Id2773d3ae8c6c48193a23174086f62617335a7af
Gerrit-Change-Number: 79784
Gerrit-PatchSet: 3
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Thu, 11 Apr 2024 17:41:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Patrick Rudolph.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79783?usp=email )
Change subject: nb/intel/sandybridge/raminit: Set MR2 on per DIMM basis
......................................................................
Patch Set 3:
(2 comments)
File src/northbridge/intel/sandybridge/raminit_common.c:
https://review.coreboot.org/c/coreboot/+/79783/comment/b77d3cad_981550f8 :
PS3, Line 781: rank/2
nit: spacing around `/`
Also, for readability, an auxiliary constant would help:
```c
const int slot = rank / 2;
```
https://review.coreboot.org/c/coreboot/+/79783/comment/f06e4676_d9a48b18 :
PS3, Line 799: reg32 &= 1 << (rank / 2 + 14) | 1 << (rank / 2 + 6);
I don't think this should be changed. The code reads the MR2 shadow register, keeps the values of the other slot's bits, combines this with the MR2 contents, then adds the slot-specific bits, and finally writes back the updated value.
Right now, this would result in the bits for the first rank being cleared, which is bad (test with a DIMM that uses address mirroring on the first slot, and any other DIMM in the second slot of the same channel)
--
To view, visit https://review.coreboot.org/c/coreboot/+/79783?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ia60d1c01b79be2ac18ca6cc90109f817d1624c55
Gerrit-Change-Number: 79783
Gerrit-PatchSet: 3
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Comment-Date: Thu, 11 Apr 2024 17:36:50 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment